summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/maliit/maliit-framework-qt5/0001-Fix-QT_IM_PLUGIN_PATH-to-allow-openembedded-to-build.patch34
-rw-r--r--recipes-qt/maliit/maliit-framework-qt5/0001-Link-to-libmaliit-1-0-in-inputcontext-plugin.patch23
-rw-r--r--recipes-qt/maliit/maliit-framework-qt5/qt5.3-fix.patch43
-rw-r--r--recipes-qt/maliit/maliit-framework-qt5_git.bb1
4 files changed, 44 insertions, 57 deletions
diff --git a/recipes-qt/maliit/maliit-framework-qt5/0001-Fix-QT_IM_PLUGIN_PATH-to-allow-openembedded-to-build.patch b/recipes-qt/maliit/maliit-framework-qt5/0001-Fix-QT_IM_PLUGIN_PATH-to-allow-openembedded-to-build.patch
deleted file mode 100644
index 830e6deb..00000000
--- a/recipes-qt/maliit/maliit-framework-qt5/0001-Fix-QT_IM_PLUGIN_PATH-to-allow-openembedded-to-build.patch
+++ /dev/null
@@ -1,34 +0,0 @@
1From fb6acbd2af9ed288c1c4f4200fc73d8d9955486a Mon Sep 17 00:00:00 2001
2From: Samuel Stirtzel <s.stirtzel@googlemail.com>
3Date: Wed, 1 Aug 2012 13:33:10 +0200
4Subject: [PATCH] Fix QT_IM_PLUGIN_PATH to allow openembedded to build Maliit
5
6Upstream-Status: Inappropriate [configuration]
7
8Signed-off-by: Samuel Stirtzel <s.stirtzel@googlemail.com>
9---
10 input-context/input-context.pri | 10 ++++++----
11 1 file changed, 6 insertions(+), 4 deletions(-)
12
13diff --git a/input-context/input-context.pri b/input-context/input-context.pri
14index d94e6a3..d460e70 100644
15--- a/input-context/input-context.pri
16+++ b/input-context/input-context.pri
17@@ -25,8 +25,10 @@ for(OPTION,$$list($$lower($$COV_OPTION))){
18
19 QMAKE_CLEAN += $$OBJECTS_DIR/*.gcno $$OBJECTS_DIR/*.gcda
20
21-QT_IM_PLUGIN_PATH = $$[QT_INSTALL_PLUGINS]/inputmethods
22-QT_PREFIX = $$[QT_INSTALL_PREFIX]
23-local-install {
24- QT_IM_PLUGIN_PATH = $$replace(QT_IM_PLUGIN_PATH, $$QT_PREFIX, $$PREFIX)
25+isEmpty(QT_IM_PLUGIN_PATH) {
26+ QT_IM_PLUGIN_PATH = $$[QT_INSTALL_PLUGINS]/inputmethods
27+ QT_PREFIX = $$[QT_INSTALL_PREFIX]
28+ local-install {
29+ QT_IM_PLUGIN_PATH = $$replace(QT_IM_PLUGIN_PATH, $$QT_PREFIX, $$PREFIX)
30+ }
31 }
32--
331.7.9.5
34
diff --git a/recipes-qt/maliit/maliit-framework-qt5/0001-Link-to-libmaliit-1-0-in-inputcontext-plugin.patch b/recipes-qt/maliit/maliit-framework-qt5/0001-Link-to-libmaliit-1-0-in-inputcontext-plugin.patch
deleted file mode 100644
index c2291c6b..00000000
--- a/recipes-qt/maliit/maliit-framework-qt5/0001-Link-to-libmaliit-1-0-in-inputcontext-plugin.patch
+++ /dev/null
@@ -1,23 +0,0 @@
1From cc33efdedbec9e9a55e9a0c6756516fd84d42e53 Mon Sep 17 00:00:00 2001
2From: Samuel Stirtzel <s.stirtzel@googlemail.com>
3Date: Fri, 1 Mar 2013 11:31:41 +0100
4Subject: [PATCH] Link to libmaliit-1,0 in inputcontext plugin
5
6Signed-off-by: Samuel Stirtzel <s.stirtzel@googlemail.com>
7---
8 .../input-context-plugin/input-context-plugin.pro | 2 ++
9 1 file changed, 2 insertions(+)
10
11diff --git a/input-context/input-context-plugin/input-context-plugin.pro b/input-context/input-context-plugin/input-context-plugin.pro
12index eefbe93..296e2fa 100644
13--- a/input-context/input-context-plugin/input-context-plugin.pro
14+++ b/input-context/input-context-plugin/input-context-plugin.pro
15@@ -15,3 +15,5 @@ CONFIG += plugin
16
17 INSTALLS += target
18 target.path += $$QT_IM_PLUGIN_PATH
19+
20+LIBS += -L../../lib -l"maliit-1.0"
21--
221.7.9.5
23
diff --git a/recipes-qt/maliit/maliit-framework-qt5/qt5.3-fix.patch b/recipes-qt/maliit/maliit-framework-qt5/qt5.3-fix.patch
new file mode 100644
index 00000000..4f8890f3
--- /dev/null
+++ b/recipes-qt/maliit/maliit-framework-qt5/qt5.3-fix.patch
@@ -0,0 +1,43 @@
1Fix compatibility with qt-5.3
2
3https://bugs.launchpad.net/ubuntu/+source/maliit-framework/+bug/1323962
4
5Upstream-Status: Pending
6
7diff --git a/src/maliit/plugins/updateevent.cpp b/src/maliit/plugins/updateevent.cpp
8index 06a5228..85b7166 100644
9--- a/src/maliit/plugins/updateevent.cpp
10+++ b/src/maliit/plugins/updateevent.cpp
11@@ -38,7 +38,7 @@ bool MImUpdateEventPrivate::isFlagSet(Qt::InputMethodHint hint,
12 bool result = false;
13
14 if (update.contains(Maliit::Internal::inputMethodHints)) {
15- const Qt::InputMethodHints hints(static_cast<Qt::InputMethodHints>(
16+ const Qt::InputMethodHints hints(static_cast<int>(
17 update.value(Maliit::Internal::inputMethodHints).toLongLong()));
18
19 result = (hints & hint);
20@@ -89,8 +89,8 @@ QStringList MImUpdateEvent::propertiesChanged() const
21 Qt::InputMethodHints MImUpdateEvent::hints(bool *changed) const
22 {
23 Q_D(const MImUpdateEvent);
24- return static_cast<Qt::InputMethodHints>(
25- d->extractProperty(Maliit::Internal::inputMethodHints, changed).toLongLong());
26+ return Qt::InputMethodHints(static_cast<int>(
27+ d->extractProperty(Maliit::Internal::inputMethodHints, changed).toLongLong()));
28 }
29
30 bool MImUpdateEvent::westernNumericInputEnforced(bool *changed) const
31diff --git a/src/mimpluginmanager.cpp b/src/mimpluginmanager.cpp
32index 02788a4..3c5c99a 100644
33--- a/src/mimpluginmanager.cpp
34+++ b/src/mimpluginmanager.cpp
35@@ -1493,7 +1493,7 @@ void MIMPluginManager::handleWidgetStateChanged(unsigned int clientId,
36 }
37 }
38
39- const Qt::InputMethodHints lastHints = static_cast<Qt::InputMethodHints>(newState.value(Maliit::Internal::inputMethodHints).toLongLong());
40+ const Qt::InputMethodHints lastHints(static_cast<int>(newState.value(Maliit::Internal::inputMethodHints).toLongLong()));
41 MImUpdateEvent ev(newState, changedProperties, lastHints);
42
43 // general notification last
diff --git a/recipes-qt/maliit/maliit-framework-qt5_git.bb b/recipes-qt/maliit/maliit-framework-qt5_git.bb
index 633bf6e4..3ef56ec8 100644
--- a/recipes-qt/maliit/maliit-framework-qt5_git.bb
+++ b/recipes-qt/maliit/maliit-framework-qt5_git.bb
@@ -9,6 +9,7 @@ inherit qmake5
9SRC_URI = "git://github.com/maliit/framework.git;branch=master \ 9SRC_URI = "git://github.com/maliit/framework.git;branch=master \
10 file://0001-Fix-MALIIT_INSTALL_PRF-to-allow-the-build-with-opene.patch \ 10 file://0001-Fix-MALIIT_INSTALL_PRF-to-allow-the-build-with-opene.patch \
11 file://maliit-server.desktop \ 11 file://maliit-server.desktop \
12 file://qt5.3-fix.patch \
12" 13"
13 14
14SRCREV = "dbc0403f329d7f6ce2f5a09e6ff5adbd2548a8c9" 15SRCREV = "dbc0403f329d7f6ce2f5a09e6ff5adbd2548a8c9"