diff options
-rw-r--r-- | recipes-qt/qt5/qtwayland_git.bb | 17 |
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb index 28dd2be8..f85fe356 100644 --- a/recipes-qt/qt5/qtwayland_git.bb +++ b/recipes-qt/qt5/qtwayland_git.bb | |||
@@ -44,3 +44,20 @@ BBCLASSEXTEND =+ "native nativesdk" | |||
44 | # The same issue as in qtbase: | 44 | # The same issue as in qtbase: |
45 | # http://errors.yoctoproject.org/Errors/Details/152641/ | 45 | # http://errors.yoctoproject.org/Errors/Details/152641/ |
46 | LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}" | 46 | LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}" |
47 | |||
48 | # Since version 5.11.2 some private headers are not installed. Work around | ||
49 | # until fixed upstream. See https://bugreports.qt.io/browse/QTBUG-71340 for | ||
50 | # further details | ||
51 | do_install_append() { | ||
52 | if [ -d "${B}/src/client" ]; then | ||
53 | upstream_pv=`echo "${PV}" | sed 's:+git.*::g'` | ||
54 | for header in `find ${B}/src/client -name '*wayland-*.h'`; do | ||
55 | header_base=`basename $header` | ||
56 | dest="${D}${includedir}/QtWaylandClient/$upstream_pv/QtWaylandClient/private/$header_base" | ||
57 | if [ ! -e "$dest" ]; then | ||
58 | echo "Manual install: $header_base to $dest" | ||
59 | install -m 644 "$header" "$dest" | ||
60 | fi | ||
61 | done | ||
62 | fi | ||
63 | } | ||