diff options
-rw-r--r-- | recipes-qt/qt5/qtwebkit/0001-Fix-build-with-non-glibc-libc-on-musl.patch | 69 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwebkit_git.bb | 5 |
2 files changed, 73 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtwebkit/0001-Fix-build-with-non-glibc-libc-on-musl.patch b/recipes-qt/qt5/qtwebkit/0001-Fix-build-with-non-glibc-libc-on-musl.patch new file mode 100644 index 00000000..5cd604e5 --- /dev/null +++ b/recipes-qt/qt5/qtwebkit/0001-Fix-build-with-non-glibc-libc-on-musl.patch | |||
@@ -0,0 +1,69 @@ | |||
1 | From 356ef55b985d8d874f2358b937d396bea52ebff6 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 23 Aug 2018 04:06:17 +0000 | ||
4 | Subject: [PATCH] Fix build with non-glibc libc on musl | ||
5 | |||
6 | Need to ensure glibc features are not assumed to be linux-wide | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | Source/JavaScriptCore/heap/MachineStackMarker.cpp | 8 ++++---- | ||
12 | .../inspector/JSGlobalObjectInspectorController.cpp | 2 ++ | ||
13 | 2 files changed, 6 insertions(+), 4 deletions(-) | ||
14 | |||
15 | diff --git a/Source/JavaScriptCore/heap/MachineStackMarker.cpp b/Source/JavaScriptCore/heap/MachineStackMarker.cpp | ||
16 | index 883914f..ce4e8d3 100644 | ||
17 | --- a/Source/JavaScriptCore/heap/MachineStackMarker.cpp | ||
18 | +++ b/Source/JavaScriptCore/heap/MachineStackMarker.cpp | ||
19 | @@ -566,7 +566,7 @@ void* MachineThreads::Thread::Registers::stackPointer() const | ||
20 | #error Unknown Architecture | ||
21 | #endif | ||
22 | |||
23 | -#elif defined(__GLIBC__) && ENABLE(JIT) | ||
24 | +#elif defined(__linux__) && ENABLE(JIT) | ||
25 | |||
26 | #if CPU(X86) | ||
27 | return reinterpret_cast<void*>((uintptr_t) regs.machineContext.gregs[REG_ESP]); | ||
28 | @@ -665,7 +665,7 @@ void* MachineThreads::Thread::Registers::framePointer() const | ||
29 | #error Unknown Architecture | ||
30 | #endif | ||
31 | |||
32 | -#elif defined(__GLIBC__) | ||
33 | +#elif defined(__linux__) | ||
34 | |||
35 | // The following sequence depends on glibc's sys/ucontext.h. | ||
36 | #if CPU(X86) | ||
37 | @@ -747,7 +747,7 @@ void* MachineThreads::Thread::Registers::instructionPointer() const | ||
38 | #error Unknown Architecture | ||
39 | #endif | ||
40 | |||
41 | -#elif defined(__GLIBC__) | ||
42 | +#elif defined(__linux__) | ||
43 | |||
44 | // The following sequence depends on glibc's sys/ucontext.h. | ||
45 | #if CPU(X86) | ||
46 | @@ -838,7 +838,7 @@ void* MachineThreads::Thread::Registers::llintPC() const | ||
47 | #error Unknown Architecture | ||
48 | #endif | ||
49 | |||
50 | -#elif defined(__GLIBC__) | ||
51 | +#elif defined(__linux__) | ||
52 | |||
53 | // The following sequence depends on glibc's sys/ucontext.h. | ||
54 | #if CPU(X86) | ||
55 | diff --git a/Source/JavaScriptCore/inspector/JSGlobalObjectInspectorController.cpp b/Source/JavaScriptCore/inspector/JSGlobalObjectInspectorController.cpp | ||
56 | index fd7f869..e95391b 100644 | ||
57 | --- a/Source/JavaScriptCore/inspector/JSGlobalObjectInspectorController.cpp | ||
58 | +++ b/Source/JavaScriptCore/inspector/JSGlobalObjectInspectorController.cpp | ||
59 | @@ -51,8 +51,10 @@ | ||
60 | #include <cxxabi.h> | ||
61 | #if OS(DARWIN) || (OS(LINUX) && !PLATFORM(GTK)) | ||
62 | #include <dlfcn.h> | ||
63 | +#if defined(__GLIBC__) | ||
64 | #include <execinfo.h> | ||
65 | #endif | ||
66 | +#endif | ||
67 | |||
68 | #if ENABLE(REMOTE_INSPECTOR) | ||
69 | #include "JSGlobalObjectDebuggable.h" | ||
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb index a7dad987..ca2d2156 100644 --- a/recipes-qt/qt5/qtwebkit_git.bb +++ b/recipes-qt/qt5/qtwebkit_git.bb | |||
@@ -1,7 +1,10 @@ | |||
1 | require qt5.inc | 1 | require qt5.inc |
2 | require qt5-git.inc | 2 | require qt5-git.inc |
3 | 3 | ||
4 | SRC_URI += "file://0001-Do-not-skip-build-for-cross-compile.patch" | 4 | SRC_URI += "\ |
5 | file://0001-Do-not-skip-build-for-cross-compile.patch \ | ||
6 | file://0001-Fix-build-with-non-glibc-libc-on-musl.patch \ | ||
7 | " | ||
5 | 8 | ||
6 | LICENSE = "BSD & LGPLv2+ | GPL-2.0" | 9 | LICENSE = "BSD & LGPLv2+ | GPL-2.0" |
7 | LIC_FILES_CHKSUM = " \ | 10 | LIC_FILES_CHKSUM = " \ |