diff options
-rw-r--r-- | recipes-qt/qt5/qt5-creator/0002-clangformat-Fix-build-with-LLVM-12.patch | 45 | ||||
-rw-r--r-- | recipes-qt/qt5/qt5-creator_git.bb | 7 |
2 files changed, 3 insertions, 49 deletions
diff --git a/recipes-qt/qt5/qt5-creator/0002-clangformat-Fix-build-with-LLVM-12.patch b/recipes-qt/qt5/qt5-creator/0002-clangformat-Fix-build-with-LLVM-12.patch deleted file mode 100644 index e204d5e6..00000000 --- a/recipes-qt/qt5/qt5-creator/0002-clangformat-Fix-build-with-LLVM-12.patch +++ /dev/null | |||
@@ -1,45 +0,0 @@ | |||
1 | From 25e7b2c5d608f71aba694224e5160fc430731b6a Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Bj=C3=B6rn=20Sch=C3=A4pers?= <bjoern@hazardy.de> | ||
3 | Date: Fri, 29 Jan 2021 18:01:37 +0100 | ||
4 | Subject: [PATCH] clangformat: Fix build with LLVM 12 | ||
5 | |||
6 | Change-Id: I493afce92b16291cf66fc510129f2154a7162847 | ||
7 | Reviewed-by: David Schulz <david.schulz@qt.io> | ||
8 | |||
9 | Fixes: | ||
10 | | ../../../../git/src/plugins/clangformat/clangformatutils.cpp: In function 'clang::format::FormatStyle ClangFormat::qtcStyle()': | ||
11 | | ../../../../git/src/plugins/clangformat/clangformatutils.cpp:54:41: error: cannot convert 'bool' to 'clang::format::FormatStyle::AlignConsecutiveStyle' in assignment | ||
12 | | 54 | style.AlignConsecutiveAssignments = false; | ||
13 | | | ^~~~~ | ||
14 | | ../../../../git/src/plugins/clangformat/clangformatutils.cpp:55:42: error: cannot convert 'bool' to 'clang::format::FormatStyle::AlignConsecutiveStyle' in assignment | ||
15 | | 55 | style.AlignConsecutiveDeclarations = false; | ||
16 | | | ^~~~~ | ||
17 | |||
18 | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> | ||
19 | |||
20 | Upstream-Status: Backport | ||
21 | --- | ||
22 | src/plugins/clangformat/clangformatutils.cpp | 5 +++++ | ||
23 | 1 file changed, 5 insertions(+) | ||
24 | |||
25 | diff --git a/src/plugins/clangformat/clangformatutils.cpp b/src/plugins/clangformat/clangformatutils.cpp | ||
26 | index 8e11c15364..a249327d0e 100644 | ||
27 | --- a/src/plugins/clangformat/clangformatutils.cpp | ||
28 | +++ b/src/plugins/clangformat/clangformatutils.cpp | ||
29 | @@ -51,8 +51,13 @@ static clang::format::FormatStyle qtcStyle() | ||
30 | style.Language = FormatStyle::LK_Cpp; | ||
31 | style.AccessModifierOffset = -4; | ||
32 | style.AlignAfterOpenBracket = FormatStyle::BAS_Align; | ||
33 | +#if LLVM_VERSION_MAJOR >= 12 | ||
34 | + style.AlignConsecutiveAssignments = FormatStyle::ACS_None; | ||
35 | + style.AlignConsecutiveDeclarations = FormatStyle::ACS_None; | ||
36 | +#else | ||
37 | style.AlignConsecutiveAssignments = false; | ||
38 | style.AlignConsecutiveDeclarations = false; | ||
39 | +#endif | ||
40 | style.AlignEscapedNewlines = FormatStyle::ENAS_DontAlign; | ||
41 | #if LLVM_VERSION_MAJOR >= 11 | ||
42 | style.AlignOperands = FormatStyle::OAS_Align; | ||
43 | -- | ||
44 | 2.30.2 | ||
45 | |||
diff --git a/recipes-qt/qt5/qt5-creator_git.bb b/recipes-qt/qt5/qt5-creator_git.bb index 1a12862e..95873381 100644 --- a/recipes-qt/qt5/qt5-creator_git.bb +++ b/recipes-qt/qt5/qt5-creator_git.bb | |||
@@ -17,14 +17,13 @@ inherit qmake5 mime-xdg | |||
17 | DEPENDS += "qtbase qtscript qtxmlpatterns qtx11extras qtdeclarative qttools qttools-native qtsvg chrpath-replacement-native zlib" | 17 | DEPENDS += "qtbase qtscript qtxmlpatterns qtx11extras qtdeclarative qttools qttools-native qtsvg chrpath-replacement-native zlib" |
18 | DEPENDS_append_libc-musl = " libexecinfo" | 18 | DEPENDS_append_libc-musl = " libexecinfo" |
19 | 19 | ||
20 | SRCREV = "c34b9502275d0d1d5b88d7a63bff076e2a164836" | 20 | SRCREV = "978f6caf1e18ad0b0415fde60a8c130448969c6d" |
21 | PV = "4.14.2+git${SRCPV}" | 21 | PV = "4.15.0+git${SRCPV}" |
22 | # Patches from https://github.com/meta-qt5/qtcreator/commits/b4.9.2 | 22 | # Patches from https://github.com/meta-qt5/qtcreator/commits/b4.9.2 |
23 | # 4.9.2.meta-qt5.1 | 23 | # 4.9.2.meta-qt5.1 |
24 | SRC_URI = " \ | 24 | SRC_URI = " \ |
25 | git://code.qt.io/qt-creator/qt-creator.git;branch=4.14 \ | 25 | git://code.qt.io/qt-creator/qt-creator.git;branch=4.15 \ |
26 | file://0001-app-Use-malloc_trim-only-on-glibc.patch \ | 26 | file://0001-app-Use-malloc_trim-only-on-glibc.patch \ |
27 | file://0002-clangformat-Fix-build-with-LLVM-12.patch \ | ||
28 | " | 27 | " |
29 | SRC_URI_append_libc-musl = " file://0001-Link-with-libexecinfo-on-musl.patch" | 28 | SRC_URI_append_libc-musl = " file://0001-Link-with-libexecinfo-on-musl.patch" |
30 | 29 | ||