summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/examples/cinematicexperience/fix_qt5_3_compatibility.patch48
-rw-r--r--recipes-qt/examples/cinematicexperience_1.0.bb1
2 files changed, 49 insertions, 0 deletions
diff --git a/recipes-qt/examples/cinematicexperience/fix_qt5_3_compatibility.patch b/recipes-qt/examples/cinematicexperience/fix_qt5_3_compatibility.patch
new file mode 100644
index 00000000..fc132ecc
--- /dev/null
+++ b/recipes-qt/examples/cinematicexperience/fix_qt5_3_compatibility.patch
@@ -0,0 +1,48 @@
1Index: Qt5_CinematicExperience_rpi_1.0/content/SettingsView.qml
2===================================================================
3--- Qt5_CinematicExperience_rpi_1.0.orig/content/SettingsView.qml
4+++ Qt5_CinematicExperience_rpi_1.0/content/SettingsView.qml
5@@ -127,8 +127,8 @@ Item {
6 Switch {
7 text: "Do you l-o-v-e colors?"
8 checked: settings.showColors
9- onText: "Yes"
10- offText: "No!"
11+ textON: "Yes"
12+ textOFF: "No!"
13 onCheckedChanged: {
14 settings.showColors = checked;
15 }
16Index: Qt5_CinematicExperience_rpi_1.0/content/Switch.qml
17===================================================================
18--- Qt5_CinematicExperience_rpi_1.0.orig/content/Switch.qml
19+++ Qt5_CinematicExperience_rpi_1.0/content/Switch.qml
20@@ -6,8 +6,8 @@ Item {
21
22 property alias text: textItem.text
23 property bool checked: false
24- property string onText: "On"
25- property string offText: "Off"
26+ property string textON: "On"
27+ property string textOFF: "Off"
28
29 QtObject {
30 id: priv
31@@ -120,7 +120,7 @@ Item {
32 color: "#000000"
33 font.pixelSize: 18
34 font.bold: true
35- text: onText
36+ text: textON
37 }
38 Text {
39 anchors.verticalCenter: parent.verticalCenter
40@@ -129,7 +129,7 @@ Item {
41 color: "#ffffff"
42 font.pixelSize: 18
43 font.bold: true
44- text: offText
45+ text: textOFF
46 }
47
48 Image {
diff --git a/recipes-qt/examples/cinematicexperience_1.0.bb b/recipes-qt/examples/cinematicexperience_1.0.bb
index 9ee55323..116127fc 100644
--- a/recipes-qt/examples/cinematicexperience_1.0.bb
+++ b/recipes-qt/examples/cinematicexperience_1.0.bb
@@ -5,6 +5,7 @@ LICENSE = "CC-BY-3.0"
5LIC_FILES_CHKSUM = "file://README;beginline=38;endline=50;md5=51babd597624b70752069953876aaa18" 5LIC_FILES_CHKSUM = "file://README;beginline=38;endline=50;md5=51babd597624b70752069953876aaa18"
6 6
7SRC_URI = "http://quitcoding.com/download/Qt5_CinematicExperience_rpi_1.0.tgz" 7SRC_URI = "http://quitcoding.com/download/Qt5_CinematicExperience_rpi_1.0.tgz"
8SRC_URI += "file://fix_qt5_3_compatibility.patch"
8 9
9SRC_URI[md5sum] = "935a5db0a6b2a72c67236e72f52be7d1" 10SRC_URI[md5sum] = "935a5db0a6b2a72c67236e72f52be7d1"
10SRC_URI[sha256sum] = "0dd602983ced5f7c0cfd5ad0fbfe2b0b7e3c9ff715e4ef23eef818ccc2b6c60b" 11SRC_URI[sha256sum] = "0dd602983ced5f7c0cfd5ad0fbfe2b0b7e3c9ff715e4ef23eef818ccc2b6c60b"