diff options
-rw-r--r-- | recipes-qt/qt5/qtwebkit-examples/0001-Fix-build-with-qt-5.11.patch | 48 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwebkit-examples_git.bb | 24 |
2 files changed, 0 insertions, 72 deletions
diff --git a/recipes-qt/qt5/qtwebkit-examples/0001-Fix-build-with-qt-5.11.patch b/recipes-qt/qt5/qtwebkit-examples/0001-Fix-build-with-qt-5.11.patch deleted file mode 100644 index 57e318b0..00000000 --- a/recipes-qt/qt5/qtwebkit-examples/0001-Fix-build-with-qt-5.11.patch +++ /dev/null | |||
@@ -1,48 +0,0 @@ | |||
1 | From e07f1fcba5a291ef0ab31fd85fbc4836eda19a66 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 24 Sep 2018 03:14:29 -0700 | ||
4 | Subject: [PATCH] Fix build with qt 5.11 | ||
5 | |||
6 | Fixes | ||
7 | |||
8 | examples/webkitwidgets/scroller/wheel/main.cpp:93:84: error: cannot call | ||
9 | member function 'int QRandomGenerator::bounded(int)' without object | ||
10 | m_wheel1->scrollTo(m_wheel1->currentIndex() + | ||
11 | QRandomGenerator::bounded(200)); | ||
12 | |||
13 | Upstream-Status: Pending | ||
14 | |||
15 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
16 | --- | ||
17 | examples/webkitwidgets/scroller/wheel/main.cpp | 8 ++++---- | ||
18 | 1 file changed, 4 insertions(+), 4 deletions(-) | ||
19 | |||
20 | diff --git a/examples/webkitwidgets/scroller/wheel/main.cpp b/examples/webkitwidgets/scroller/wheel/main.cpp | ||
21 | index 11fad08..9a6a225 100644 | ||
22 | --- a/examples/webkitwidgets/scroller/wheel/main.cpp | ||
23 | +++ b/examples/webkitwidgets/scroller/wheel/main.cpp | ||
24 | @@ -40,7 +40,7 @@ | ||
25 | |||
26 | #include <QtWidgets> | ||
27 | #include <qmath.h> | ||
28 | - | ||
29 | +#include <QRandomGenerator> | ||
30 | #include "wheelwidget.h" | ||
31 | |||
32 | class MainWindow : public QMainWindow | ||
33 | @@ -90,9 +90,9 @@ public: | ||
34 | private slots: | ||
35 | void rotateRandom() | ||
36 | { | ||
37 | - m_wheel1->scrollTo(m_wheel1->currentIndex() + QRandomGenerator::bounded(200)); | ||
38 | - m_wheel2->scrollTo(m_wheel2->currentIndex() + QRandomGenerator::bounded(200)); | ||
39 | - m_wheel3->scrollTo(m_wheel3->currentIndex() + QRandomGenerator::bounded(200)); | ||
40 | + m_wheel1->scrollTo(m_wheel1->currentIndex() + QRandomGenerator::global()->bounded(200)); | ||
41 | + m_wheel2->scrollTo(m_wheel2->currentIndex() + QRandomGenerator::global()->bounded(200)); | ||
42 | + m_wheel3->scrollTo(m_wheel3->currentIndex() + QRandomGenerator::global()->bounded(200)); | ||
43 | } | ||
44 | |||
45 | private: | ||
46 | -- | ||
47 | 2.19.0 | ||
48 | |||
diff --git a/recipes-qt/qt5/qtwebkit-examples_git.bb b/recipes-qt/qt5/qtwebkit-examples_git.bb deleted file mode 100644 index 4b635bdf..00000000 --- a/recipes-qt/qt5/qtwebkit-examples_git.bb +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | require qt5.inc | ||
2 | require qt5-git.inc | ||
3 | |||
4 | LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )" | ||
5 | LIC_FILES_CHKSUM = " \ | ||
6 | file://LICENSE.GPLv2;md5=05832301944453ec79e40ba3c3cfceec \ | ||
7 | file://LICENSE.LGPLv21;md5=58a180e1cf84c756c29f782b3a485c29 \ | ||
8 | file://LICENSE.LGPLv3;md5=b8c75190712063cde04e1f41b6fdad98 \ | ||
9 | file://LICENSE.GPLv3;md5=40f9bf30e783ddc201497165dfb32afb \ | ||
10 | file://examples/webkitwidgets/scroller/wheel/main.cpp;endline=39;md5=b0739af76072fbe303dc04b6941e054f \ | ||
11 | file://examples/webkitwidgets/imageanalyzer/imageanalyzer.cpp;endline=39;md5=b0739af76072fbe303dc04b6941e054f \ | ||
12 | " | ||
13 | |||
14 | SRC_URI += "file://0001-Fix-build-with-qt-5.11.patch" | ||
15 | |||
16 | PACKAGECONFIG ?= "examples" | ||
17 | |||
18 | DEPENDS += "qtwebkit qtxmlpatterns" | ||
19 | RDEPENDS_${PN}-examples += "qtwebkit-qmlplugins" | ||
20 | RDEPENDS_${PN}-examples += "${@bb.utils.contains('PACKAGECONFIG_OPENSSL', 'openssl', 'ca-certificates', '', d)}" | ||
21 | |||
22 | QT_MODULE_BRANCH = "dev" | ||
23 | |||
24 | SRCREV = "2d68492004bf4ba49cf58c9bd72706cb282cf59b" | ||