diff options
-rw-r--r-- | conf/layer.conf | 2 | ||||
-rw-r--r-- | recipes-qt/examples/qt5everywheredemo_1.0.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/nativesdk-qtbase_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qt5-git.inc | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase-native_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase_git.bb | 2 |
6 files changed, 7 insertions, 5 deletions
diff --git a/conf/layer.conf b/conf/layer.conf index aacfd784..92558b33 100644 --- a/conf/layer.conf +++ b/conf/layer.conf | |||
@@ -26,3 +26,5 @@ BBFILE_PRIORITY_qt5-layer = "7" | |||
26 | LICENSE_PATH += "${LAYERDIR}/licenses" | 26 | LICENSE_PATH += "${LAYERDIR}/licenses" |
27 | 27 | ||
28 | IMAGE_FEATURES[validitems] += "qtcreator-debug" | 28 | IMAGE_FEATURES[validitems] += "qtcreator-debug" |
29 | |||
30 | QT_GIT ?= "git://code.qt.io" | ||
diff --git a/recipes-qt/examples/qt5everywheredemo_1.0.bb b/recipes-qt/examples/qt5everywheredemo_1.0.bb index db5bbe6a..0546b00c 100644 --- a/recipes-qt/examples/qt5everywheredemo_1.0.bb +++ b/recipes-qt/examples/qt5everywheredemo_1.0.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://main.cpp;md5=1187cb795a0f96bce64e63dd1a67dc2b" | |||
7 | DEPENDS = "qtdeclarative qtgraphicaleffects" | 7 | DEPENDS = "qtdeclarative qtgraphicaleffects" |
8 | 8 | ||
9 | SRCREV = "c17fe9e0ec0882ac4c4dc1168095f569acab5d09" | 9 | SRCREV = "c17fe9e0ec0882ac4c4dc1168095f569acab5d09" |
10 | SRC_URI = "git://code.qt.io/qt-labs/qt5-everywhere-demo.git" | 10 | SRC_URI = "${QT_GIT}/qt-labs/qt5-everywhere-demo.git" |
11 | 11 | ||
12 | S = "${WORKDIR}/git/QtDemo" | 12 | S = "${WORKDIR}/git/QtDemo" |
13 | 13 | ||
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb index df80407e..9832eee4 100644 --- a/recipes-qt/qt5/nativesdk-qtbase_git.bb +++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb | |||
@@ -5,7 +5,7 @@ require ${PN}.inc | |||
5 | FILESEXTRAPATHS =. "${FILE_DIRNAME}/${BPN}-git:" | 5 | FILESEXTRAPATHS =. "${FILE_DIRNAME}/${BPN}-git:" |
6 | 6 | ||
7 | SRC_URI = "\ | 7 | SRC_URI = "\ |
8 | git://code.qt.io/qt/${QT_MODULE}.git;branch=${QT_MODULE_BRANCH} \ | 8 | ${QT_GIT}/qt/${QT_MODULE}.git;branch=${QT_MODULE_BRANCH} \ |
9 | " | 9 | " |
10 | 10 | ||
11 | # common for qtbase-native, qtbase-nativesdk and qtbase | 11 | # common for qtbase-native, qtbase-nativesdk and qtbase |
diff --git a/recipes-qt/qt5/qt5-git.inc b/recipes-qt/qt5/qt5-git.inc index 84ddf496..c8789980 100644 --- a/recipes-qt/qt5/qt5-git.inc +++ b/recipes-qt/qt5/qt5-git.inc | |||
@@ -5,7 +5,7 @@ QT_MODULE_BRANCH ?= "5.4" | |||
5 | 5 | ||
6 | # each module needs to define valid SRCREV | 6 | # each module needs to define valid SRCREV |
7 | SRC_URI += " \ | 7 | SRC_URI += " \ |
8 | git://code.qt.io/qt/${QT_MODULE}.git;branch=${QT_MODULE_BRANCH} \ | 8 | ${QT_GIT}/qt/${QT_MODULE}.git;branch=${QT_MODULE_BRANCH} \ |
9 | " | 9 | " |
10 | 10 | ||
11 | S = "${WORKDIR}/git" | 11 | S = "${WORKDIR}/git" |
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb index 5a308d4b..e558ee6d 100644 --- a/recipes-qt/qt5/qtbase-native_git.bb +++ b/recipes-qt/qt5/qtbase-native_git.bb | |||
@@ -2,7 +2,7 @@ require qt5-git.inc | |||
2 | require ${PN}.inc | 2 | require ${PN}.inc |
3 | 3 | ||
4 | SRC_URI = "\ | 4 | SRC_URI = "\ |
5 | git://code.qt.io/qt/${QT_MODULE}.git;branch=${QT_MODULE_BRANCH} \ | 5 | ${QT_GIT}/qt/${QT_MODULE}.git;branch=${QT_MODULE_BRANCH} \ |
6 | " | 6 | " |
7 | 7 | ||
8 | # common for qtbase-native, qtbase-nativesdk and qtbase | 8 | # common for qtbase-native, qtbase-nativesdk and qtbase |
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb index 549c92af..1be31ea5 100644 --- a/recipes-qt/qt5/qtbase_git.bb +++ b/recipes-qt/qt5/qtbase_git.bb | |||
@@ -2,7 +2,7 @@ require qt5-git.inc | |||
2 | require ${PN}.inc | 2 | require ${PN}.inc |
3 | 3 | ||
4 | SRC_URI = "\ | 4 | SRC_URI = "\ |
5 | git://code.qt.io/qt/${QT_MODULE}.git;branch=${QT_MODULE_BRANCH} \ | 5 | ${QT_GIT}/qt/${QT_MODULE}.git;branch=${QT_MODULE_BRANCH} \ |
6 | " | 6 | " |
7 | 7 | ||
8 | # common for qtbase-native, qtbase-nativesdk and qtbase | 8 | # common for qtbase-native, qtbase-nativesdk and qtbase |