diff options
7 files changed, 1 insertions, 255 deletions
diff --git a/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb b/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb index 0fca38e6..2d006242 100755 --- a/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb +++ b/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb | |||
@@ -8,11 +8,6 @@ inherit packagegroup | |||
8 | 8 | ||
9 | PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1" | 9 | PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1" |
10 | 10 | ||
11 | # Requires Ruby to work | ||
12 | USE_RUBY = " \ | ||
13 | ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'qtwebkit-dev', '', d)} \ | ||
14 | " | ||
15 | |||
16 | # Requires Wayland to work | 11 | # Requires Wayland to work |
17 | USE_WAYLAND = " \ | 12 | USE_WAYLAND = " \ |
18 | qtwayland-dev \ | 13 | qtwayland-dev \ |
@@ -90,7 +85,6 @@ RDEPENDS_${PN} += " \ | |||
90 | qttools-staticdev \ | 85 | qttools-staticdev \ |
91 | qttools-tools \ | 86 | qttools-tools \ |
92 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '${USE_WAYLAND}', '', d)} \ | 87 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '${USE_WAYLAND}', '', d)} \ |
93 | ${USE_RUBY} \ | ||
94 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '${USE_X11}', '', d)} \ | 88 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '${USE_X11}', '', d)} \ |
95 | qtwebsockets-dev \ | 89 | qtwebsockets-dev \ |
96 | qtwebsockets-mkspecs \ | 90 | qtwebsockets-mkspecs \ |
diff --git a/recipes-qt/qt5/qt5-creator_git.bb b/recipes-qt/qt5/qt5-creator_git.bb index 5b723ab4..5c11e4e8 100644 --- a/recipes-qt/qt5/qt5-creator_git.bb +++ b/recipes-qt/qt5/qt5-creator_git.bb | |||
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = " \ | |||
14 | 14 | ||
15 | inherit qmake5 | 15 | inherit qmake5 |
16 | 16 | ||
17 | DEPENDS = "qtbase qtscript qtwebkit qtxmlpatterns qtx11extras qtdeclarative qttools qttools-native qtsvg chrpath-replacement-native zlib" | 17 | DEPENDS = "qtbase qtscript qtxmlpatterns qtx11extras qtdeclarative qttools qttools-native qtsvg chrpath-replacement-native zlib" |
18 | DEPENDS_append_toolchain-clang = " clang llvm-common" | 18 | DEPENDS_append_toolchain-clang = " clang llvm-common" |
19 | DEPENDS_append_libc-musl = " libexecinfo" | 19 | DEPENDS_append_libc-musl = " libexecinfo" |
20 | 20 | ||
diff --git a/recipes-qt/qt5/qtwebkit/0001-Do-not-skip-build-for-cross-compile.patch b/recipes-qt/qt5/qtwebkit/0001-Do-not-skip-build-for-cross-compile.patch deleted file mode 100644 index a237d03d..00000000 --- a/recipes-qt/qt5/qtwebkit/0001-Do-not-skip-build-for-cross-compile.patch +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | From 34018c2a61045c58f88e09a12ecd62533aa2c2f1 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com> | ||
3 | Date: Mon, 4 Jun 2018 10:35:46 +0200 | ||
4 | Subject: [PATCH] Do not skip build for cross-compile | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | Upstream-Status: Inappropriate [OE specific] | ||
10 | |||
11 | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> | ||
12 | --- | ||
13 | Tools/qmake/mkspecs/features/functions.prf | 2 -- | ||
14 | 1 file changed, 2 deletions(-) | ||
15 | |||
16 | diff --git a/Tools/qmake/mkspecs/features/functions.prf b/Tools/qmake/mkspecs/features/functions.prf | ||
17 | index e3f42cec4..797b7085f 100644 | ||
18 | --- a/Tools/qmake/mkspecs/features/functions.prf | ||
19 | +++ b/Tools/qmake/mkspecs/features/functions.prf | ||
20 | @@ -53,8 +53,6 @@ defineReplace(appleSdkVersion) { | ||
21 | defineTest(isPlatformSupported) { | ||
22 | !qtHaveModule(widgets): skipBuild("QtWidgets module is required to build QtWebKit.") | ||
23 | |||
24 | - cross_compile: skipBuild("cross-compilation of QtWebKit with qmake is not supported yet") | ||
25 | - | ||
26 | requiredPrograms = cmake gperf python perl bison ruby flex | ||
27 | for(program, requiredPrograms): \ | ||
28 | !programExistsInPath($$program): \ | ||
diff --git a/recipes-qt/qt5/qtwebkit/0002-Fix-build-with-non-glibc-libc-on-musl.patch b/recipes-qt/qt5/qtwebkit/0002-Fix-build-with-non-glibc-libc-on-musl.patch deleted file mode 100644 index bf79b363..00000000 --- a/recipes-qt/qt5/qtwebkit/0002-Fix-build-with-non-glibc-libc-on-musl.patch +++ /dev/null | |||
@@ -1,69 +0,0 @@ | |||
1 | From c4ceb318aa1064bfa677cdd800c52155eb1bed3a Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 23 Aug 2018 04:06:17 +0000 | ||
4 | Subject: [PATCH] Fix build with non-glibc libc on musl | ||
5 | |||
6 | Need to ensure glibc features are not assumed to be linux-wide | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | Source/JavaScriptCore/heap/MachineStackMarker.cpp | 8 ++++---- | ||
12 | .../inspector/JSGlobalObjectInspectorController.cpp | 2 ++ | ||
13 | 2 files changed, 6 insertions(+), 4 deletions(-) | ||
14 | |||
15 | diff --git a/Source/JavaScriptCore/heap/MachineStackMarker.cpp b/Source/JavaScriptCore/heap/MachineStackMarker.cpp | ||
16 | index 883914fd3..ce4e8d331 100644 | ||
17 | --- a/Source/JavaScriptCore/heap/MachineStackMarker.cpp | ||
18 | +++ b/Source/JavaScriptCore/heap/MachineStackMarker.cpp | ||
19 | @@ -566,7 +566,7 @@ void* MachineThreads::Thread::Registers::stackPointer() const | ||
20 | #error Unknown Architecture | ||
21 | #endif | ||
22 | |||
23 | -#elif defined(__GLIBC__) && ENABLE(JIT) | ||
24 | +#elif defined(__linux__) && ENABLE(JIT) | ||
25 | |||
26 | #if CPU(X86) | ||
27 | return reinterpret_cast<void*>((uintptr_t) regs.machineContext.gregs[REG_ESP]); | ||
28 | @@ -665,7 +665,7 @@ void* MachineThreads::Thread::Registers::framePointer() const | ||
29 | #error Unknown Architecture | ||
30 | #endif | ||
31 | |||
32 | -#elif defined(__GLIBC__) | ||
33 | +#elif defined(__linux__) | ||
34 | |||
35 | // The following sequence depends on glibc's sys/ucontext.h. | ||
36 | #if CPU(X86) | ||
37 | @@ -747,7 +747,7 @@ void* MachineThreads::Thread::Registers::instructionPointer() const | ||
38 | #error Unknown Architecture | ||
39 | #endif | ||
40 | |||
41 | -#elif defined(__GLIBC__) | ||
42 | +#elif defined(__linux__) | ||
43 | |||
44 | // The following sequence depends on glibc's sys/ucontext.h. | ||
45 | #if CPU(X86) | ||
46 | @@ -838,7 +838,7 @@ void* MachineThreads::Thread::Registers::llintPC() const | ||
47 | #error Unknown Architecture | ||
48 | #endif | ||
49 | |||
50 | -#elif defined(__GLIBC__) | ||
51 | +#elif defined(__linux__) | ||
52 | |||
53 | // The following sequence depends on glibc's sys/ucontext.h. | ||
54 | #if CPU(X86) | ||
55 | diff --git a/Source/JavaScriptCore/inspector/JSGlobalObjectInspectorController.cpp b/Source/JavaScriptCore/inspector/JSGlobalObjectInspectorController.cpp | ||
56 | index fd7f869d4..e95391b32 100644 | ||
57 | --- a/Source/JavaScriptCore/inspector/JSGlobalObjectInspectorController.cpp | ||
58 | +++ b/Source/JavaScriptCore/inspector/JSGlobalObjectInspectorController.cpp | ||
59 | @@ -51,8 +51,10 @@ | ||
60 | #include <cxxabi.h> | ||
61 | #if OS(DARWIN) || (OS(LINUX) && !PLATFORM(GTK)) | ||
62 | #include <dlfcn.h> | ||
63 | +#if defined(__GLIBC__) | ||
64 | #include <execinfo.h> | ||
65 | #endif | ||
66 | +#endif | ||
67 | |||
68 | #if ENABLE(REMOTE_INSPECTOR) | ||
69 | #include "JSGlobalObjectDebuggable.h" | ||
diff --git a/recipes-qt/qt5/qtwebkit/0003-Fix-build-bug-for-armv32-BE.patch b/recipes-qt/qt5/qtwebkit/0003-Fix-build-bug-for-armv32-BE.patch deleted file mode 100644 index ffd8da0f..00000000 --- a/recipes-qt/qt5/qtwebkit/0003-Fix-build-bug-for-armv32-BE.patch +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | From f6576377f8bf2c854d8079b7f309f570b3d2bde4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Lei Maohui <leimaohui@cn.fujitsu.com> | ||
3 | Date: Fri, 31 Aug 2018 15:42:48 +0900 | ||
4 | Subject: [PATCH] Fix build bug for armv32 BE. | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> | ||
9 | --- | ||
10 | Source/WTF/wtf/dtoa/utils.h | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/Source/WTF/wtf/dtoa/utils.h b/Source/WTF/wtf/dtoa/utils.h | ||
14 | index 889642cee..05302e6e6 100644 | ||
15 | --- a/Source/WTF/wtf/dtoa/utils.h | ||
16 | +++ b/Source/WTF/wtf/dtoa/utils.h | ||
17 | @@ -49,7 +49,7 @@ | ||
18 | defined(__ARMEL__) || \ | ||
19 | defined(_MIPS_ARCH_MIPS32R2) | ||
20 | #define DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS 1 | ||
21 | -#elif CPU(MIPS) || CPU(MIPS64) || CPU(PPC) || CPU(PPC64) || CPU(PPC64LE) || CPU(SH4) || CPU(S390) || CPU(S390X) || CPU(IA64) || CPU(ALPHA) || CPU(ARM64) || CPU(HPPA) | ||
22 | +#elif CPU(MIPS) || CPU(MIPS64) || CPU(PPC) || CPU(PPC64) || CPU(PPC64LE) || CPU(SH4) || CPU(S390) || CPU(S390X) || CPU(IA64) || CPU(ALPHA) || CPU(ARM64) || CPU(HPPA) || CPU(ARM) | ||
23 | #define DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS 1 | ||
24 | #elif defined(_M_IX86) || defined(__i386__) | ||
25 | #if defined(_WIN32) | ||
diff --git a/recipes-qt/qt5/qtwebkit/0004-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch b/recipes-qt/qt5/qtwebkit/0004-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch deleted file mode 100644 index 14cb8aa4..00000000 --- a/recipes-qt/qt5/qtwebkit/0004-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | From 83aa5b3265d7c9f64e754cb890988cf8a5669ce7 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 24 Sep 2018 02:11:10 -0700 | ||
4 | Subject: [PATCH] PlatformQt.cmake: Do not generate hardcoded include paths | ||
5 | |||
6 | If we do not use this define,then it falls into else case which | ||
7 | generated .pri files with /usr/include and so on for includes and | ||
8 | compiler does not like specifying absolute include paths pointing to | ||
9 | build host includes | ||
10 | |||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | Source/WebKit/PlatformQt.cmake | 4 ++-- | ||
14 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/Source/WebKit/PlatformQt.cmake b/Source/WebKit/PlatformQt.cmake | ||
17 | index 9aed9906e..48638aef4 100644 | ||
18 | --- a/Source/WebKit/PlatformQt.cmake | ||
19 | +++ b/Source/WebKit/PlatformQt.cmake | ||
20 | @@ -512,7 +512,7 @@ if (NOT MACOS_BUILD_FRAMEWORKS) | ||
21 | install(FILES ${WebKit_PKGCONFIG_FILENAME} DESTINATION ${ECM_PKGCONFIG_INSTALL_DIR} COMPONENT Data) | ||
22 | endif () | ||
23 | |||
24 | -if (KDE_INSTALL_USE_QT_SYS_PATHS) | ||
25 | +if (KDE_INSTALL_USE_QT_SYS_PATHS OR CROSS_COMPILE) | ||
26 | set(WebKit_PRI_ARGUMENTS | ||
27 | BIN_INSTALL_DIR "$$QT_MODULE_BIN_BASE" | ||
28 | LIB_INSTALL_DIR "$$QT_MODULE_LIB_BASE" | ||
29 | @@ -737,7 +737,7 @@ if (NOT MACOS_BUILD_FRAMEWORKS) | ||
30 | install(FILES ${WebKitWidgets_PKGCONFIG_FILENAME} DESTINATION ${ECM_PKGCONFIG_INSTALL_DIR} COMPONENT Data) | ||
31 | endif () | ||
32 | |||
33 | -if (KDE_INSTALL_USE_QT_SYS_PATHS) | ||
34 | +if (KDE_INSTALL_USE_QT_SYS_PATHS OR CROSS_COMPILE) | ||
35 | set(WebKitWidgets_PRI_ARGUMENTS | ||
36 | BIN_INSTALL_DIR "$$QT_MODULE_BIN_BASE" | ||
37 | LIB_INSTALL_DIR "$$QT_MODULE_LIB_BASE" | ||
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb deleted file mode 100644 index 942e733a..00000000 --- a/recipes-qt/qt5/qtwebkit_git.bb +++ /dev/null | |||
@@ -1,89 +0,0 @@ | |||
1 | require qt5.inc | ||
2 | require qt5-git.inc | ||
3 | |||
4 | LICENSE = "BSD & LGPLv2+ | GPL-2.0" | ||
5 | LIC_FILES_CHKSUM = " \ | ||
6 | file://LICENSE.LGPLv21;md5=58a180e1cf84c756c29f782b3a485c29 \ | ||
7 | file://Source/JavaScriptCore/parser/Parser.h;endline=21;md5=bd69f72183a7af673863f057576e21ee \ | ||
8 | " | ||
9 | |||
10 | DEPENDS += "qtbase qtdeclarative icu ruby-native sqlite3 glib-2.0 libxslt gperf-native bison-native flex-native" | ||
11 | |||
12 | # Patches from https://github.com/meta-qt5/qtwebkit/commits/b5.13 | ||
13 | # 5.13.meta-qt5.1 | ||
14 | SRC_URI += "\ | ||
15 | file://0001-Do-not-skip-build-for-cross-compile.patch \ | ||
16 | file://0002-Fix-build-with-non-glibc-libc-on-musl.patch \ | ||
17 | file://0003-Fix-build-bug-for-armv32-BE.patch \ | ||
18 | file://0004-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch \ | ||
19 | " | ||
20 | |||
21 | inherit cmake_qt5 perlnative | ||
22 | |||
23 | inherit ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "pythonnative", "", d)} | ||
24 | |||
25 | python() { | ||
26 | if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split(): | ||
27 | raise bb.parse.SkipRecipe('Requires meta-python2 to be present.') | ||
28 | } | ||
29 | |||
30 | # qemuarm build fails with: | ||
31 | # | {standard input}: Assembler messages: | ||
32 | # | {standard input}:106: Error: invalid immediate: 983040 is out of range | ||
33 | # | {standard input}:106: Error: value of 983040 too large for field of 2 bytes at 146 | ||
34 | ARM_INSTRUCTION_SET_armv4 = "arm" | ||
35 | ARM_INSTRUCTION_SET_armv5 = "arm" | ||
36 | |||
37 | # https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474 | ||
38 | # https://bugs.webkit.org/show_bug.cgi?id=159880 | ||
39 | # JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime. | ||
40 | # Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb). | ||
41 | ARM_INSTRUCTION_SET_armv7a = "thumb" | ||
42 | ARM_INSTRUCTION_SET_armv7r = "thumb" | ||
43 | ARM_INSTRUCTION_SET_armv7ve = "thumb" | ||
44 | |||
45 | # http://errors.yoctoproject.org/Errors/Details/179245/ | ||
46 | # just use -fpermissive in this case like fedora did: | ||
47 | # https://bugzilla.redhat.com/show_bug.cgi?id=1582954 | ||
48 | CXXFLAGS += "-fpermissive" | ||
49 | |||
50 | EXTRA_OECMAKE += " \ | ||
51 | -DPORT=Qt \ | ||
52 | -DCROSS_COMPILE=ON \ | ||
53 | -DECM_MKSPECS_INSTALL_DIR=${libdir}${QT_DIR_NAME}/mkspecs/modules \ | ||
54 | -DQML_INSTALL_DIR=${OE_QMAKE_PATH_QML} \ | ||
55 | " | ||
56 | |||
57 | EXTRA_OECMAKE_append_toolchain-clang = " -DCMAKE_CXX_IMPLICIT_INCLUDE_DIRECTORIES:PATH='${STAGING_INCDIR}'" | ||
58 | |||
59 | # JIT not supported on MIPS/PPC | ||
60 | EXTRA_OECMAKE_append_mipsarch = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON " | ||
61 | EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON " | ||
62 | # Disable gold on mips64/clang | ||
63 | # mips64-yoe-linux-musl-ld.gold: internal error in get_got_page_offset, at ../../gold/mips.cc:6260 | ||
64 | # mips-yoe-linux-musl-ld.gold: error: Can't find matching LO16 reloc | ||
65 | EXTRA_OECMAKE_append_toolchain-clang_mipsarch = " -DUSE_LD_GOLD=OFF " | ||
66 | |||
67 | PACKAGECONFIG ??= "qtlocation qtmultimedia qtsensors qtwebchannel \ | ||
68 | ${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \ | ||
69 | fontconfig \ | ||
70 | " | ||
71 | |||
72 | # gstreamer conflicts with qtmultimedia! | ||
73 | PACKAGECONFIG[gstreamer] = "-DUSE_GSTREAMER=ON,-DUSE_GSTREAMER=OFF,gstreamer1.0 gstreamer1.0-plugins-base" | ||
74 | PACKAGECONFIG[qtlocation] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,qtlocation" | ||
75 | PACKAGECONFIG[qtmultimedia] = "-DUSE_QT_MULTIMEDIA=ON,-DUSE_QT_MULTIMEDIA=OFF,qtmultimedia" | ||
76 | PACKAGECONFIG[qtsensors] = "-DENABLE_DEVICE_ORIENTATION=ON,-DENABLE_DEVICE_ORIENTATION=OFF,qtsensors" | ||
77 | PACKAGECONFIG[qtwebchannel] = "-DENABLE_QT_WEBCHANNEL=ON,-DENABLE_QT_WEBCHANNEL=OFF,qtwebchannel" | ||
78 | PACKAGECONFIG[libwebp] = ",,libwebp" | ||
79 | PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,libxcomposite libxrender" | ||
80 | PACKAGECONFIG[fontconfig] = "-DENABLE_TEST_SUPPORT=ON,-DENABLE_TEST_SUPPORT=OFF,fontconfig" | ||
81 | # hyphen is only in meta-office currently! | ||
82 | PACKAGECONFIG[hyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,hyphen" | ||
83 | |||
84 | # remove default ${PN}-examples* set in qt5.inc, because they conflicts with ${PN} from separate webkit-examples recipe | ||
85 | PACKAGES_remove = "${PN}-examples" | ||
86 | |||
87 | QT_MODULE_BRANCH = "dev" | ||
88 | |||
89 | SRCREV = "ab1bd15209abaf7effc51dbc2f272c5681af7223" | ||