diff options
-rw-r--r-- | recipes-qt/qt5/qt3d-runtime/0001-runtime-Include-missing-QCoreApplication-header.patch | 29 | ||||
-rw-r--r-- | recipes-qt/qt5/qt3d-runtime_git.bb | 2 |
2 files changed, 0 insertions, 31 deletions
diff --git a/recipes-qt/qt5/qt3d-runtime/0001-runtime-Include-missing-QCoreApplication-header.patch b/recipes-qt/qt5/qt3d-runtime/0001-runtime-Include-missing-QCoreApplication-header.patch deleted file mode 100644 index bc61e538..00000000 --- a/recipes-qt/qt5/qt3d-runtime/0001-runtime-Include-missing-QCoreApplication-header.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | From e6247a6823d372cc779934cf6c74d65bae9652b5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 23 Aug 2018 03:23:20 +0000 | ||
4 | Subject: [PATCH] runtime: Include missing <QCoreApplication> header | ||
5 | |||
6 | Fixes following errors seen on mips | ||
7 | |||
8 | q3dsengine.cpp:1327:9: error: 'QCoreApplication' has not been declared | ||
9 | QCoreApplication::sendEvent(&m_profileUiEventSource, e); | ||
10 | ^~~~~~~~~~~~~~~~ | ||
11 | |||
12 | Upstream-Status: Pending | ||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
14 | --- | ||
15 | src/runtime/q3dsengine.cpp | 1 + | ||
16 | 1 file changed, 1 insertion(+) | ||
17 | |||
18 | diff --git a/src/runtime/q3dsengine.cpp b/src/runtime/q3dsengine.cpp | ||
19 | index 1a438f0..d6d4eb5 100644 | ||
20 | --- a/src/runtime/q3dsengine.cpp | ||
21 | +++ b/src/runtime/q3dsengine.cpp | ||
22 | @@ -36,6 +36,7 @@ | ||
23 | #include "q3dsinlineqmlsubpresentation_p.h" | ||
24 | #include "q3dsviewersettings.h" | ||
25 | |||
26 | +#include <QCoreApplication> | ||
27 | #include <QLoggingCategory> | ||
28 | #include <QKeyEvent> | ||
29 | #include <QMouseEvent> | ||
diff --git a/recipes-qt/qt5/qt3d-runtime_git.bb b/recipes-qt/qt5/qt3d-runtime_git.bb index 2b017106..8df143ae 100644 --- a/recipes-qt/qt5/qt3d-runtime_git.bb +++ b/recipes-qt/qt5/qt3d-runtime_git.bb | |||
@@ -7,8 +7,6 @@ LIC_FILES_CHKSUM = " \ | |||
7 | file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \ | 7 | file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \ |
8 | " | 8 | " |
9 | 9 | ||
10 | SRC_URI += "file://0001-runtime-Include-missing-QCoreApplication-header.patch" | ||
11 | |||
12 | DEPENDS += "qtbase qtdeclarative qt3d" | 10 | DEPENDS += "qtbase qtdeclarative qt3d" |
13 | 11 | ||
14 | QT_MODULE_BRANCH = "2.2" | 12 | QT_MODULE_BRANCH = "2.2" |