summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb1
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb1
-rw-r--r--recipes-qt/qt5/qtbase/0023-build-failure-with-clang.patch48
-rw-r--r--recipes-qt/qt5/qtbase_git.bb1
4 files changed, 51 insertions, 0 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 1a0e38eb..987d156f 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -45,6 +45,7 @@ SRC_URI += "\
45 file://0018-Fix-compile-issue-with-gcc-9.patch \ 45 file://0018-Fix-compile-issue-with-gcc-9.patch \
46 file://0019-Fix-compilation-of-qendian-s-qswap-specializations-o.patch \ 46 file://0019-Fix-compilation-of-qendian-s-qswap-specializations-o.patch \
47 file://0020-Fix-qbswap-calls-for-Big-Endian-targets.patch \ 47 file://0020-Fix-qbswap-calls-for-Big-Endian-targets.patch \
48 file://0023-build-failure-with-clang.patch \
48" 49"
49 50
50# common for qtbase-native and nativesdk-qtbase 51# common for qtbase-native and nativesdk-qtbase
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index e636167e..51cc6c4a 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -40,6 +40,7 @@ SRC_URI += "\
40 file://0018-Fix-compile-issue-with-gcc-9.patch \ 40 file://0018-Fix-compile-issue-with-gcc-9.patch \
41 file://0019-Fix-compilation-of-qendian-s-qswap-specializations-o.patch \ 41 file://0019-Fix-compilation-of-qendian-s-qswap-specializations-o.patch \
42 file://0020-Fix-qbswap-calls-for-Big-Endian-targets.patch \ 42 file://0020-Fix-qbswap-calls-for-Big-Endian-targets.patch \
43 file://0023-build-failure-with-clang.patch \
43" 44"
44 45
45# common for qtbase-native and nativesdk-qtbase 46# common for qtbase-native and nativesdk-qtbase
diff --git a/recipes-qt/qt5/qtbase/0023-build-failure-with-clang.patch b/recipes-qt/qt5/qtbase/0023-build-failure-with-clang.patch
new file mode 100644
index 00000000..0576a22c
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0023-build-failure-with-clang.patch
@@ -0,0 +1,48 @@
1From f958dccc8c7c777aaca1f110ed48c71b28fdea92 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 1 Mar 2019 15:11:19 -0800
4Subject: [PATCH] Fix build failure with clang
5
6Complement below commit
7
8commit 1555894dec537cbc422f43fe959b0d0ee0000881
9Author: Thiago Macieira <thiago.macieira@intel.com>
10Date: Wed Jul 25 19:04:20 2018 -0700
11
12 QCborValue: Disable support for spaceship operator
13
14 __has_include(<compare>) is not the correct way to detect this feature,
15 since that's a library header and may be provided by an implementation
16 (libc++) before the compiler supports the syntax.
17
18 Change-Id: I80aae0d068974d83b6c0fffd1544c8e558e2446b
19 Reviewed-by: Edward Welbourne <edward.welbourne@qt.io>
20
21Fixes
22tst_qcborvalue.cpp:336:17: error: invalid operands to binary expression ('QCborValue' and 'QCborValue')
23 QVERIFY(!(v > other));
24 ~ ^ ~~~~~
25
26Upstream-Status: Pending
27
28Signed-off-by: Khem Raj <raj.khem@gmail.com>
29---
30 tests/auto/corelib/serialization/qcborvalue/tst_qcborvalue.cpp | 2 +-
31 1 file changed, 1 insertion(+), 1 deletion(-)
32
33diff --git a/tests/auto/corelib/serialization/qcborvalue/tst_qcborvalue.cpp b/tests/auto/corelib/serialization/qcborvalue/tst_qcborvalue.cpp
34index 38b26e7de4..4b753eab6b 100644
35--- a/tests/auto/corelib/serialization/qcborvalue/tst_qcborvalue.cpp
36+++ b/tests/auto/corelib/serialization/qcborvalue/tst_qcborvalue.cpp
37@@ -330,7 +330,7 @@ void tst_QCborValue::copyCompare()
38 QCOMPARE(v, other);
39 QVERIFY(!(v != other));
40 QVERIFY(!(v < other));
41-#if QT_HAS_INCLUDE(<compare>)
42+#if 0 && QT_HAS_INCLUDE(<compare>)
43 QVERIFY(v <= other);
44 QVERIFY(v >= other);
45 QVERIFY(!(v > other));
46--
472.21.0
48
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index ca31626b..a9c17559 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -36,6 +36,7 @@ SRC_URI += "\
36 file://0018-Fix-compile-issue-with-gcc-9.patch \ 36 file://0018-Fix-compile-issue-with-gcc-9.patch \
37 file://0019-Fix-compilation-of-qendian-s-qswap-specializations-o.patch \ 37 file://0019-Fix-compilation-of-qendian-s-qswap-specializations-o.patch \
38 file://0020-Fix-qbswap-calls-for-Big-Endian-targets.patch \ 38 file://0020-Fix-qbswap-calls-for-Big-Endian-targets.patch \
39 file://0023-build-failure-with-clang.patch \
39" 40"
40 41
41 42