summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_%.bbappend10
1 files changed, 1 insertions, 9 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_%.bbappend
index b42338ab..89026193 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_%.bbappend
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_%.bbappend
@@ -4,12 +4,4 @@ PACKAGECONFIG[qt5] = '--enable-qt \
4 --with-moc="${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/moc" \ 4 --with-moc="${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/moc" \
5 --with-uic="${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/uic" \ 5 --with-uic="${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/uic" \
6 --with-rcc="${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/rcc" \ 6 --with-rcc="${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/rcc" \
7 ,--disable-qt,qtbase qtdeclarative qtbase-native' 7 ,--disable-qt,gstreamer1.0-plugins-base qtbase qtdeclarative qtbase-native'
8
9# The GStreamer Qt5 plugin needs desktop OpenGL or OpenGL ES to work, so make sure it is enabled
10python() {
11 cur_packageconfig = d.getVar('PACKAGECONFIG',True).split()
12 if 'qt5' in cur_packageconfig and not (('opengl' in cur_packageconfig) or ('gles2' in cur_packageconfig)):
13 gl_packageconfig = d.getVar('PACKAGECONFIG_GL',True)
14 d.appendVar('PACKAGECONFIG', ' ' + gl_packageconfig)
15}