summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtbase
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtbase')
-rw-r--r--recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch14
-rw-r--r--recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch (renamed from recipes-qt/qt5/qtbase/0003-Add-external-hostbindir-option.patch)6
-rw-r--r--recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch (renamed from recipes-qt/qt5/qtbase/0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch)6
-rw-r--r--recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch34
-rw-r--r--recipes-qt/qt5/qtbase/0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch106
-rw-r--r--recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch (renamed from recipes-qt/qt5/qtbase/0006-Disable-all-unknown-features-instead-of-erroring-out.patch)6
-rw-r--r--recipes-qt/qt5/qtbase/0005-configure-bump-path-length-from-256-to-512-character.patch33
-rw-r--r--recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch (renamed from recipes-qt/qt5/qtbase/0007-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch)4
-rw-r--r--recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch (renamed from recipes-qt/qt5/qtbase/0008-Delete-qlonglong-and-qulonglong.patch)2
-rw-r--r--recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch (renamed from recipes-qt/qt5/qtbase/0010-Replace-pthread_yield-with-sched_yield.patch)10
-rw-r--r--recipes-qt/qt5/qtbase/0009-Always-build-uic.patch (renamed from recipes-qt/qt5/qtbase/0011-Always-build-uic.patch)6
-rw-r--r--recipes-qt/qt5/qtbase/0009-tst_qstring-Disable-Wformat-security-with-clang-as-w.patch28
-rw-r--r--recipes-qt/qt5/qtbase/0011-configure-paths-for-target-qmake-properly.patch75
13 files changed, 61 insertions, 269 deletions
diff --git a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
index 3f373c76..28c26603 100644
--- a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
+++ b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
@@ -1,4 +1,4 @@
1From 805b338154ed0262a7b8bf5c582ff5b193a55492 Mon Sep 17 00:00:00 2001 1From e13425e6f1e784b0b016cf68a54dfbae32995b86 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com> 2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Mon, 15 Apr 2013 04:29:32 +0200 3Date: Mon, 15 Apr 2013 04:29:32 +0200
4Subject: [PATCH] Add linux-oe-g++ platform 4Subject: [PATCH] Add linux-oe-g++ platform
@@ -30,10 +30,10 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
30 create mode 100644 mkspecs/linux-oe-g++/qplatformdefs.h 30 create mode 100644 mkspecs/linux-oe-g++/qplatformdefs.h
31 31
32diff --git a/configure b/configure 32diff --git a/configure b/configure
33index bc18e614d2..579a96d787 100755 33index 73679de621..5a0eebce50 100755
34--- a/configure 34--- a/configure
35+++ b/configure 35+++ b/configure
36@@ -1614,7 +1614,7 @@ fi 36@@ -709,7 +709,7 @@ fi
37 # is where the resulting variable is written to 37 # is where the resulting variable is written to
38 setBootstrapVariable() 38 setBootstrapVariable()
39 { 39 {
@@ -43,10 +43,10 @@ index bc18e614d2..579a96d787 100755
43 43
44 # build qmake 44 # build qmake
45diff --git a/mkspecs/features/configure.prf b/mkspecs/features/configure.prf 45diff --git a/mkspecs/features/configure.prf b/mkspecs/features/configure.prf
46index 4ca7c6ba07..5b5ac13f1d 100644 46index 934a18a924..0f5b1b6333 100644
47--- a/mkspecs/features/configure.prf 47--- a/mkspecs/features/configure.prf
48+++ b/mkspecs/features/configure.prf 48+++ b/mkspecs/features/configure.prf
49@@ -44,14 +44,14 @@ defineTest(qtCompileTest) { 49@@ -46,14 +46,14 @@ defineTest(qtCompileTest) {
50 } 50 }
51 51
52 # Clean up after previous run 52 # Clean up after previous run
@@ -64,10 +64,10 @@ index 4ca7c6ba07..5b5ac13f1d 100644
64 msg = "test $$1 succeeded" 64 msg = "test $$1 succeeded"
65 write_file($$QMAKE_CONFIG_LOG, msg, append) 65 write_file($$QMAKE_CONFIG_LOG, msg, append)
66diff --git a/mkspecs/features/qt_functions.prf b/mkspecs/features/qt_functions.prf 66diff --git a/mkspecs/features/qt_functions.prf b/mkspecs/features/qt_functions.prf
67index 999cd18154..2ac91ba519 100644 67index c00fdb73f8..0cf4de7b49 100644
68--- a/mkspecs/features/qt_functions.prf 68--- a/mkspecs/features/qt_functions.prf
69+++ b/mkspecs/features/qt_functions.prf 69+++ b/mkspecs/features/qt_functions.prf
70@@ -67,7 +67,7 @@ defineTest(qtHaveModule) { 70@@ -69,7 +69,7 @@ defineTest(qtHaveModule) {
71 defineTest(qtPrepareTool) { 71 defineTest(qtPrepareTool) {
72 cmd = $$eval(QT_TOOL.$${2}.binary) 72 cmd = $$eval(QT_TOOL.$${2}.binary)
73 isEmpty(cmd) { 73 isEmpty(cmd) {
diff --git a/recipes-qt/qt5/qtbase/0003-Add-external-hostbindir-option.patch b/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch
index 9f1a2b2c..5ee6e049 100644
--- a/recipes-qt/qt5/qtbase/0003-Add-external-hostbindir-option.patch
+++ b/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch
@@ -1,9 +1,9 @@
1From 67977e16e5d0aecd931d8e4355c12cc907df592f Mon Sep 17 00:00:00 2001 1From 5ed152f8caa7ef00fb20d19a06ab5f7887e9aba6 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com> 2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Sat, 6 Apr 2013 13:15:07 +0200 3Date: Sat, 6 Apr 2013 13:15:07 +0200
4Subject: [PATCH] Add -external-hostbindir option 4Subject: [PATCH] cmake: Use OE_QMAKE_PATH_EXTERNAL_HOST_BINS
5 5
6* cmake: Use OE_QMAKE_PATH_EXTERNAL_HOST_BINS to determine path to host binaries 6... to determine path to host binaries
7 7
8Upstream-Status: Inappropriate [OE specific] 8Upstream-Status: Inappropriate [OE specific]
9 9
diff --git a/recipes-qt/qt5/qtbase/0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch b/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
index f9859620..7ff1ff71 100644
--- a/recipes-qt/qt5/qtbase/0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
+++ b/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
@@ -1,4 +1,4 @@
1From 18e2f4368f22bf5ac8b2a36c30a7ad39ed97bf49 Mon Sep 17 00:00:00 2001 1From 77fab782e8a199f9ede83bc97cbce21a544961c2 Mon Sep 17 00:00:00 2001
2From: Holger Freyther <zecke@selfish.org> 2From: Holger Freyther <zecke@selfish.org>
3Date: Wed, 26 Sep 2012 17:22:30 +0200 3Date: Wed, 26 Sep 2012 17:22:30 +0200
4Subject: [PATCH] qlibraryinfo: allow to set qt.conf from the outside using the 4Subject: [PATCH] qlibraryinfo: allow to set qt.conf from the outside using the
@@ -19,10 +19,10 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
19 1 file changed, 4 insertions(+), 1 deletion(-) 19 1 file changed, 4 insertions(+), 1 deletion(-)
20 20
21diff --git a/src/corelib/global/qlibraryinfo.cpp b/src/corelib/global/qlibraryinfo.cpp 21diff --git a/src/corelib/global/qlibraryinfo.cpp b/src/corelib/global/qlibraryinfo.cpp
22index 27fe10a79e..29ffcda203 100644 22index b4ba0b5b2e..11d4c00f39 100644
23--- a/src/corelib/global/qlibraryinfo.cpp 23--- a/src/corelib/global/qlibraryinfo.cpp
24+++ b/src/corelib/global/qlibraryinfo.cpp 24+++ b/src/corelib/global/qlibraryinfo.cpp
25@@ -164,7 +164,10 @@ void QLibrarySettings::load() 25@@ -172,7 +172,10 @@ void QLibrarySettings::load()
26 QSettings *QLibraryInfoPrivate::findConfiguration() 26 QSettings *QLibraryInfoPrivate::findConfiguration()
27 { 27 {
28 #ifdef QT_BUILD_QMAKE 28 #ifdef QT_BUILD_QMAKE
diff --git a/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch b/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch
new file mode 100644
index 00000000..5ab6a7b1
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch
@@ -0,0 +1,34 @@
1From 4848804312f0045b53c85db113ac9e42fe1b7360 Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denys@ti.com>
3Date: Tue, 25 Aug 2015 10:05:15 -0400
4Subject: [PATCH] configure: bump path length from 256 to 512 characters
5
6Increase the path length that gets hardcoded into generated config.cpp file
7from 256 to 512 characters, as nativesdk path can be quite long.
8
9Also update length of EXT_PREFIX and HOST_PREFIX now.
10
11Change-Id: If98dd57160efe9c98c36148cdf872f50b3d38118
12Signed-off-by: Denys Dmytriyenko <denys@ti.com>
13---
14 configure.pri | 6 +++---
15 1 file changed, 3 insertions(+), 3 deletions(-)
16
17diff --git a/configure.pri b/configure.pri
18index be1b166080..52f03bf3f2 100644
19--- a/configure.pri
20+++ b/configure.pri
21@@ -796,10 +796,10 @@ defineTest(qtConfOutput_preparePaths) {
22 "static const char qt_configure_installation [12+11] = \"qt_instdate=2012-12-20\";" \
23 "" \
24 "/* Installation Info */" \
25- "static const char qt_configure_prefix_path_str [12+256] = \"qt_prfxpath=$$config.input.prefix\";" \
26+ "static const char qt_configure_prefix_path_str [12+512] = \"qt_prfxpath=$$config.input.prefix\";" \
27 "$${LITERAL_HASH}ifdef QT_BUILD_QMAKE" \
28- "static const char qt_configure_ext_prefix_path_str [12+256] = \"qt_epfxpath=$$config.input.extprefix\";" \
29- "static const char qt_configure_host_prefix_path_str [12+256] = \"qt_hpfxpath=$$config.input.hostprefix\";" \
30+ "static const char qt_configure_ext_prefix_path_str [12+512] = \"qt_epfxpath=$$config.input.extprefix\";" \
31+ "static const char qt_configure_host_prefix_path_str [12+512] = \"qt_hpfxpath=$$config.input.hostprefix\";" \
32 "$${LITERAL_HASH}endif" \
33 "" \
34 "static const short qt_configure_str_offsets[] = {" \
diff --git a/recipes-qt/qt5/qtbase/0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch b/recipes-qt/qt5/qtbase/0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch
deleted file mode 100644
index aa97b56f..00000000
--- a/recipes-qt/qt5/qtbase/0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch
+++ /dev/null
@@ -1,106 +0,0 @@
1From fe9cfbde28c651d00b8f5fda7dc85a97af0c50a1 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Sat, 27 Apr 2013 23:15:37 +0200
4Subject: [PATCH] qt_module: Fix pkgconfig and libtool replacements
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9* in situation like this:
10 QT_SYSROOT:/OE/oe-core/tmp-eglibc/sysroots/qemuarm
11 QT_INSTALL_LIBS:/OE/oe-core/tmp-eglibc/sysroots/qemuarm/usr/lib
12 QT_INSTALL_LIBS/raw:/usr/lib
13 QT_INSTALL_LIBS/get:/OE/oe-core/tmp-eglibc/work/armv5te-oe-linux-gnueabi/qtbase/5.0.0-r0.0/build/lib
14
15 I don't want the replacement like this:
16 sed
17 -e "s,/OE/oe-core/tmp-eglibc/work/armv5te-oe-linux-gnueabi/qtbase/5.0.0-r0.0/build/include,/usr/include/qt5,g"
18 -e "s,/OE/oe-core/tmp-eglibc/work/armv5te-oe-linux-gnueabi/qtbase/5.0.0-r0.0/build/lib,/usr/lib,g"
19 "../../lib/pkgconfig/Qt5Core.pc"
20 >"/OE/oe-core/tmp-eglibc/work/armv5te-oe-linux-gnueabi/qtbase/5.0.0-r0.0/image/OE/oe-core/tmp-eglibc/sysroots/qemuarm/usr/lib/pkgconfig/Qt5Core.pc"
21 because that way I'll end with -L/usr/lib in .pc file which is
22 cross-compile unfriendly, keeping ${libdir}/${includedir} works better
23 in my case
24
25* qt_module: Fix paths in .prl files
26* qmake does not prefix them with QT_SYSROOT when using them
27 so e.g. when building qtdeclarative we get -L/usr/lib to LINKAGE
28 variable, which is unsafe for cross-compilation
29* writting QT_SYSROOT in .prl files is dangerous for sstate when
30 builds are in different directories, so we need
31 SSTATE_SCAN_FILES += "*.pri *.prl"
32 to make them relocateble
33
34* fix paths in packageconfig files
35 This reverts parts of:
36
37 enable path replacement in installed prl files on all platforms
38
39 Task-number: QTBUG-33794
40 Change-Id: Id0d38715673b8a1c0c034e9c15783eb255c4315b
41 Reviewed-by: Joerg Bornemann <joerg.bornemann@digia.com>
42
43* to debug this, rebuild qtbase and read build/src/corelib/Makefile
44* this is example of broken install_target rule (added line feeds):
45 -$(SED) -e s,/OE/5.3.1-r0/build/lib,/usr/lib,g
46 -e 's,/OE/5.3.1-r0/build/include,$$\{includedir},g'
47 -e 's,/OE/5.3.1-r0/build/lib,$$\{libdir},g'
48 "../../lib/pkgconfig/Qt5Core.pc"
49 >"$(INSTALL_ROOT)/usr/lib/pkgconfig/Qt5Core.pc"
50 change .prf files, create copy of WORKDIR, re-excecute only
51 do_configure task and compare generated Makefile, repeat until
52 replace in generated Makefile works ok, then refresh patch and
53 try complete rebuild for qtbase
54* if everything is ok, then try:
55 image $ grep -R "\-L/usr" .
56 image $ grep -R "\-I/usr" .
57 and it should return only few cases of
58 qmake.conf:QMAKE_LFLAGS_THREAD = -L/usr/lib/threads
59 for aix* platformas
60
61Change-Id: Ie1c94b15f2a4e736b65b4d0924d99eb2a7d92a6c
62Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
63Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
64Signed-off-by: Jonathan Liu <net147@gmail.com>
65---
66 mkspecs/features/qt.prf | 13 +++++++++++++
67 mkspecs/features/qt_common.prf | 2 +-
68 2 files changed, 14 insertions(+), 1 deletion(-)
69
70diff --git a/mkspecs/features/qt.prf b/mkspecs/features/qt.prf
71index 98f794c485..bd8b7b52e4 100644
72--- a/mkspecs/features/qt.prf
73+++ b/mkspecs/features/qt.prf
74@@ -315,6 +315,19 @@ contains(TEMPLATE, .*app) {
75 QTPLUGIN = $$manualplugs $$autoplugs
76 }
77
78+contains(TEMPLATE, .*lib) {
79+ pkgconfig_prefix_replace.match = "prefix=$$[QT_SYSROOT]"
80+ pkgconfig_prefix_replace.replace = "prefix="
81+ pkgconfig_prefix_replace.CONFIG = path
82+ QMAKE_PKGCONFIG_INSTALL_REPLACE += pkgconfig_prefix_replace
83+
84+ # drop -L/usr/lib in .prl files
85+ prl_replace.match = "-L\$${libdir}"
86+ prl_replace.replace = ""
87+ prl_replace.CONFIG = path
88+ QMAKE_PRL_INSTALL_REPLACE += prl_replace
89+}
90+
91 QT_PLUGIN_VERIFY = DEPLOYMENT_PLUGIN
92 qtConfig(static) {
93 QT_PLUGIN_VERIFY += QTPLUGIN
94diff --git a/mkspecs/features/qt_common.prf b/mkspecs/features/qt_common.prf
95index d30983f62b..6da07e032c 100644
96--- a/mkspecs/features/qt_common.prf
97+++ b/mkspecs/features/qt_common.prf
98@@ -37,7 +37,7 @@ contains(TEMPLATE, .*lib) {
99 lib_replace.replace =
100 } else {
101 lib_replace.match = $$rplbase/lib
102- lib_replace.replace = $$qqt_libdir
103+ lib_replace.replace = "\$$\\{libdir}"
104 }
105 lib_replace.CONFIG = path
106 QMAKE_PRL_INSTALL_REPLACE += lib_replace
diff --git a/recipes-qt/qt5/qtbase/0006-Disable-all-unknown-features-instead-of-erroring-out.patch b/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch
index c2b44381..8538901f 100644
--- a/recipes-qt/qt5/qtbase/0006-Disable-all-unknown-features-instead-of-erroring-out.patch
+++ b/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch
@@ -1,4 +1,4 @@
1From 8acdd69a4083080f4dd40001eee30209ec5de0b2 Mon Sep 17 00:00:00 2001 1From 6ecb404346525a92f4c8926aa285662f3f5010b3 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@qt.io> 2From: Samuli Piippo <samuli.piippo@qt.io>
3Date: Mon, 24 Oct 2016 09:45:18 +0300 3Date: Mon, 24 Oct 2016 09:45:18 +0300
4Subject: [PATCH] Disable all unknown features instead of erroring out 4Subject: [PATCH] Disable all unknown features instead of erroring out
@@ -10,10 +10,10 @@ Change-Id: Ib884fe33cac74439f9592b145937f6b75ced8447
10 1 file changed, 2 insertions(+), 1 deletion(-) 10 1 file changed, 2 insertions(+), 1 deletion(-)
11 11
12diff --git a/mkspecs/features/qt_configure.prf b/mkspecs/features/qt_configure.prf 12diff --git a/mkspecs/features/qt_configure.prf b/mkspecs/features/qt_configure.prf
13index eaaa161270..fa3addae11 100644 13index 966c43108c..32f0dd0041 100644
14--- a/mkspecs/features/qt_configure.prf 14--- a/mkspecs/features/qt_configure.prf
15+++ b/mkspecs/features/qt_configure.prf 15+++ b/mkspecs/features/qt_configure.prf
16@@ -1035,7 +1035,8 @@ defineReplace(qtConfEvaluateSingleExpression) { 16@@ -1180,7 +1180,8 @@ defineReplace(qtConfEvaluateSingleExpression) {
17 error("Expression '$$1' is accessing field '$$var' of non-local feature $${feature}.") 17 error("Expression '$$1' is accessing field '$$var' of non-local feature $${feature}.")
18 return($$result) 18 return($$result)
19 } 19 }
diff --git a/recipes-qt/qt5/qtbase/0005-configure-bump-path-length-from-256-to-512-character.patch b/recipes-qt/qt5/qtbase/0005-configure-bump-path-length-from-256-to-512-character.patch
deleted file mode 100644
index 0c0d2c73..00000000
--- a/recipes-qt/qt5/qtbase/0005-configure-bump-path-length-from-256-to-512-character.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From be9179d2cbb9009794940092d30dac7800708964 Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denys@ti.com>
3Date: Tue, 25 Aug 2015 10:05:15 -0400
4Subject: [PATCH] configure: bump path length from 256 to 512 characters
5
6Increase the path length that gets hardcoded into generated config.cpp file
7from 256 to 512 characters, as nativesdk path can be quite long.
8
9Also update length of EXT_PREFIX and HOST_PREFIX now.
10
11Signed-off-by: Denys Dmytriyenko <denys@ti.com>
12---
13 configure | 6 +++---
14 1 file changed, 3 insertions(+), 3 deletions(-)
15
16diff --git a/configure b/configure
17index 579a96d787..5af98cd77e 100755
18--- a/configure
19+++ b/configure
20@@ -1551,10 +1551,10 @@ cat > "$outpath/src/corelib/global/qconfig.cpp.new" <<EOF
21 static const char qt_configure_installation [12+11] = "qt_instdate=2012-12-20";
22
23 /* Installation Info */
24-static const char qt_configure_prefix_path_str [256 + 12] = "qt_prfxpath=$QT_INSTALL_PREFIX";
25+static const char qt_configure_prefix_path_str [512 + 12] = "qt_prfxpath=$QT_INSTALL_PREFIX";
26 #ifdef QT_BUILD_QMAKE
27-static const char qt_configure_ext_prefix_path_str [256 + 12] = "qt_epfxpath=$QT_EXT_PREFIX";
28-static const char qt_configure_host_prefix_path_str [256 + 12] = "qt_hpfxpath=$QT_HOST_PREFIX";
29+static const char qt_configure_ext_prefix_path_str [512 + 12] = "qt_epfxpath=$QT_EXT_PREFIX";
30+static const char qt_configure_host_prefix_path_str [512 + 12] = "qt_hpfxpath=$QT_HOST_PREFIX";
31 #endif
32
33 static const short qt_configure_str_offsets[] = {
diff --git a/recipes-qt/qt5/qtbase/0007-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch b/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch
index b70b0d35..253815bd 100644
--- a/recipes-qt/qt5/qtbase/0007-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch
+++ b/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch
@@ -1,4 +1,4 @@
1From 5316b420dc408d3a47daa3ba854a7883c911f6b9 Mon Sep 17 00:00:00 2001 1From 3730ac03a1473a0e1fdfe1537b73818ab99961e9 Mon Sep 17 00:00:00 2001
2From: Pascal Bach <pascal.bach@siemens.com> 2From: Pascal Bach <pascal.bach@siemens.com>
3Date: Wed, 11 May 2016 15:20:41 +0200 3Date: Wed, 11 May 2016 15:20:41 +0200
4Subject: [PATCH] Pretend Qt5 wasn't found if OE_QMAKE_PATH_EXTERNAL_HOST_BINS 4Subject: [PATCH] Pretend Qt5 wasn't found if OE_QMAKE_PATH_EXTERNAL_HOST_BINS
@@ -30,7 +30,7 @@ Signed-off-by: Pascal Bach <pascal.bach@siemens.com>
30 2 files changed, 10 insertions(+) 30 2 files changed, 10 insertions(+)
31 31
32diff --git a/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in b/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in 32diff --git a/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in b/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in
33index d2358cae4b..feb73c02a5 100644 33index 4f342d67d7..202b723882 100644
34--- a/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in 34--- a/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in
35+++ b/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in 35+++ b/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in
36@@ -9,6 +9,11 @@ if (CMAKE_VERSION VERSION_LESS 3.0.0) 36@@ -9,6 +9,11 @@ if (CMAKE_VERSION VERSION_LESS 3.0.0)
diff --git a/recipes-qt/qt5/qtbase/0008-Delete-qlonglong-and-qulonglong.patch b/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch
index c992586a..68e4b201 100644
--- a/recipes-qt/qt5/qtbase/0008-Delete-qlonglong-and-qulonglong.patch
+++ b/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch
@@ -1,4 +1,4 @@
1From 2755a80114433e75f08fbb0df0fee9f7526172aa Mon Sep 17 00:00:00 2001 1From 2fa6b447302abbaf1fd710e94b92692a300baaaf Mon Sep 17 00:00:00 2001
2From: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> 2From: Huang Qiyu <huangqy.fnst@cn.fujitsu.com>
3Date: Wed, 7 Jun 2017 21:00:49 +0900 3Date: Wed, 7 Jun 2017 21:00:49 +0900
4Subject: [PATCH] Delete qlonglong and qulonglong 4Subject: [PATCH] Delete qlonglong and qulonglong
diff --git a/recipes-qt/qt5/qtbase/0010-Replace-pthread_yield-with-sched_yield.patch b/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
index 5c625e08..678de529 100644
--- a/recipes-qt/qt5/qtbase/0010-Replace-pthread_yield-with-sched_yield.patch
+++ b/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
@@ -1,4 +1,4 @@
1From bbe822066913c0908b6366009517c19e828e1458 Mon Sep 17 00:00:00 2001 1From 41d7028d2239a98a76cc91939edb2cb728019d08 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 27 Jul 2017 08:02:51 -0700 3Date: Thu, 27 Jul 2017 08:02:51 -0700
4Subject: [PATCH] Replace pthread_yield with sched_yield 4Subject: [PATCH] Replace pthread_yield with sched_yield
@@ -14,7 +14,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
14 2 files changed, 5 insertions(+), 4 deletions(-) 14 2 files changed, 5 insertions(+), 4 deletions(-)
15 15
16diff --git a/tests/auto/corelib/kernel/qmetatype/tst_qmetatype.cpp b/tests/auto/corelib/kernel/qmetatype/tst_qmetatype.cpp 16diff --git a/tests/auto/corelib/kernel/qmetatype/tst_qmetatype.cpp b/tests/auto/corelib/kernel/qmetatype/tst_qmetatype.cpp
17index 7d9f56ef38..bc115ef61d 100644 17index b6106e8c9e..6d6ea0b739 100644
18--- a/tests/auto/corelib/kernel/qmetatype/tst_qmetatype.cpp 18--- a/tests/auto/corelib/kernel/qmetatype/tst_qmetatype.cpp
19+++ b/tests/auto/corelib/kernel/qmetatype/tst_qmetatype.cpp 19+++ b/tests/auto/corelib/kernel/qmetatype/tst_qmetatype.cpp
20@@ -34,7 +34,7 @@ 20@@ -34,7 +34,7 @@
@@ -36,10 +36,10 @@ index 7d9f56ef38..bc115ef61d 100644
36 QMetaType info(tp); 36 QMetaType info(tp);
37 if (!info.isValid()) { 37 if (!info.isValid()) {
38diff --git a/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp b/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp 38diff --git a/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp b/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp
39index fe1057bdde..e23e97b259 100644 39index 7340817ade..f34162a105 100644
40--- a/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp 40--- a/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp
41+++ b/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp 41+++ b/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp
42@@ -75,6 +75,7 @@ 42@@ -77,6 +77,7 @@
43 #include <stdlib.h> 43 #include <stdlib.h>
44 #include <sys/stat.h> 44 #include <sys/stat.h>
45 #include <unistd.h> 45 #include <unistd.h>
@@ -47,7 +47,7 @@ index fe1057bdde..e23e97b259 100644
47 #endif 47 #endif
48 48
49 #include "private/qhostinfo_p.h" 49 #include "private/qhostinfo_p.h"
50@@ -2129,8 +2130,8 @@ public slots: 50@@ -2131,8 +2132,8 @@ public slots:
51 51
52 #if defined(Q_OS_MAC) 52 #if defined(Q_OS_MAC)
53 pthread_yield_np(); 53 pthread_yield_np();
diff --git a/recipes-qt/qt5/qtbase/0011-Always-build-uic.patch b/recipes-qt/qt5/qtbase/0009-Always-build-uic.patch
index 244cc0bc..118a4f29 100644
--- a/recipes-qt/qt5/qtbase/0011-Always-build-uic.patch
+++ b/recipes-qt/qt5/qtbase/0009-Always-build-uic.patch
@@ -1,4 +1,4 @@
1From 7c42f9b42c34d75f6c8e21e55af9b0e58f5743cc Mon Sep 17 00:00:00 2001 1From 294e4c718407e66631ce36c37258217c9adb3f83 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com> 2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Sat, 16 Nov 2013 00:32:30 +0100 3Date: Sat, 16 Nov 2013 00:32:30 +0100
4Subject: [PATCH] Always build uic 4Subject: [PATCH] Always build uic
@@ -14,10 +14,10 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
14 1 file changed, 1 insertion(+), 1 deletion(-) 14 1 file changed, 1 insertion(+), 1 deletion(-)
15 15
16diff --git a/src/src.pro b/src/src.pro 16diff --git a/src/src.pro b/src/src.pro
17index 90d7e2b76c..4ca6b0bd01 100644 17index 43fc06f2e5..1e9d4dcc0d 100644
18--- a/src/src.pro 18--- a/src/src.pro
19+++ b/src/src.pro 19+++ b/src/src.pro
20@@ -188,7 +188,7 @@ qtConfig(gui) { 20@@ -203,7 +203,7 @@ qtConfig(gui) {
21 } 21 }
22 } 22 }
23 } 23 }
diff --git a/recipes-qt/qt5/qtbase/0009-tst_qstring-Disable-Wformat-security-with-clang-as-w.patch b/recipes-qt/qt5/qtbase/0009-tst_qstring-Disable-Wformat-security-with-clang-as-w.patch
deleted file mode 100644
index 609cd846..00000000
--- a/recipes-qt/qt5/qtbase/0009-tst_qstring-Disable-Wformat-security-with-clang-as-w.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From 7bab0171601bc769403be62d145164137f1b7b66 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 25 Jul 2017 19:40:52 -0700
4Subject: [PATCH] tst_qstring: Disable Wformat-security with clang as well
5
6Currently, its only disabled for gcc, but we need to disable
7it with clang as well in order to compile it successfully with
8clang
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 tests/auto/corelib/tools/qstring/tst_qstring.cpp | 3 +++
13 1 file changed, 3 insertions(+)
14
15diff --git a/tests/auto/corelib/tools/qstring/tst_qstring.cpp b/tests/auto/corelib/tools/qstring/tst_qstring.cpp
16index a0a872710c..20a9a9f9db 100644
17--- a/tests/auto/corelib/tools/qstring/tst_qstring.cpp
18+++ b/tests/auto/corelib/tools/qstring/tst_qstring.cpp
19@@ -1066,6 +1066,9 @@ void tst_QString::acc_01()
20
21 QT_WARNING_PUSH
22 QT_WARNING_DISABLE_GCC("-Wformat-security")
23+#ifdef __clang__
24+QT_WARNING_DISABLE_CLANG("-Wformat-security")
25+#endif
26
27 void tst_QString::isNull()
28 {
diff --git a/recipes-qt/qt5/qtbase/0011-configure-paths-for-target-qmake-properly.patch b/recipes-qt/qt5/qtbase/0011-configure-paths-for-target-qmake-properly.patch
deleted file mode 100644
index c527c131..00000000
--- a/recipes-qt/qt5/qtbase/0011-configure-paths-for-target-qmake-properly.patch
+++ /dev/null
@@ -1,75 +0,0 @@
1From b8e94df3d49be69659e8dfb0809c614f73c21706 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Fri, 13 Nov 2015 12:36:11 +0100
4Subject: [PATCH] configure paths for target qmake properly
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9to use this patch in all qtbase/qtbase-native(sdk) changes ore made
10conditionally based on QT_CROSS_COMPILE
11
12Upstream-Status: Inappropriate [OE specific]
13
14Change-Id: I2b2f00c496216e98fbe14801f9e840ef5333c4b6
15Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
16Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
17---
18 configure | 23 +++++++++++++++++++----
19 1 file changed, 19 insertions(+), 4 deletions(-)
20
21diff --git a/configure b/configure
22index 5af98cd77e..34dedafe91 100755
23--- a/configure
24+++ b/configure
25@@ -1500,8 +1500,13 @@ if [ -z "$QT_REL_HOST_DATA" ]; then
26 fi
27 fi
28
29-shortxspec=`echo $XQMAKESPEC | sed "s,^${relpath}/mkspecs/,,"`
30-shortspec=`echo $QMAKESPEC | sed "s,^${relpath}/mkspecs/,,"`
31+if [ "$QT_CROSS_COMPILE" = "yes" ] ; then
32+ shortxspec=linux-g++
33+ shortspec=linux-g++
34+else
35+ shortxspec=`echo $XQMAKESPEC | sed "s,^${relpath}/mkspecs/,,"`
36+ shortspec=`echo $QMAKESPEC | sed "s,^${relpath}/mkspecs/,,"`
37+fi
38
39 QT_CONFIGURE_STR_OFF=0
40
41@@ -1534,7 +1539,11 @@ QT_CONFIGURE_STRS_ALL=$QT_CONFIGURE_STRS
42
43 QT_CONFIGURE_STR_OFFSETS=
44 QT_CONFIGURE_STRS=
45-addConfStr "$CFG_SYSROOT"
46+if [ "$QT_CROSS_COMPILE" = "yes" ] ; then
47+ addConfStr ""
48+else
49+ addConfStr "$CFG_SYSROOT"
50+fi
51 addConfStr "$QT_REL_HOST_BINS"
52 addConfStr "$QT_REL_HOST_LIBS"
53 addConfStr "$QT_REL_HOST_DATA"
54@@ -1546,6 +1555,12 @@ addConfStr "$shortspec"
55 #-------------------------------------------------------------------------------
56 [ -d "$outpath/src/corelib/global" ] || mkdir -p "$outpath/src/corelib/global"
57
58+if [ "$QT_CROSS_COMPILE" = "yes" ] ; then
59+ QT_TARGET_PREFIX=$QT_EXT_PREFIX
60+else
61+ QT_TARGET_PREFIX=$QT_HOST_PREFIX
62+fi
63+
64 cat > "$outpath/src/corelib/global/qconfig.cpp.new" <<EOF
65 /* Installation date */
66 static const char qt_configure_installation [12+11] = "qt_instdate=2012-12-20";
67@@ -1554,7 +1569,7 @@ static const char qt_configure_installation [12+11] = "qt_instdate=2
68 static const char qt_configure_prefix_path_str [512 + 12] = "qt_prfxpath=$QT_INSTALL_PREFIX";
69 #ifdef QT_BUILD_QMAKE
70 static const char qt_configure_ext_prefix_path_str [512 + 12] = "qt_epfxpath=$QT_EXT_PREFIX";
71-static const char qt_configure_host_prefix_path_str [512 + 12] = "qt_hpfxpath=$QT_HOST_PREFIX";
72+static const char qt_configure_host_prefix_path_str [512 + 12] = "qt_hpfxpath=$QT_TARGET_PREFIX";
73 #endif
74
75 static const short qt_configure_str_offsets[] = {