summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtbase_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtbase_git.bb')
-rw-r--r--recipes-qt/qt5/qtbase_git.bb26
1 files changed, 9 insertions, 17 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 550968cd..c535380b 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -17,25 +17,18 @@ LIC_FILES_CHKSUM = " \
17# common for qtbase-native, qtbase-nativesdk and qtbase 17# common for qtbase-native, qtbase-nativesdk and qtbase
18SRC_URI += "\ 18SRC_URI += "\
19 file://0001-Add-linux-oe-g-platform.patch \ 19 file://0001-Add-linux-oe-g-platform.patch \
20 file://0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch \ 20 file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
21 file://0003-Add-external-hostbindir-option.patch \ 21 file://0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch \
22 file://0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch \ 22 file://0004-configure-bump-path-length-from-256-to-512-character.patch \
23 file://0005-configure-bump-path-length-from-256-to-512-character.patch \ 23 file://0005-Disable-all-unknown-features-instead-of-erroring-out.patch \
24 file://0006-Disable-all-unknown-features-instead-of-erroring-out.patch \ 24 file://0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch \
25 file://0007-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch \ 25 file://0007-Delete-qlonglong-and-qulonglong.patch \
26 file://0008-Delete-qlonglong-and-qulonglong.patch \ 26 file://0008-Replace-pthread_yield-with-sched_yield.patch \
27 file://0009-tst_qstring-Disable-Wformat-security-with-clang-as-w.patch \
28 file://0010-Replace-pthread_yield-with-sched_yield.patch \
29 file://run-ptest \ 27 file://run-ptest \
30" 28"
31 29
32inherit ptest 30inherit ptest
33 31
34# only for target qtbase
35SRC_URI += "\
36 file://0011-configure-paths-for-target-qmake-properly.patch \
37"
38
39# LGPL-3.0 is used only in src/plugins/platforms/android/extract.cpp 32# LGPL-3.0 is used only in src/plugins/platforms/android/extract.cpp
40 33
41# for syncqt 34# for syncqt
@@ -66,7 +59,7 @@ LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -f
66# separate some parts of PACKAGECONFIG which are often changed 59# separate some parts of PACKAGECONFIG which are often changed
67PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)}" 60PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)}"
68PACKAGECONFIG_FB ?= "${@bb.utils.contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)}" 61PACKAGECONFIG_FB ?= "${@bb.utils.contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)}"
69PACKAGECONFIG_X11 ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xcb xrender xinput2 glib xkb xkbcommon-evdev', '', d)}" 62PACKAGECONFIG_X11 ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xcb xinput2 glib xkb xkbcommon-evdev', '', d)}"
70PACKAGECONFIG_FONTS ?= "" 63PACKAGECONFIG_FONTS ?= ""
71PACKAGECONFIG_SYSTEM ?= "jpeg libpng zlib" 64PACKAGECONFIG_SYSTEM ?= "jpeg libpng zlib"
72PACKAGECONFIG_DISTRO ?= "" 65PACKAGECONFIG_DISTRO ?= ""
@@ -130,7 +123,6 @@ PACKAGECONFIG[sql-db2] = "-sql-db2,-no-sql-db2"
130PACKAGECONFIG[sql-sqlite2] = "-sql-sqlite2,-no-sql-sqlite2,sqlite" 123PACKAGECONFIG[sql-sqlite2] = "-sql-sqlite2,-no-sql-sqlite2,sqlite"
131PACKAGECONFIG[sql-sqlite] = "-sql-sqlite -system-sqlite,-no-sql-sqlite,sqlite3" 124PACKAGECONFIG[sql-sqlite] = "-sql-sqlite -system-sqlite,-no-sql-sqlite,sqlite3"
132PACKAGECONFIG[xinput2] = "-xinput2,-no-xinput2,libxi" 125PACKAGECONFIG[xinput2] = "-xinput2,-no-xinput2,libxi"
133PACKAGECONFIG[xrender] = "-xrender,-no-xrender,libxrender"
134PACKAGECONFIG[iconv] = "-iconv,-no-iconv,virtual/libiconv" 126PACKAGECONFIG[iconv] = "-iconv,-no-iconv,virtual/libiconv"
135PACKAGECONFIG[xkb] = "-xkb,-no-xkb -no-xkbcommon,libxkbcommon" 127PACKAGECONFIG[xkb] = "-xkb,-no-xkb -no-xkbcommon,libxkbcommon"
136PACKAGECONFIG[xkbcommon-evdev] = "-xkbcommon-evdev,-no-xkbcommon-evdev,libxkbcommon,xkeyboard-config" 128PACKAGECONFIG[xkbcommon-evdev] = "-xkbcommon-evdev,-no-xkbcommon-evdev,libxkbcommon,xkeyboard-config"
@@ -228,4 +220,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
228 220
229RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}" 221RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
230 222
231SRCREV = "49dc9aa409d727824f26b246054a22b5a7dd5980" 223SRCREV = "f6b36eaafec24b4c67efff621d380a4ca4257d0b"