summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtlocation/0001-Make-mapbox-gl-build-configurable.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtlocation/0001-Make-mapbox-gl-build-configurable.patch')
-rw-r--r--recipes-qt/qt5/qtlocation/0001-Make-mapbox-gl-build-configurable.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtlocation/0001-Make-mapbox-gl-build-configurable.patch b/recipes-qt/qt5/qtlocation/0001-Make-mapbox-gl-build-configurable.patch
new file mode 100644
index 00000000..49fcff6b
--- /dev/null
+++ b/recipes-qt/qt5/qtlocation/0001-Make-mapbox-gl-build-configurable.patch
@@ -0,0 +1,27 @@
1From f7c76b91e726a0e63e5226eb6e89b13e0c3509b7 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@qt.io>
3Date: Wed, 7 Jun 2017 13:29:29 +0300
4Subject: [PATCH] Make mapbox-gl build configurable
5
6mapbox-gl-native won't compile for ARMv5 or older, so disable the
7build by default.
8
9Task-number: QTBUG-61289
10Change-Id: I5f26200f2735b363c3c322f9035b331b9159c47b
11---
12 src/plugins/geoservices/geoservices.pro | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/src/plugins/geoservices/geoservices.pro b/src/plugins/geoservices/geoservices.pro
16index 0810d39..03fc119 100644
17--- a/src/plugins/geoservices/geoservices.pro
18+++ b/src/plugins/geoservices/geoservices.pro
19@@ -6,7 +6,7 @@ qtConfig(concurrent) {
20 SUBDIRS += osm
21 }
22
23-qtConfig(c++14):!win32|mingw:!qnx {
24+mapboxgl:qtConfig(c++14):!win32|mingw:!qnx {
25 !exists(../../3rdparty/mapbox-gl-native/CMakeLists.txt) {
26 warning("Submodule mapbox-gl-native does not exist. Run 'git submodule update --init' on qtlocation.")
27 } else {