summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtremoteobjects_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtremoteobjects_git.bb')
-rw-r--r--recipes-qt/qt5/qtremoteobjects_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtremoteobjects_git.bb b/recipes-qt/qt5/qtremoteobjects_git.bb
new file mode 100644
index 00000000..f563818d
--- /dev/null
+++ b/recipes-qt/qt5/qtremoteobjects_git.bb
@@ -0,0 +1,27 @@
1LICENSE = "BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 ) & ( GPL-2.0+ | LGPL-3.0 ) | The-Qt-Company-Commercial"
2LIC_FILES_CHKSUM = " \
3 file://LICENSE.GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
4 file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
5 file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \
6 file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
7"
8
9require qt5.inc
10require qt5-git.inc
11
12DEPENDS += "qtbase qtdeclarative qtremoteobjects-native"
13
14SRC_URI += " \
15 file://0001-Allow-a-tools-only-build.patch \
16"
17
18PACKAGECONFIG ??= ""
19PACKAGECONFIG_class-native ??= "tools-only"
20PACKAGECONFIG_class-nativesdk ??= "tools-only"
21PACKAGECONFIG[tools-only] = "CONFIG+=tools-only"
22
23EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
24
25SRCREV = "ae0b101884b05355e3a7bc06dbca722ad3d08d0f"
26
27BBCLASSEXTEND += "native nativesdk"