summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtwebengine_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb30
1 files changed, 15 insertions, 15 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 148bbdbd..f8bebfc5 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -28,7 +28,7 @@ DEPENDS += " \
28 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxcomposite libxcursor libxi libxrandr libxtst', '', d)} \ 28 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxcomposite libxcursor libxi libxrandr libxtst', '', d)} \
29" 29"
30 30
31DEPENDS_append_libc-musl = " libexecinfo" 31DEPENDS:append:libc-musl = " libexecinfo"
32 32
33EXTRA_QMAKEVARS_CONFIGURE += "-feature-webengine-system-ninja -no-feature-webengine-system-gn" 33EXTRA_QMAKEVARS_CONFIGURE += "-feature-webengine-system-ninja -no-feature-webengine-system-gn"
34EXTRA_QMAKEVARS_PRE += "CONFIG+=force_debug_info" 34EXTRA_QMAKEVARS_PRE += "CONFIG+=force_debug_info"
@@ -67,12 +67,12 @@ PACKAGECONFIG[spellchecker] = "-feature-webengine-spellchecker,-no-feature-weben
67EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}" 67EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
68 68
69COMPATIBLE_MACHINE = "(-)" 69COMPATIBLE_MACHINE = "(-)"
70COMPATIBLE_MACHINE_x86 = "(.*)" 70COMPATIBLE_MACHINE:x86 = "(.*)"
71COMPATIBLE_MACHINE_x86-64 = "(.*)" 71COMPATIBLE_MACHINE:x86-64 = "(.*)"
72COMPATIBLE_MACHINE_armv6 = "(.*)" 72COMPATIBLE_MACHINE:armv6 = "(.*)"
73COMPATIBLE_MACHINE_armv7a = "(.*)" 73COMPATIBLE_MACHINE:armv7a = "(.*)"
74COMPATIBLE_MACHINE_armv7ve = "(.*)" 74COMPATIBLE_MACHINE:armv7ve = "(.*)"
75COMPATIBLE_MACHINE_aarch64 = "(.*)" 75COMPATIBLE_MACHINE:aarch64 = "(.*)"
76 76
77inherit qmake5 77inherit qmake5
78inherit gettext 78inherit gettext
@@ -108,7 +108,7 @@ do_configure() {
108 ${EXTRA_QMAKEVARS_CONFIGURE} 108 ${EXTRA_QMAKEVARS_CONFIGURE}
109} 109}
110 110
111do_configure_prepend_libc-musl() { 111do_configure:prepend:libc-musl() {
112 for f in `find ${S}/src/3rdparty/chromium/third_party/ffmpeg/chromium/config/Chromium/linux/ -name config.h -o -name config.asm`; do 112 for f in `find ${S}/src/3rdparty/chromium/third_party/ffmpeg/chromium/config/Chromium/linux/ -name config.h -o -name config.asm`; do
113 sed -i -e "s:define HAVE_SYSCTL 1:define HAVE_SYSCTL 0:g" $f 113 sed -i -e "s:define HAVE_SYSCTL 1:define HAVE_SYSCTL 0:g" $f
114 done 114 done
@@ -116,17 +116,17 @@ do_configure_prepend_libc-musl() {
116 116
117do_compile[progress] = "outof:^\[(\d+)/(\d+)\]\s+" 117do_compile[progress] = "outof:^\[(\d+)/(\d+)\]\s+"
118 118
119do_install_append() { 119do_install:append() {
120 sed -i 's@ -Wl,--start-group.*-Wl,--end-group@@g; s@[^ ]*${B}[^ ]* @@g' ${D}${libdir}/pkgconfig/Qt5WebEngineCore.pc 120 sed -i 's@ -Wl,--start-group.*-Wl,--end-group@@g; s@[^ ]*${B}[^ ]* @@g' ${D}${libdir}/pkgconfig/Qt5WebEngineCore.pc
121} 121}
122 122
123# for /usr/share/qt5/qtwebengine_resources.pak 123# for /usr/share/qt5/qtwebengine_resources.pak
124FILES_${PN} += "${OE_QMAKE_PATH_QT_TRANSLATIONS} ${OE_QMAKE_PATH_QT_DATA}" 124FILES:${PN} += "${OE_QMAKE_PATH_QT_TRANSLATIONS} ${OE_QMAKE_PATH_QT_DATA}"
125 125
126# Chromium uses libpci to determine which optimizations/workarounds to apply 126# Chromium uses libpci to determine which optimizations/workarounds to apply
127RDEPENDS_${PN}_append_x86 = " libpci" 127RDEPENDS:${PN}:append:x86 = " libpci"
128 128
129RDEPENDS_${PN}-examples += " \ 129RDEPENDS:${PN}-examples += " \
130 ${PN}-qmlplugins \ 130 ${PN}-qmlplugins \
131 qtquickcontrols-qmlplugins \ 131 qtquickcontrols-qmlplugins \
132 qtdeclarative-qmlplugins \ 132 qtdeclarative-qmlplugins \
@@ -140,7 +140,7 @@ SRC_URI += " \
140 ${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \ 140 ${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \
141 file://0001-Force-host-toolchain-configuration.patch \ 141 file://0001-Force-host-toolchain-configuration.patch \
142" 142"
143SRC_URI_append_libc-musl = "\ 143SRC_URI:append:libc-musl = "\
144 file://0002-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \ 144 file://0002-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \
145 file://0003-musl-link-against-libexecinfo.patch \ 145 file://0003-musl-link-against-libexecinfo.patch \
146" 146"
@@ -159,7 +159,7 @@ SRC_URI += " \
159 file://chromium/0007-chromium-fix-build-after-y2038-changes-in-glibc.patch;patchdir=src/3rdparty \ 159 file://chromium/0007-chromium-fix-build-after-y2038-changes-in-glibc.patch;patchdir=src/3rdparty \
160" 160"
161 161
162SRC_URI_append_libc-musl = "\ 162SRC_URI:append:libc-musl = "\
163 file://chromium/0005-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \ 163 file://chromium/0005-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \
164 file://chromium/0006-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \ 164 file://chromium/0006-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \
165 file://chromium/0007-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \ 165 file://chromium/0007-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \
@@ -183,4 +183,4 @@ SRCREV = "${SRCREV_qtwebengine}"
183SRCREV_FORMAT = "qtwebengine_chromium" 183SRCREV_FORMAT = "qtwebengine_chromium"
184 184
185# WARNING: qtwebengine-5.5.99+5.6.0-rc+gitAUTOINC+3f02c25de4_779a2388fc-r0 do_package_qa: QA Issue: ELF binary '/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/qtwebengine/5.5.99+5.6.0-rc+gitAUTOINC+3f02c25de4_779a2388fc-r0/packages-split/qtwebengine/usr/lib/libQt5WebEngineCore.so.5.6.0' has relocations in .text [textrel] 185# WARNING: qtwebengine-5.5.99+5.6.0-rc+gitAUTOINC+3f02c25de4_779a2388fc-r0 do_package_qa: QA Issue: ELF binary '/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/qtwebengine/5.5.99+5.6.0-rc+gitAUTOINC+3f02c25de4_779a2388fc-r0/packages-split/qtwebengine/usr/lib/libQt5WebEngineCore.so.5.6.0' has relocations in .text [textrel]
186INSANE_SKIP_${PN} += "textrel" 186INSANE_SKIP:${PN} += "textrel"