summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2019-05-22 18:41:20 +0100
committerAndrei Gherzan <andrei@gherzan.ro>2019-05-22 18:48:24 +0100
commita709fa31b0bc8a61444196e0914e249b0f9f97a2 (patch)
tree35e08996f84cf325ed3c0b7fa9a440fbe842d485
parent7059c374512f1c1c0df9ecab0703d11438bdf78b (diff)
downloadmeta-raspberrypi-ag/dri.tar.gz
mesa-gl: Fix build after poky switched to mesonag/dri
Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
-rw-r--r--recipes-graphics/mesa/mesa-gl/0001-Allow-enable-DRI-without-DRI-drivers.patch45
-rw-r--r--recipes-graphics/mesa/mesa-gl_%.bbappend5
2 files changed, 50 insertions, 0 deletions
diff --git a/recipes-graphics/mesa/mesa-gl/0001-Allow-enable-DRI-without-DRI-drivers.patch b/recipes-graphics/mesa/mesa-gl/0001-Allow-enable-DRI-without-DRI-drivers.patch
new file mode 100644
index 0000000..52d670a
--- /dev/null
+++ b/recipes-graphics/mesa/mesa-gl/0001-Allow-enable-DRI-without-DRI-drivers.patch
@@ -0,0 +1,45 @@
1From 8e0a58c8eea7ed70071cac139655700fdfa16445 Mon Sep 17 00:00:00 2001
2From: Andrei Gherzan <andrei@gherzan.ro>
3Date: Wed, 22 May 2019 18:32:07 +0100
4Subject: [PATCH] Allow enable DRI without DRI drivers
5
6Upstream-status: Pending
7Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
8---
9 meson.build | 2 +-
10 meson_options.txt | 6 ++++++
11 2 files changed, 7 insertions(+), 1 deletion(-)
12
13diff --git a/meson.build b/meson.build
14index 53d02e3..9a8578f 100644
15--- a/meson.build
16+++ b/meson.build
17@@ -119,7 +119,7 @@ with_dri_r200 = _drivers.contains('r200')
18 with_dri_nouveau = _drivers.contains('nouveau')
19 with_dri_swrast = _drivers.contains('swrast')
20
21-with_dri = _drivers.length() != 0 and _drivers != ['']
22+with_dri = get_option('dri') or (_drivers.length() != 0 and _drivers != [''])
23
24 _drivers = get_option('gallium-drivers')
25 if _drivers.contains('auto')
26diff --git a/meson_options.txt b/meson_options.txt
27index ccf7065..5174320 100644
28--- a/meson_options.txt
29+++ b/meson_options.txt
30@@ -34,6 +34,12 @@ option(
31 choices : ['auto', 'true', 'false'],
32 description : 'enable support for dri3'
33 )
34+option(
35+ 'dri',
36+ type : 'boolean',
37+ value : false,
38+ description : 'enable support for dri'
39+)
40 option(
41 'dri-drivers',
42 type : 'array',
43--
442.17.1
45
diff --git a/recipes-graphics/mesa/mesa-gl_%.bbappend b/recipes-graphics/mesa/mesa-gl_%.bbappend
index 08ec1c5..778b08d 100644
--- a/recipes-graphics/mesa/mesa-gl_%.bbappend
+++ b/recipes-graphics/mesa/mesa-gl_%.bbappend
@@ -1,6 +1,11 @@
1FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
2SRC_URI += "file://0001-Allow-enable-DRI-without-DRI-drivers.patch"
3
1PACKAGECONFIG_append_rpi = " gbm" 4PACKAGECONFIG_append_rpi = " gbm"
2PROVIDES_append_rpi = " virtual/libgbm" 5PROVIDES_append_rpi = " virtual/libgbm"
3 6
4do_install_append_rpi() { 7do_install_append_rpi() {
5 rm -rf ${D}${includedir}/KHR/khrplatform.h 8 rm -rf ${D}${includedir}/KHR/khrplatform.h
6} 9}
10
11EXTRA_OEMESON += "-Ddri=true"