summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.com>2021-08-03 14:43:18 +0100
committerAndrei Gherzan <andrei@gherzan.com>2021-08-03 14:44:07 +0100
commit844827a3d265fbde0467c5687747662ceb49a938 (patch)
tree545d37c830534b43da2533efd402d9068cc15148 /recipes-devtools/python
parent8dc3a310883ea87cd9900442f46f20bb08e57583 (diff)
downloadmeta-raspberrypi-ag/override.tar.gz
Convert to new override syntaxag/override
converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Andrei Gherzan <andrei@gherzan.com>
Diffstat (limited to 'recipes-devtools/python')
-rw-r--r--recipes-devtools/python/python3-adafruit-blinka_6.2.2.bb6
-rw-r--r--recipes-devtools/python/python3-adafruit-circuitpython-busdevice_5.0.5.bb2
-rw-r--r--recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb2
-rw-r--r--recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb2
-rw-r--r--recipes-devtools/python/python3-adafruit-circuitpython-pca9685_3.3.4.bb2
-rw-r--r--recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.4.bb2
-rw-r--r--recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb2
-rw-r--r--recipes-devtools/python/python3-adafruit-pureio_1.1.8.bb2
-rw-r--r--recipes-devtools/python/rpio_0.10.0.bb2
9 files changed, 11 insertions, 11 deletions
diff --git a/recipes-devtools/python/python3-adafruit-blinka_6.2.2.bb b/recipes-devtools/python/python3-adafruit-blinka_6.2.2.bb
index dc9e680..4659ad9 100644
--- a/recipes-devtools/python/python3-adafruit-blinka_6.2.2.bb
+++ b/recipes-devtools/python/python3-adafruit-blinka_6.2.2.bb
@@ -12,7 +12,7 @@ inherit setuptools3
12 12
13DEPENDS += "python3-setuptools-scm-native" 13DEPENDS += "python3-setuptools-scm-native"
14 14
15do_install_append() { 15do_install:append() {
16# it ships ./bcm283x/pulseio/libgpiod_pulsein which is a prebuilt 16# it ships ./bcm283x/pulseio/libgpiod_pulsein which is a prebuilt
17# 32bit binary therefore we should make this specific to 32bit rpi machines (based on bcm283x) only 17# 32bit binary therefore we should make this specific to 32bit rpi machines (based on bcm283x) only
18 if [ ${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '1', '0', d)} = "0" ]; then 18 if [ ${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '1', '0', d)} = "0" ]; then
@@ -20,11 +20,11 @@ do_install_append() {
20 fi 20 fi
21} 21}
22 22
23RDEPENDS_${PN} += " \ 23RDEPENDS:${PN} += " \
24 libgpiod \ 24 libgpiod \
25 python3-adafruit-platformdetect \ 25 python3-adafruit-platformdetect \
26 python3-adafruit-pureio \ 26 python3-adafruit-pureio \
27 python3-core \ 27 python3-core \
28" 28"
29 29
30RDEPENDS_${PN}_append_rpi = " rpi-gpio" 30RDEPENDS:${PN}:append:rpi = " rpi-gpio"
diff --git a/recipes-devtools/python/python3-adafruit-circuitpython-busdevice_5.0.5.bb b/recipes-devtools/python/python3-adafruit-circuitpython-busdevice_5.0.5.bb
index 7c1a267..7cccd58 100644
--- a/recipes-devtools/python/python3-adafruit-circuitpython-busdevice_5.0.5.bb
+++ b/recipes-devtools/python/python3-adafruit-circuitpython-busdevice_5.0.5.bb
@@ -12,7 +12,7 @@ inherit setuptools3
12 12
13DEPENDS += "python3-setuptools-scm-native" 13DEPENDS += "python3-setuptools-scm-native"
14 14
15RDEPENDS_${PN} += " \ 15RDEPENDS:${PN} += " \
16 python3-adafruit-blinka \ 16 python3-adafruit-blinka \
17 python3-core \ 17 python3-core \
18" 18"
diff --git a/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb b/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb
index b0475e6..c5da4ac 100644
--- a/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb
+++ b/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb
@@ -12,7 +12,7 @@ inherit setuptools3
12 12
13DEPENDS += "python3-setuptools-scm-native" 13DEPENDS += "python3-setuptools-scm-native"
14 14
15RDEPENDS_${PN} += " \ 15RDEPENDS:${PN} += " \
16 python3-adafruit-blinka \ 16 python3-adafruit-blinka \
17 python3-core \ 17 python3-core \
18" 18"
diff --git a/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb b/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb
index 12a63f3..eacca3e 100644
--- a/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb
+++ b/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb
@@ -12,7 +12,7 @@ inherit setuptools3
12 12
13DEPENDS += "python3-setuptools-scm-native" 13DEPENDS += "python3-setuptools-scm-native"
14 14
15RDEPENDS_${PN} += " \ 15RDEPENDS:${PN} += " \
16 python3-adafruit-blinka \ 16 python3-adafruit-blinka \
17 python3-adafruit-circuitpython-busdevice \ 17 python3-adafruit-circuitpython-busdevice \
18 python3-adafruit-circuitpython-motor \ 18 python3-adafruit-circuitpython-motor \
diff --git a/recipes-devtools/python/python3-adafruit-circuitpython-pca9685_3.3.4.bb b/recipes-devtools/python/python3-adafruit-circuitpython-pca9685_3.3.4.bb
index a46b130..23cd786 100644
--- a/recipes-devtools/python/python3-adafruit-circuitpython-pca9685_3.3.4.bb
+++ b/recipes-devtools/python/python3-adafruit-circuitpython-pca9685_3.3.4.bb
@@ -12,7 +12,7 @@ inherit setuptools3
12 12
13DEPENDS += "python3-setuptools-scm-native" 13DEPENDS += "python3-setuptools-scm-native"
14 14
15RDEPENDS_${PN} += " \ 15RDEPENDS:${PN} += " \
16 python3-adafruit-blinka \ 16 python3-adafruit-blinka \
17 python3-adafruit-circuitpython-busdevice \ 17 python3-adafruit-circuitpython-busdevice \
18 python3-adafruit-circuitpython-register \ 18 python3-adafruit-circuitpython-register \
diff --git a/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.4.bb b/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.4.bb
index 7d0377b..ccf5eaa 100644
--- a/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.4.bb
+++ b/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.4.bb
@@ -12,4 +12,4 @@ DEPENDS += "python3-setuptools-scm-native"
12 12
13inherit setuptools3 13inherit setuptools3
14 14
15RDEPENDS_${PN} += "python3-core" 15RDEPENDS:${PN} += "python3-core"
diff --git a/recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb b/recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb
index 0574c53..b88affa 100644
--- a/recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb
+++ b/recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb
@@ -12,4 +12,4 @@ inherit setuptools3
12 12
13DEPENDS += "python3-setuptools-scm-native" 13DEPENDS += "python3-setuptools-scm-native"
14 14
15RDEPENDS_${PN} += "python3-core" 15RDEPENDS:${PN} += "python3-core"
diff --git a/recipes-devtools/python/python3-adafruit-pureio_1.1.8.bb b/recipes-devtools/python/python3-adafruit-pureio_1.1.8.bb
index a59e6f5..63c7166 100644
--- a/recipes-devtools/python/python3-adafruit-pureio_1.1.8.bb
+++ b/recipes-devtools/python/python3-adafruit-pureio_1.1.8.bb
@@ -12,7 +12,7 @@ inherit setuptools3
12 12
13DEPENDS += "python3-setuptools-scm-native" 13DEPENDS += "python3-setuptools-scm-native"
14 14
15RDEPENDS_${PN} += " \ 15RDEPENDS:${PN} += " \
16 python3-core \ 16 python3-core \
17 python3-ctypes \ 17 python3-ctypes \
18 python3-fcntl \ 18 python3-fcntl \
diff --git a/recipes-devtools/python/rpio_0.10.0.bb b/recipes-devtools/python/rpio_0.10.0.bb
index d5653cb..1c8075f 100644
--- a/recipes-devtools/python/rpio_0.10.0.bb
+++ b/recipes-devtools/python/rpio_0.10.0.bb
@@ -14,7 +14,7 @@ inherit setuptools3
14 14
15COMPATIBLE_MACHINE = "^rpi$" 15COMPATIBLE_MACHINE = "^rpi$"
16 16
17RDEPENDS_${PN} = "\ 17RDEPENDS:${PN} = "\
18 python3-logging \ 18 python3-logging \
19 python3-threading \ 19 python3-threading \
20" 20"