diff options
author | Andrei Gherzan <andrei@gherzan.com> | 2021-08-03 14:43:18 +0100 |
---|---|---|
committer | Andrei Gherzan <andrei@gherzan.com> | 2021-08-03 14:44:07 +0100 |
commit | 844827a3d265fbde0467c5687747662ceb49a938 (patch) | |
tree | 545d37c830534b43da2533efd402d9068cc15148 /recipes-devtools/python | |
parent | 8dc3a310883ea87cd9900442f46f20bb08e57583 (diff) | |
download | meta-raspberrypi-ag/override.tar.gz |
Convert to new override syntaxag/override
converting the metadata to use ":" as the override character instead of
"_".
Signed-off-by: Andrei Gherzan <andrei@gherzan.com>
Diffstat (limited to 'recipes-devtools/python')
9 files changed, 11 insertions, 11 deletions
diff --git a/recipes-devtools/python/python3-adafruit-blinka_6.2.2.bb b/recipes-devtools/python/python3-adafruit-blinka_6.2.2.bb index dc9e680..4659ad9 100644 --- a/recipes-devtools/python/python3-adafruit-blinka_6.2.2.bb +++ b/recipes-devtools/python/python3-adafruit-blinka_6.2.2.bb | |||
@@ -12,7 +12,7 @@ inherit setuptools3 | |||
12 | 12 | ||
13 | DEPENDS += "python3-setuptools-scm-native" | 13 | DEPENDS += "python3-setuptools-scm-native" |
14 | 14 | ||
15 | do_install_append() { | 15 | do_install:append() { |
16 | # it ships ./bcm283x/pulseio/libgpiod_pulsein which is a prebuilt | 16 | # it ships ./bcm283x/pulseio/libgpiod_pulsein which is a prebuilt |
17 | # 32bit binary therefore we should make this specific to 32bit rpi machines (based on bcm283x) only | 17 | # 32bit binary therefore we should make this specific to 32bit rpi machines (based on bcm283x) only |
18 | if [ ${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '1', '0', d)} = "0" ]; then | 18 | if [ ${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '1', '0', d)} = "0" ]; then |
@@ -20,11 +20,11 @@ do_install_append() { | |||
20 | fi | 20 | fi |
21 | } | 21 | } |
22 | 22 | ||
23 | RDEPENDS_${PN} += " \ | 23 | RDEPENDS:${PN} += " \ |
24 | libgpiod \ | 24 | libgpiod \ |
25 | python3-adafruit-platformdetect \ | 25 | python3-adafruit-platformdetect \ |
26 | python3-adafruit-pureio \ | 26 | python3-adafruit-pureio \ |
27 | python3-core \ | 27 | python3-core \ |
28 | " | 28 | " |
29 | 29 | ||
30 | RDEPENDS_${PN}_append_rpi = " rpi-gpio" | 30 | RDEPENDS:${PN}:append:rpi = " rpi-gpio" |
diff --git a/recipes-devtools/python/python3-adafruit-circuitpython-busdevice_5.0.5.bb b/recipes-devtools/python/python3-adafruit-circuitpython-busdevice_5.0.5.bb index 7c1a267..7cccd58 100644 --- a/recipes-devtools/python/python3-adafruit-circuitpython-busdevice_5.0.5.bb +++ b/recipes-devtools/python/python3-adafruit-circuitpython-busdevice_5.0.5.bb | |||
@@ -12,7 +12,7 @@ inherit setuptools3 | |||
12 | 12 | ||
13 | DEPENDS += "python3-setuptools-scm-native" | 13 | DEPENDS += "python3-setuptools-scm-native" |
14 | 14 | ||
15 | RDEPENDS_${PN} += " \ | 15 | RDEPENDS:${PN} += " \ |
16 | python3-adafruit-blinka \ | 16 | python3-adafruit-blinka \ |
17 | python3-core \ | 17 | python3-core \ |
18 | " | 18 | " |
diff --git a/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb b/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb index b0475e6..c5da4ac 100644 --- a/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb +++ b/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb | |||
@@ -12,7 +12,7 @@ inherit setuptools3 | |||
12 | 12 | ||
13 | DEPENDS += "python3-setuptools-scm-native" | 13 | DEPENDS += "python3-setuptools-scm-native" |
14 | 14 | ||
15 | RDEPENDS_${PN} += " \ | 15 | RDEPENDS:${PN} += " \ |
16 | python3-adafruit-blinka \ | 16 | python3-adafruit-blinka \ |
17 | python3-core \ | 17 | python3-core \ |
18 | " | 18 | " |
diff --git a/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb b/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb index 12a63f3..eacca3e 100644 --- a/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb +++ b/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb | |||
@@ -12,7 +12,7 @@ inherit setuptools3 | |||
12 | 12 | ||
13 | DEPENDS += "python3-setuptools-scm-native" | 13 | DEPENDS += "python3-setuptools-scm-native" |
14 | 14 | ||
15 | RDEPENDS_${PN} += " \ | 15 | RDEPENDS:${PN} += " \ |
16 | python3-adafruit-blinka \ | 16 | python3-adafruit-blinka \ |
17 | python3-adafruit-circuitpython-busdevice \ | 17 | python3-adafruit-circuitpython-busdevice \ |
18 | python3-adafruit-circuitpython-motor \ | 18 | python3-adafruit-circuitpython-motor \ |
diff --git a/recipes-devtools/python/python3-adafruit-circuitpython-pca9685_3.3.4.bb b/recipes-devtools/python/python3-adafruit-circuitpython-pca9685_3.3.4.bb index a46b130..23cd786 100644 --- a/recipes-devtools/python/python3-adafruit-circuitpython-pca9685_3.3.4.bb +++ b/recipes-devtools/python/python3-adafruit-circuitpython-pca9685_3.3.4.bb | |||
@@ -12,7 +12,7 @@ inherit setuptools3 | |||
12 | 12 | ||
13 | DEPENDS += "python3-setuptools-scm-native" | 13 | DEPENDS += "python3-setuptools-scm-native" |
14 | 14 | ||
15 | RDEPENDS_${PN} += " \ | 15 | RDEPENDS:${PN} += " \ |
16 | python3-adafruit-blinka \ | 16 | python3-adafruit-blinka \ |
17 | python3-adafruit-circuitpython-busdevice \ | 17 | python3-adafruit-circuitpython-busdevice \ |
18 | python3-adafruit-circuitpython-register \ | 18 | python3-adafruit-circuitpython-register \ |
diff --git a/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.4.bb b/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.4.bb index 7d0377b..ccf5eaa 100644 --- a/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.4.bb +++ b/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.4.bb | |||
@@ -12,4 +12,4 @@ DEPENDS += "python3-setuptools-scm-native" | |||
12 | 12 | ||
13 | inherit setuptools3 | 13 | inherit setuptools3 |
14 | 14 | ||
15 | RDEPENDS_${PN} += "python3-core" | 15 | RDEPENDS:${PN} += "python3-core" |
diff --git a/recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb b/recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb index 0574c53..b88affa 100644 --- a/recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb +++ b/recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb | |||
@@ -12,4 +12,4 @@ inherit setuptools3 | |||
12 | 12 | ||
13 | DEPENDS += "python3-setuptools-scm-native" | 13 | DEPENDS += "python3-setuptools-scm-native" |
14 | 14 | ||
15 | RDEPENDS_${PN} += "python3-core" | 15 | RDEPENDS:${PN} += "python3-core" |
diff --git a/recipes-devtools/python/python3-adafruit-pureio_1.1.8.bb b/recipes-devtools/python/python3-adafruit-pureio_1.1.8.bb index a59e6f5..63c7166 100644 --- a/recipes-devtools/python/python3-adafruit-pureio_1.1.8.bb +++ b/recipes-devtools/python/python3-adafruit-pureio_1.1.8.bb | |||
@@ -12,7 +12,7 @@ inherit setuptools3 | |||
12 | 12 | ||
13 | DEPENDS += "python3-setuptools-scm-native" | 13 | DEPENDS += "python3-setuptools-scm-native" |
14 | 14 | ||
15 | RDEPENDS_${PN} += " \ | 15 | RDEPENDS:${PN} += " \ |
16 | python3-core \ | 16 | python3-core \ |
17 | python3-ctypes \ | 17 | python3-ctypes \ |
18 | python3-fcntl \ | 18 | python3-fcntl \ |
diff --git a/recipes-devtools/python/rpio_0.10.0.bb b/recipes-devtools/python/rpio_0.10.0.bb index d5653cb..1c8075f 100644 --- a/recipes-devtools/python/rpio_0.10.0.bb +++ b/recipes-devtools/python/rpio_0.10.0.bb | |||
@@ -14,7 +14,7 @@ inherit setuptools3 | |||
14 | 14 | ||
15 | COMPATIBLE_MACHINE = "^rpi$" | 15 | COMPATIBLE_MACHINE = "^rpi$" |
16 | 16 | ||
17 | RDEPENDS_${PN} = "\ | 17 | RDEPENDS:${PN} = "\ |
18 | python3-logging \ | 18 | python3-logging \ |
19 | python3-threading \ | 19 | python3-threading \ |
20 | " | 20 | " |