summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-omx-1.14/0005-Don-t-abort-gst_omx_video_dec_set_format-if-there-s-.patch24
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-omx-1.16/0001-Don-t-try-to-acquire-buffer-when-src-pad-isn-t-activ.patch (renamed from recipes-multimedia/gstreamer/gstreamer1.0-omx-1.14/0001-Don-t-try-to-acquire-buffer-when-src-pad-isn-t-activ.patch)14
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-omx-1.16/0001-config-files-path.patch (renamed from recipes-multimedia/gstreamer/gstreamer1.0-omx-1.14/0001-config-files-path.patch)0
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-omx-1.16/0003-no-timeout-on-get-state.patch (renamed from recipes-multimedia/gstreamer/gstreamer1.0-omx-1.14/0003-no-timeout-on-get-state.patch)6
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-omx-1.16/0004-Properly-handle-drain-requests-while-flushing.patch (renamed from recipes-multimedia/gstreamer/gstreamer1.0-omx-1.14/0004-Properly-handle-drain-requests-while-flushing.patch)12
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-omx-1.16/0005-Don-t-abort-gst_omx_video_dec_set_format-if-there-s-.patch36
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-omx_1.16%.bbappend (renamed from recipes-multimedia/gstreamer/gstreamer1.0-omx_1.14%.bbappend)2
7 files changed, 54 insertions, 40 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.14/0005-Don-t-abort-gst_omx_video_dec_set_format-if-there-s-.patch b/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.14/0005-Don-t-abort-gst_omx_video_dec_set_format-if-there-s-.patch
deleted file mode 100644
index ed8645e..0000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.14/0005-Don-t-abort-gst_omx_video_dec_set_format-if-there-s-.patch
+++ /dev/null
@@ -1,24 +0,0 @@
1From 0d2ad639e6158c8023c157e206ef3ff7abdc089c Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Enrique=20Oca=C3=B1a=20Gonz=C3=A1lez?= <eocanha@igalia.com>
3Date: Fri, 4 Dec 2015 18:39:59 +0100
4Subject: [PATCH] Don't abort gst_omx_video_dec_set_format() if there's a
5 timeout releasing the buffers taken by the egl_render out port
6
7---
8 omx/gstomxvideodec.c | 5 ++++-
9 1 file changed, 4 insertions(+), 1 deletion(-)
10
11Index: gst-omx-1.14.0/omx/gstomxvideodec.c
12===================================================================
13--- gst-omx-1.14.0.orig/omx/gstomxvideodec.c
14+++ gst-omx-1.14.0/omx/gstomxvideodec.c
15@@ -2214,7 +2214,9 @@ gst_omx_video_dec_disable (GstOMXVideoDe
16 return FALSE;
17 if (gst_omx_port_wait_buffers_released (out_port,
18 1 * GST_SECOND) != OMX_ErrorNone)
19+#if !(defined (USE_OMX_TARGET_RPI) && defined (HAVE_GST_GL))
20 return FALSE;
21+#endif
22 if (gst_omx_video_dec_deallocate_output_buffers (self) != OMX_ErrorNone)
23 return FALSE;
24 if (gst_omx_port_wait_enabled (out_port, 1 * GST_SECOND) != OMX_ErrorNone)
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.14/0001-Don-t-try-to-acquire-buffer-when-src-pad-isn-t-activ.patch b/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.16/0001-Don-t-try-to-acquire-buffer-when-src-pad-isn-t-activ.patch
index 85fea67..c8af7da 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.14/0001-Don-t-try-to-acquire-buffer-when-src-pad-isn-t-activ.patch
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.16/0001-Don-t-try-to-acquire-buffer-when-src-pad-isn-t-activ.patch
@@ -1,8 +1,10 @@
1From cfb432fcd8868c7a4f32010c61e47e2bf0ff80c6 Mon Sep 17 00:00:00 2001 1From 160181edf5fc73288abfe99fa04de4a550cd9c65 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Enrique=20Oca=C3=B1a=20Gonz=C3=A1lez?= <eocanha@igalia.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 25 May 2015 14:53:35 +0200 3Date: Thu, 11 Feb 2016 12:53:20 -0800
4Subject: [PATCH] Don't try to acquire buffer when src pad isn't active 4Subject: [PATCH] Don't try to acquire buffer when src pad isn't active
5 5
6From: =?UTF-8?q?Enrique=20Oca=C3=B1a=20Gonz=C3=A1lez?= <eocanha@igalia.com>
7
6This solves a race condition when setting the pipeline from PAUSE to 8This solves a race condition when setting the pipeline from PAUSE to
7NULL while the decoder loop is still running. Without this patch, the 9NULL while the decoder loop is still running. Without this patch, the
8thread which interacts with the decode sink pad gets blocked here: 10thread which interacts with the decode sink pad gets blocked here:
@@ -29,11 +31,11 @@ arrive:
29 1 file changed, 5 insertions(+) 31 1 file changed, 5 insertions(+)
30 32
31diff --git a/omx/gstomxvideodec.c b/omx/gstomxvideodec.c 33diff --git a/omx/gstomxvideodec.c b/omx/gstomxvideodec.c
32index d12ee8f..fb0100a 100644 34index abe6e30..c4dc33f 100644
33--- a/omx/gstomxvideodec.c 35--- a/omx/gstomxvideodec.c
34+++ b/omx/gstomxvideodec.c 36+++ b/omx/gstomxvideodec.c
35@@ -1250,6 +1250,11 @@ gst_omx_video_dec_loop (GstOMXVideoDec * self) 37@@ -1598,6 +1598,11 @@ gst_omx_video_dec_loop (GstOMXVideoDec * self)
36 GstClockTimeDiff deadline; 38 GstOMXAcquireBufferReturn acq_return;
37 OMX_ERRORTYPE err; 39 OMX_ERRORTYPE err;
38 40
39+ if (!gst_pad_is_active(GST_VIDEO_DECODER_SRC_PAD (self))) { 41+ if (!gst_pad_is_active(GST_VIDEO_DECODER_SRC_PAD (self))) {
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.14/0001-config-files-path.patch b/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.16/0001-config-files-path.patch
index 6903c17..6903c17 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.14/0001-config-files-path.patch
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.16/0001-config-files-path.patch
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.14/0003-no-timeout-on-get-state.patch b/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.16/0003-no-timeout-on-get-state.patch
index 4124bcc..4342326 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.14/0003-no-timeout-on-get-state.patch
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.16/0003-no-timeout-on-get-state.patch
@@ -1,4 +1,4 @@
1From 02e49cba402a783fa1b30e445b83a5c280949c1e Mon Sep 17 00:00:00 2001 1From 21f776bff596bc0bd09708efa6497f8bdcd065c0 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 13 Feb 2016 11:42:29 -0800 3Date: Sat, 13 Feb 2016 11:42:29 -0800
4 4
@@ -7,10 +7,10 @@ Date: Sat, 13 Feb 2016 11:42:29 -0800
7 1 file changed, 2 insertions(+), 2 deletions(-) 7 1 file changed, 2 insertions(+), 2 deletions(-)
8 8
9diff --git a/omx/gstomxvideodec.c b/omx/gstomxvideodec.c 9diff --git a/omx/gstomxvideodec.c b/omx/gstomxvideodec.c
10index fb0100a..bad6335 100644 10index c4dc33f..ba5304f 100644
11--- a/omx/gstomxvideodec.c 11--- a/omx/gstomxvideodec.c
12+++ b/omx/gstomxvideodec.c 12+++ b/omx/gstomxvideodec.c
13@@ -1713,9 +1713,9 @@ gst_omx_video_dec_stop (GstVideoDecoder * decoder) 13@@ -2021,9 +2021,9 @@ gst_omx_video_dec_stop (GstVideoDecoder * decoder)
14 g_cond_broadcast (&self->drain_cond); 14 g_cond_broadcast (&self->drain_cond);
15 g_mutex_unlock (&self->drain_lock); 15 g_mutex_unlock (&self->drain_lock);
16 16
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.14/0004-Properly-handle-drain-requests-while-flushing.patch b/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.16/0004-Properly-handle-drain-requests-while-flushing.patch
index 3c9dd2c..144ced6 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.14/0004-Properly-handle-drain-requests-while-flushing.patch
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.16/0004-Properly-handle-drain-requests-while-flushing.patch
@@ -1,4 +1,4 @@
1From f00912f0628aff15e882bdc1619f5de1ddf5c720 Mon Sep 17 00:00:00 2001 1From 140bf8548843a98b0af2ddc1765ab59c16c8994c Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Enrique=20Oca=C3=B1a=20Gonz=C3=A1lez?= <eocanha@igalia.com> 2From: =?UTF-8?q?Enrique=20Oca=C3=B1a=20Gonz=C3=A1lez?= <eocanha@igalia.com>
3Date: Tue, 17 Nov 2015 16:51:27 +0000 3Date: Tue, 17 Nov 2015 16:51:27 +0000
4Subject: [PATCH] Properly handle drain requests while flushing 4Subject: [PATCH] Properly handle drain requests while flushing
@@ -10,11 +10,11 @@ the drain request, leaving the decoder input thread waiting forever.
10 omx/gstomx.c | 7 +++++++ 10 omx/gstomx.c | 7 +++++++
11 1 file changed, 7 insertions(+) 11 1 file changed, 7 insertions(+)
12 12
13Index: gst-omx-1.14.0/omx/gstomx.c 13diff --git a/omx/gstomx.c b/omx/gstomx.c
14=================================================================== 14index 038ce32..5202d33 100644
15--- gst-omx-1.14.0.orig/omx/gstomx.c 15--- a/omx/gstomx.c
16+++ gst-omx-1.14.0/omx/gstomx.c 16+++ b/omx/gstomx.c
17@@ -837,6 +837,13 @@ gst_omx_component_new (GstObject * paren 17@@ -1011,6 +1011,13 @@ gst_omx_component_new (GstObject * parent, const gchar * core_name,
18 18
19 g_mutex_lock (&comp->lock); 19 g_mutex_lock (&comp->lock);
20 gst_omx_component_handle_messages (comp); 20 gst_omx_component_handle_messages (comp);
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.16/0005-Don-t-abort-gst_omx_video_dec_set_format-if-there-s-.patch b/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.16/0005-Don-t-abort-gst_omx_video_dec_set_format-if-there-s-.patch
new file mode 100644
index 0000000..3245294
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.16/0005-Don-t-abort-gst_omx_video_dec_set_format-if-there-s-.patch
@@ -0,0 +1,36 @@
1From cf6cf2060c5a7a7ddc0396a0c20c234fc56c79b6 Mon Sep 17 00:00:00 2001
2From: Andrei Gherzan <andrei@gherzan.ro>
3Date: Tue, 28 May 2019 18:02:24 +0100
4Subject: [PATCH] Don't abort gst_omx_video_dec_set_format() if there's a
5 timeout releasing the buffers taken by the egl_render out port
6
7From 0d2ad639e6158c8023c157e206ef3ff7abdc089c Mon Sep 17 00:00:00 2001
8From: =?UTF-8?q?Enrique=20Oca=C3=B1a=20Gonz=C3=A1lez?=
9<eocanha@igalia.com>
10Date: Fri, 4 Dec 2015 18:39:59 +0100
11Subject: [PATCH] Don't abort gst_omx_video_dec_set_format() if there's a
12timeout releasing the buffers taken by the egl_render out port
13
14Upstream-status: Pending
15Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
16---
17 omx/gstomxvideodec.c | 2 ++
18 1 file changed, 2 insertions(+)
19
20diff --git a/omx/gstomxvideodec.c b/omx/gstomxvideodec.c
21index ba5304f..8bd5d3d 100644
22--- a/omx/gstomxvideodec.c
23+++ b/omx/gstomxvideodec.c
24@@ -2229,7 +2229,9 @@ gst_omx_video_dec_disable (GstOMXVideoDec * self)
25 return FALSE;
26 if (gst_omx_port_wait_buffers_released (out_port,
27 1 * GST_SECOND) != OMX_ErrorNone)
28+#if !(defined (USE_OMX_TARGET_RPI) && defined (HAVE_GST_GL))
29 return FALSE;
30+#endif
31 if (!gst_omx_video_dec_deallocate_output_buffers (self))
32 return FALSE;
33 if (gst_omx_port_wait_enabled (out_port, 1 * GST_SECOND) != OMX_ErrorNone)
34--
352.17.1
36
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.14%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.16%.bbappend
index cb7986b..79b35c4 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.14%.bbappend
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.16%.bbappend
@@ -9,4 +9,4 @@ SRC_URI_append_rpi = " \
9 file://0005-Don-t-abort-gst_omx_video_dec_set_format-if-there-s-.patch \ 9 file://0005-Don-t-abort-gst_omx_video_dec_set_format-if-there-s-.patch \
10" 10"
11 11
12FILESEXTRAPATHS_prepend := "${THISDIR}/gstreamer1.0-omx-1.14:" 12FILESEXTRAPATHS_prepend := "${THISDIR}/gstreamer1.0-omx-1.16:"