summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0001-Don-t-try-to-acquire-buffer-when-src-pad-isn-t-activ.patch10
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0001-config-files-path.patch49
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0002-fix-decoder-flushing.patch13
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0003-no-timeout-on-get-state.patch12
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0004-Properly-handle-drain-requests-while-flushing.patch18
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0005-Don-t-abort-gst_omx_video_dec_set_format-if-there-s-.patch9
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-omx/0001-config-files-path.patch137
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-omx/0003-no-timeout-on-get-state.patch16
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-omx/0004-Properly-handle-drain-requests-while-flushing.patch69
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-omx/0005-Don-t-abort-gst_omx_video_dec_set_format-if-there-s-.patch30
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend (renamed from recipes-multimedia/gstreamer/gstreamer1.0-omx%.bbappend)0
11 files changed, 67 insertions, 296 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0001-Don-t-try-to-acquire-buffer-when-src-pad-isn-t-activ.patch b/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0001-Don-t-try-to-acquire-buffer-when-src-pad-isn-t-activ.patch
index 815a7c2..85fea67 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0001-Don-t-try-to-acquire-buffer-when-src-pad-isn-t-activ.patch
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0001-Don-t-try-to-acquire-buffer-when-src-pad-isn-t-activ.patch
@@ -1,4 +1,4 @@
1From 2e111e52f96f0b942abda120c30a876629bd73fc Mon Sep 17 00:00:00 2001 1From cfb432fcd8868c7a4f32010c61e47e2bf0ff80c6 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Enrique=20Oca=C3=B1a=20Gonz=C3=A1lez?= <eocanha@igalia.com> 2From: =?UTF-8?q?Enrique=20Oca=C3=B1a=20Gonz=C3=A1lez?= <eocanha@igalia.com>
3Date: Mon, 25 May 2015 14:53:35 +0200 3Date: Mon, 25 May 2015 14:53:35 +0200
4Subject: [PATCH] Don't try to acquire buffer when src pad isn't active 4Subject: [PATCH] Don't try to acquire buffer when src pad isn't active
@@ -23,15 +23,16 @@ arrive:
23 gst_omx_video_dec_loop() 23 gst_omx_video_dec_loop()
24 gst_omx_port_acquire_buffer() 24 gst_omx_port_acquire_buffer()
25 gst_omx_component_wait_message() 25 gst_omx_component_wait_message()
26
26--- 27---
27 omx/gstomxvideodec.c | 5 +++++ 28 omx/gstomxvideodec.c | 5 +++++
28 1 file changed, 5 insertions(+) 29 1 file changed, 5 insertions(+)
29 30
30diff --git a/omx/gstomxvideodec.c b/omx/gstomxvideodec.c 31diff --git a/omx/gstomxvideodec.c b/omx/gstomxvideodec.c
31index cd24944..57a61dd 100644 32index d12ee8f..fb0100a 100644
32--- a/omx/gstomxvideodec.c 33--- a/omx/gstomxvideodec.c
33+++ b/omx/gstomxvideodec.c 34+++ b/omx/gstomxvideodec.c
34@@ -1247,6 +1247,11 @@ gst_omx_video_dec_loop (GstOMXVideoDec * self) 35@@ -1250,6 +1250,11 @@ gst_omx_video_dec_loop (GstOMXVideoDec * self)
35 GstClockTimeDiff deadline; 36 GstClockTimeDiff deadline;
36 OMX_ERRORTYPE err; 37 OMX_ERRORTYPE err;
37 38
@@ -43,6 +44,3 @@ index cd24944..57a61dd 100644
43 #if defined (USE_OMX_TARGET_RPI) && defined (HAVE_GST_GL) 44 #if defined (USE_OMX_TARGET_RPI) && defined (HAVE_GST_GL)
44 port = self->eglimage ? self->egl_out_port : self->dec_out_port; 45 port = self->eglimage ? self->egl_out_port : self->dec_out_port;
45 #else 46 #else
46--
471.8.3.2
48
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0001-config-files-path.patch b/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0001-config-files-path.patch
index a7da922..6903c17 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0001-config-files-path.patch
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0001-config-files-path.patch
@@ -1,3 +1,14 @@
1From 0dc88ed881eb8420dad4cf0934a900d85b6ef313 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 11 Feb 2016 12:53:20 -0800
4
5---
6 config/bellagio/gstomx.conf | 8 ++++----
7 config/rpi/gstomx.conf | 22 +++++++++++-----------
8 2 files changed, 15 insertions(+), 15 deletions(-)
9
10diff --git a/config/bellagio/gstomx.conf b/config/bellagio/gstomx.conf
11index 5ca8ba6..8931255 100644
1--- a/config/bellagio/gstomx.conf 12--- a/config/bellagio/gstomx.conf
2+++ b/config/bellagio/gstomx.conf 13+++ b/config/bellagio/gstomx.conf
3@@ -1,6 +1,6 @@ 14@@ -1,6 +1,6 @@
@@ -6,18 +17,18 @@
6-core-name=/usr/local/lib/libomxil-bellagio.so.0 17-core-name=/usr/local/lib/libomxil-bellagio.so.0
7+core-name=/usr/lib/libomxil-bellagio.so.0 18+core-name=/usr/lib/libomxil-bellagio.so.0
8 component-name=OMX.st.video_decoder.mpeg4 19 component-name=OMX.st.video_decoder.mpeg4
9 rank=256 20 rank=257
10 in-port-index=0 21 in-port-index=0
11@@ -9,7 +9,7 @@ 22@@ -9,7 +9,7 @@ hacks=event-port-settings-changed-ndata-parameter-swap;event-port-settings-chang
12 23
13 [omxh264dec] 24 [omxh264dec]
14 type-name=GstOMXH264Dec 25 type-name=GstOMXH264Dec
15-core-name=/usr/local/lib/libomxil-bellagio.so.0 26-core-name=/usr/local/lib/libomxil-bellagio.so.0
16+core-name=/usr/lib/libomxil-bellagio.so.0 27+core-name=/usr/lib/libomxil-bellagio.so.0
17 component-name=OMX.st.video_decoder.avc 28 component-name=OMX.st.video_decoder.avc
18 rank=256 29 rank=257
19 in-port-index=0 30 in-port-index=0
20@@ -18,7 +18,7 @@ 31@@ -18,7 +18,7 @@ hacks=event-port-settings-changed-ndata-parameter-swap;event-port-settings-chang
21 32
22 [omxmpeg4videoenc] 33 [omxmpeg4videoenc]
23 type-name=GstOMXMPEG4VideoEnc 34 type-name=GstOMXMPEG4VideoEnc
@@ -26,7 +37,7 @@
26 component-name=OMX.st.video_encoder.mpeg4 37 component-name=OMX.st.video_encoder.mpeg4
27 rank=0 38 rank=0
28 in-port-index=0 39 in-port-index=0
29@@ -27,7 +27,7 @@ 40@@ -27,7 +27,7 @@ hacks=event-port-settings-changed-ndata-parameter-swap;video-framerate-integer;s
30 41
31 [omxaacenc] 42 [omxaacenc]
32 type-name=GstOMXAACEnc 43 type-name=GstOMXAACEnc
@@ -35,6 +46,8 @@
35 component-name=OMX.st.audio_encoder.aac 46 component-name=OMX.st.audio_encoder.aac
36 rank=0 47 rank=0
37 in-port-index=0 48 in-port-index=0
49diff --git a/config/rpi/gstomx.conf b/config/rpi/gstomx.conf
50index d3ea56a..2508dae 100644
38--- a/config/rpi/gstomx.conf 51--- a/config/rpi/gstomx.conf
39+++ b/config/rpi/gstomx.conf 52+++ b/config/rpi/gstomx.conf
40@@ -1,6 +1,6 @@ 53@@ -1,6 +1,6 @@
@@ -45,7 +58,7 @@
45 component-name=OMX.broadcom.video_decode 58 component-name=OMX.broadcom.video_decode
46 rank=257 59 rank=257
47 in-port-index=130 60 in-port-index=130
48@@ -9,7 +9,7 @@ 61@@ -9,7 +9,7 @@ hacks=no-component-role
49 62
50 [omxmpeg4videodec] 63 [omxmpeg4videodec]
51 type-name=GstOMXMPEG4VideoDec 64 type-name=GstOMXMPEG4VideoDec
@@ -54,7 +67,7 @@
54 component-name=OMX.broadcom.video_decode 67 component-name=OMX.broadcom.video_decode
55 rank=257 68 rank=257
56 in-port-index=130 69 in-port-index=130
57@@ -18,7 +18,7 @@ 70@@ -18,7 +18,7 @@ hacks=no-component-role
58 71
59 [omxh263dec] 72 [omxh263dec]
60 type-name=GstOMXH263Dec 73 type-name=GstOMXH263Dec
@@ -63,7 +76,7 @@
63 component-name=OMX.broadcom.video_decode 76 component-name=OMX.broadcom.video_decode
64 rank=257 77 rank=257
65 in-port-index=130 78 in-port-index=130
66@@ -27,7 +27,7 @@ 79@@ -27,7 +27,7 @@ hacks=no-component-role
67 80
68 [omxh264dec] 81 [omxh264dec]
69 type-name=GstOMXH264Dec 82 type-name=GstOMXH264Dec
@@ -72,7 +85,7 @@
72 component-name=OMX.broadcom.video_decode 85 component-name=OMX.broadcom.video_decode
73 rank=257 86 rank=257
74 in-port-index=130 87 in-port-index=130
75@@ -36,7 +36,7 @@ 88@@ -36,7 +36,7 @@ hacks=no-component-role;signals-premature-eos
76 89
77 [omxtheoradec] 90 [omxtheoradec]
78 type-name=GstOMXTheoraDec 91 type-name=GstOMXTheoraDec
@@ -81,7 +94,7 @@
81 component-name=OMX.broadcom.video_decode 94 component-name=OMX.broadcom.video_decode
82 rank=257 95 rank=257
83 in-port-index=130 96 in-port-index=130
84@@ -45,7 +45,7 @@ 97@@ -45,7 +45,7 @@ hacks=no-component-role
85 98
86 [omxvp8dec] 99 [omxvp8dec]
87 type-name=GstOMXVP8Dec 100 type-name=GstOMXVP8Dec
@@ -90,7 +103,7 @@
90 component-name=OMX.broadcom.video_decode 103 component-name=OMX.broadcom.video_decode
91 rank=257 104 rank=257
92 in-port-index=130 105 in-port-index=130
93@@ -54,7 +54,7 @@ 106@@ -54,7 +54,7 @@ hacks=no-component-role
94 107
95 [omxmjpegdec] 108 [omxmjpegdec]
96 type-name=GstOMXMJPEGDec 109 type-name=GstOMXMJPEGDec
@@ -99,16 +112,16 @@
99 component-name=OMX.broadcom.video_decode 112 component-name=OMX.broadcom.video_decode
100 rank=257 113 rank=257
101 in-port-index=130 114 in-port-index=130
102@@ -63,7 +63,7 @@ 115@@ -63,7 +63,7 @@ hacks=no-component-role
103 116
104 [omxvc1dec] 117 [omxvc1dec]
105 type-name=GstOMXWMVDec 118 type-name=GstOMXWMVDec
106-core-name=/opt/vc/lib/libopenmaxil.so 119-core-name=/opt/vc/lib/libopenmaxil.so
107+core-name=/usr/lib/libopenmaxil.so 120+core-name=/usr/lib/libopenmaxil.so
108 component-name=OMX.broadcom.video_decode 121 component-name=OMX.broadcom.video_decode
109 rank=256 122 rank=257
110 in-port-index=130 123 in-port-index=130
111@@ -73,7 +73,7 @@ 124@@ -73,7 +73,7 @@ sink-template-caps=video/x-wmv,wmvversion=(int)3,format=(string){WMV3,WVC1},widt
112 125
113 [omxh264enc] 126 [omxh264enc]
114 type-name=GstOMXH264Enc 127 type-name=GstOMXH264Enc
@@ -117,21 +130,21 @@
117 component-name=OMX.broadcom.video_encode 130 component-name=OMX.broadcom.video_encode
118 rank=257 131 rank=257
119 in-port-index=200 132 in-port-index=200
120@@ -82,7 +82,7 @@ 133@@ -82,7 +82,7 @@ hacks=no-component-role;no-component-reconfigure
121 134
122 [omxanalogaudiosink] 135 [omxanalogaudiosink]
123 type-name=GstOMXAnalogAudioSink 136 type-name=GstOMXAnalogAudioSink
124-core-name=/opt/vc/lib/libopenmaxil.so 137-core-name=/opt/vc/lib/libopenmaxil.so
125+core-name=/usr/lib/libopenmaxil.so 138+core-name=/usr/lib/libopenmaxil.so
126 component-name=OMX.broadcom.audio_render 139 component-name=OMX.broadcom.audio_render
127 rank=256 140 rank=257
128 in-port-index=100 141 in-port-index=100
129@@ -92,7 +92,7 @@ 142@@ -92,7 +92,7 @@ sink-template-caps=audio/x-raw,format=(string){S16LE,S32LE},layout=(string)inter
130 143
131 [omxhdmiaudiosink] 144 [omxhdmiaudiosink]
132 type-name=GstOMXHdmiAudioSink 145 type-name=GstOMXHdmiAudioSink
133-core-name=/opt/vc/lib/libopenmaxil.so 146-core-name=/opt/vc/lib/libopenmaxil.so
134+core-name=/usr/lib/libopenmaxil.so 147+core-name=/usr/lib/libopenmaxil.so
135 component-name=OMX.broadcom.audio_render 148 component-name=OMX.broadcom.audio_render
136 rank=257 149 rank=258
137 in-port-index=100 150 in-port-index=100
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0002-fix-decoder-flushing.patch b/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0002-fix-decoder-flushing.patch
index d4c7c81..122ddb3 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0002-fix-decoder-flushing.patch
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0002-fix-decoder-flushing.patch
@@ -1,8 +1,16 @@
1From fc4773f36aa31b4ae0fc97d3aa3f94db0c88f194 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 11 Feb 2016 12:53:20 -0800
4
5---
6 omx/gstomx.c | 4 ++--
7 1 file changed, 2 insertions(+), 2 deletions(-)
8
1diff --git a/omx/gstomx.c b/omx/gstomx.c 9diff --git a/omx/gstomx.c b/omx/gstomx.c
2index 69696c4..c382019 100644 10index 0237f3c..45732c3 100644
3--- a/omx/gstomx.c 11--- a/omx/gstomx.c
4+++ b/omx/gstomx.c 12+++ b/omx/gstomx.c
5@@ -1508,8 +1508,8 @@ gst_omx_port_set_flushing (GstOMXPort * port, GstClockTime timeout, 13@@ -1538,8 +1538,8 @@ gst_omx_port_set_flushing (GstOMXPort * port, GstClockTime timeout,
6 last_error = OMX_ErrorNone; 14 last_error = OMX_ErrorNone;
7 gst_omx_component_handle_messages (comp); 15 gst_omx_component_handle_messages (comp);
8 while (signalled && last_error == OMX_ErrorNone && !port->flushed 16 while (signalled && last_error == OMX_ErrorNone && !port->flushed
@@ -13,4 +21,3 @@ index 69696c4..c382019 100644
13 signalled = gst_omx_component_wait_message (comp, timeout); 21 signalled = gst_omx_component_wait_message (comp, timeout);
14 if (signalled) 22 if (signalled)
15 gst_omx_component_handle_messages (comp); 23 gst_omx_component_handle_messages (comp);
16
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0003-no-timeout-on-get-state.patch b/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0003-no-timeout-on-get-state.patch
index 0a0050d..4124bcc 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0003-no-timeout-on-get-state.patch
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0003-no-timeout-on-get-state.patch
@@ -1,8 +1,16 @@
1From 02e49cba402a783fa1b30e445b83a5c280949c1e Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 13 Feb 2016 11:42:29 -0800
4
5---
6 omx/gstomxvideodec.c | 4 ++--
7 1 file changed, 2 insertions(+), 2 deletions(-)
8
1diff --git a/omx/gstomxvideodec.c b/omx/gstomxvideodec.c 9diff --git a/omx/gstomxvideodec.c b/omx/gstomxvideodec.c
2index 0d4e7a1..a0d9c74 100644 10index fb0100a..bad6335 100644
3--- a/omx/gstomxvideodec.c 11--- a/omx/gstomxvideodec.c
4+++ b/omx/gstomxvideodec.c 12+++ b/omx/gstomxvideodec.c
5@@ -1697,9 +1697,9 @@ gst_omx_video_dec_stop (GstVideoDecoder * decoder) 13@@ -1713,9 +1713,9 @@ gst_omx_video_dec_stop (GstVideoDecoder * decoder)
6 g_cond_broadcast (&self->drain_cond); 14 g_cond_broadcast (&self->drain_cond);
7 g_mutex_unlock (&self->drain_lock); 15 g_mutex_unlock (&self->drain_lock);
8 16
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0004-Properly-handle-drain-requests-while-flushing.patch b/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0004-Properly-handle-drain-requests-while-flushing.patch
index 4d10f24..b02072a 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0004-Properly-handle-drain-requests-while-flushing.patch
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0004-Properly-handle-drain-requests-while-flushing.patch
@@ -1,20 +1,20 @@
1From 80dddfd13aaf2fe7272765f8cf291215fe375e28 Mon Sep 17 00:00:00 2001 1From f00912f0628aff15e882bdc1619f5de1ddf5c720 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Enrique=20Oca=C3=B1a=20Gonz=C3=A1lez?= <eocanha@igalia.com> 2From: =?UTF-8?q?Enrique=20Oca=C3=B1a=20Gonz=C3=A1lez?= <eocanha@igalia.com>
3Date: Tue, 17 Nov 2015 16:51:27 +0000 3Date: Tue, 17 Nov 2015 16:51:27 +0000
4Subject: [PATCH] Properly handle drain requests while flushing 4Subject: [PATCH] Properly handle drain requests while flushing
5 5
6Without this commit the decoder streaming thread stops without ever attending 6Without this commit the decoder streaming thread stops without ever attending
7the drain request, leaving the decoder input thread waiting forever. 7the drain request, leaving the decoder input thread waiting forever.
8
8--- 9---
9 omx/gstomx.c | 7 +++++++ 10 omx/gstomx.c | 7 +++++++
10 omx/gstomxvideodec.c | 13 +++++++++++++ 11 1 file changed, 7 insertions(+)
11 2 files changed, 20 insertions(+)
12 12
13Index: gst-omx-1.10.2/omx/gstomx.c 13diff --git a/omx/gstomx.c b/omx/gstomx.c
14=================================================================== 14index 45732c3..784a5d7 100644
15--- gst-omx-1.10.2.orig/omx/gstomx.c 15--- a/omx/gstomx.c
16+++ gst-omx-1.10.2/omx/gstomx.c 16+++ b/omx/gstomx.c
17@@ -737,6 +737,13 @@ gst_omx_component_new (GstObject * paren 17@@ -737,6 +737,13 @@ gst_omx_component_new (GstObject * parent, const gchar * core_name,
18 18
19 g_mutex_lock (&comp->lock); 19 g_mutex_lock (&comp->lock);
20 gst_omx_component_handle_messages (comp); 20 gst_omx_component_handle_messages (comp);
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0005-Don-t-abort-gst_omx_video_dec_set_format-if-there-s-.patch b/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0005-Don-t-abort-gst_omx_video_dec_set_format-if-there-s-.patch
index b7a8753..fdfdd1b 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0005-Don-t-abort-gst_omx_video_dec_set_format-if-there-s-.patch
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-omx-1.12/0005-Don-t-abort-gst_omx_video_dec_set_format-if-there-s-.patch
@@ -1,4 +1,4 @@
1From 12103842d5f347cf245e71071d0c44297bcdb1f9 Mon Sep 17 00:00:00 2001 1From 0d2ad639e6158c8023c157e206ef3ff7abdc089c Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Enrique=20Oca=C3=B1a=20Gonz=C3=A1lez?= <eocanha@igalia.com> 2From: =?UTF-8?q?Enrique=20Oca=C3=B1a=20Gonz=C3=A1lez?= <eocanha@igalia.com>
3Date: Fri, 4 Dec 2015 18:39:59 +0100 3Date: Fri, 4 Dec 2015 18:39:59 +0100
4Subject: [PATCH] Don't abort gst_omx_video_dec_set_format() if there's a 4Subject: [PATCH] Don't abort gst_omx_video_dec_set_format() if there's a
@@ -9,10 +9,10 @@ Subject: [PATCH] Don't abort gst_omx_video_dec_set_format() if there's a
9 1 file changed, 4 insertions(+), 1 deletion(-) 9 1 file changed, 4 insertions(+), 1 deletion(-)
10 10
11diff --git a/omx/gstomxvideodec.c b/omx/gstomxvideodec.c 11diff --git a/omx/gstomxvideodec.c b/omx/gstomxvideodec.c
12index 2368f34..da35e0d 100644 12index bad6335..c63b972 100644
13--- a/omx/gstomxvideodec.c 13--- a/omx/gstomxvideodec.c
14+++ b/omx/gstomxvideodec.c 14+++ b/omx/gstomxvideodec.c
15@@ -1905,8 +1905,11 @@ gst_omx_video_dec_set_format (GstVideoDecoder * decoder, 15@@ -1911,8 +1911,11 @@ gst_omx_video_dec_set_format (GstVideoDecoder * decoder,
16 5 * GST_SECOND) != OMX_ErrorNone) 16 5 * GST_SECOND) != OMX_ErrorNone)
17 return FALSE; 17 return FALSE;
18 if (gst_omx_port_wait_buffers_released (out_port, 18 if (gst_omx_port_wait_buffers_released (out_port,
@@ -25,6 +25,3 @@ index 2368f34..da35e0d 100644
25 if (gst_omx_port_deallocate_buffers (self->dec_in_port) != OMX_ErrorNone) 25 if (gst_omx_port_deallocate_buffers (self->dec_in_port) != OMX_ErrorNone)
26 return FALSE; 26 return FALSE;
27 if (gst_omx_video_dec_deallocate_output_buffers (self) != OMX_ErrorNone) 27 if (gst_omx_video_dec_deallocate_output_buffers (self) != OMX_ErrorNone)
28--
292.1.4
30
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx/0001-config-files-path.patch b/recipes-multimedia/gstreamer/gstreamer1.0-omx/0001-config-files-path.patch
deleted file mode 100644
index a7da922..0000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-omx/0001-config-files-path.patch
+++ /dev/null
@@ -1,137 +0,0 @@
1--- a/config/bellagio/gstomx.conf
2+++ b/config/bellagio/gstomx.conf
3@@ -1,6 +1,6 @@
4 [omxmpeg4videodec]
5 type-name=GstOMXMPEG4VideoDec
6-core-name=/usr/local/lib/libomxil-bellagio.so.0
7+core-name=/usr/lib/libomxil-bellagio.so.0
8 component-name=OMX.st.video_decoder.mpeg4
9 rank=256
10 in-port-index=0
11@@ -9,7 +9,7 @@
12
13 [omxh264dec]
14 type-name=GstOMXH264Dec
15-core-name=/usr/local/lib/libomxil-bellagio.so.0
16+core-name=/usr/lib/libomxil-bellagio.so.0
17 component-name=OMX.st.video_decoder.avc
18 rank=256
19 in-port-index=0
20@@ -18,7 +18,7 @@
21
22 [omxmpeg4videoenc]
23 type-name=GstOMXMPEG4VideoEnc
24-core-name=/usr/local/lib/libomxil-bellagio.so.0
25+core-name=/usr/lib/libomxil-bellagio.so.0
26 component-name=OMX.st.video_encoder.mpeg4
27 rank=0
28 in-port-index=0
29@@ -27,7 +27,7 @@
30
31 [omxaacenc]
32 type-name=GstOMXAACEnc
33-core-name=/usr/local/lib/libomxil-bellagio.so.0
34+core-name=/usr/lib/libomxil-bellagio.so.0
35 component-name=OMX.st.audio_encoder.aac
36 rank=0
37 in-port-index=0
38--- a/config/rpi/gstomx.conf
39+++ b/config/rpi/gstomx.conf
40@@ -1,6 +1,6 @@
41 [omxmpeg2videodec]
42 type-name=GstOMXMPEG2VideoDec
43-core-name=/opt/vc/lib/libopenmaxil.so
44+core-name=/usr/lib/libopenmaxil.so
45 component-name=OMX.broadcom.video_decode
46 rank=257
47 in-port-index=130
48@@ -9,7 +9,7 @@
49
50 [omxmpeg4videodec]
51 type-name=GstOMXMPEG4VideoDec
52-core-name=/opt/vc/lib/libopenmaxil.so
53+core-name=/usr/lib/libopenmaxil.so
54 component-name=OMX.broadcom.video_decode
55 rank=257
56 in-port-index=130
57@@ -18,7 +18,7 @@
58
59 [omxh263dec]
60 type-name=GstOMXH263Dec
61-core-name=/opt/vc/lib/libopenmaxil.so
62+core-name=/usr/lib/libopenmaxil.so
63 component-name=OMX.broadcom.video_decode
64 rank=257
65 in-port-index=130
66@@ -27,7 +27,7 @@
67
68 [omxh264dec]
69 type-name=GstOMXH264Dec
70-core-name=/opt/vc/lib/libopenmaxil.so
71+core-name=/usr/lib/libopenmaxil.so
72 component-name=OMX.broadcom.video_decode
73 rank=257
74 in-port-index=130
75@@ -36,7 +36,7 @@
76
77 [omxtheoradec]
78 type-name=GstOMXTheoraDec
79-core-name=/opt/vc/lib/libopenmaxil.so
80+core-name=/usr/lib/libopenmaxil.so
81 component-name=OMX.broadcom.video_decode
82 rank=257
83 in-port-index=130
84@@ -45,7 +45,7 @@
85
86 [omxvp8dec]
87 type-name=GstOMXVP8Dec
88-core-name=/opt/vc/lib/libopenmaxil.so
89+core-name=/usr/lib/libopenmaxil.so
90 component-name=OMX.broadcom.video_decode
91 rank=257
92 in-port-index=130
93@@ -54,7 +54,7 @@
94
95 [omxmjpegdec]
96 type-name=GstOMXMJPEGDec
97-core-name=/opt/vc/lib/libopenmaxil.so
98+core-name=/usr/lib/libopenmaxil.so
99 component-name=OMX.broadcom.video_decode
100 rank=257
101 in-port-index=130
102@@ -63,7 +63,7 @@
103
104 [omxvc1dec]
105 type-name=GstOMXWMVDec
106-core-name=/opt/vc/lib/libopenmaxil.so
107+core-name=/usr/lib/libopenmaxil.so
108 component-name=OMX.broadcom.video_decode
109 rank=256
110 in-port-index=130
111@@ -73,7 +73,7 @@
112
113 [omxh264enc]
114 type-name=GstOMXH264Enc
115-core-name=/opt/vc/lib/libopenmaxil.so
116+core-name=/usr/lib/libopenmaxil.so
117 component-name=OMX.broadcom.video_encode
118 rank=257
119 in-port-index=200
120@@ -82,7 +82,7 @@
121
122 [omxanalogaudiosink]
123 type-name=GstOMXAnalogAudioSink
124-core-name=/opt/vc/lib/libopenmaxil.so
125+core-name=/usr/lib/libopenmaxil.so
126 component-name=OMX.broadcom.audio_render
127 rank=256
128 in-port-index=100
129@@ -92,7 +92,7 @@
130
131 [omxhdmiaudiosink]
132 type-name=GstOMXHdmiAudioSink
133-core-name=/opt/vc/lib/libopenmaxil.so
134+core-name=/usr/lib/libopenmaxil.so
135 component-name=OMX.broadcom.audio_render
136 rank=257
137 in-port-index=100
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx/0003-no-timeout-on-get-state.patch b/recipes-multimedia/gstreamer/gstreamer1.0-omx/0003-no-timeout-on-get-state.patch
deleted file mode 100644
index 0a0050d..0000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-omx/0003-no-timeout-on-get-state.patch
+++ /dev/null
@@ -1,16 +0,0 @@
1diff --git a/omx/gstomxvideodec.c b/omx/gstomxvideodec.c
2index 0d4e7a1..a0d9c74 100644
3--- a/omx/gstomxvideodec.c
4+++ b/omx/gstomxvideodec.c
5@@ -1697,9 +1697,9 @@ gst_omx_video_dec_stop (GstVideoDecoder * decoder)
6 g_cond_broadcast (&self->drain_cond);
7 g_mutex_unlock (&self->drain_lock);
8
9- gst_omx_component_get_state (self->dec, 5 * GST_SECOND);
10+ gst_omx_component_get_state (self->dec, 0);
11 #if defined (USE_OMX_TARGET_RPI) && defined (HAVE_GST_GL)
12- gst_omx_component_get_state (self->egl_render, 1 * GST_SECOND);
13+ gst_omx_component_get_state (self->egl_render, 0);
14 #endif
15
16 gst_buffer_replace (&self->codec_data, NULL);
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx/0004-Properly-handle-drain-requests-while-flushing.patch b/recipes-multimedia/gstreamer/gstreamer1.0-omx/0004-Properly-handle-drain-requests-while-flushing.patch
deleted file mode 100644
index 98689f3..0000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-omx/0004-Properly-handle-drain-requests-while-flushing.patch
+++ /dev/null
@@ -1,69 +0,0 @@
1From 80dddfd13aaf2fe7272765f8cf291215fe375e28 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Enrique=20Oca=C3=B1a=20Gonz=C3=A1lez?= <eocanha@igalia.com>
3Date: Tue, 17 Nov 2015 16:51:27 +0000
4Subject: [PATCH] Properly handle drain requests while flushing
5
6Without this commit the decoder streaming thread stops without ever attending
7the drain request, leaving the decoder input thread waiting forever.
8---
9 omx/gstomx.c | 7 +++++++
10 omx/gstomxvideodec.c | 13 +++++++++++++
11 2 files changed, 20 insertions(+)
12
13diff --git a/omx/gstomx.c b/omx/gstomx.c
14index 69696c4..f0cd890 100644
15--- a/omx/gstomx.c
16+++ b/omx/gstomx.c
17@@ -830,6 +830,13 @@ gst_omx_component_set_state (GstOMXComponent * comp, OMX_STATETYPE state)
18 done:
19
20 gst_omx_component_handle_messages (comp);
21+
22+ if (err != OMX_ErrorNone && comp->last_error == OMX_ErrorNone) {
23+ GST_ERROR_OBJECT (comp->parent,
24+ "Last operation returned an error. Setting last_error manually.");
25+ comp->last_error = err;
26+ }
27+
28 g_mutex_unlock (&comp->lock);
29
30 if (err != OMX_ErrorNone) {
31diff --git a/omx/gstomxvideodec.c b/omx/gstomxvideodec.c
32index d531f75..a26c4a6 100644
33--- a/omx/gstomxvideodec.c
34+++ b/omx/gstomxvideodec.c
35@@ -1539,9 +1539,16 @@ component_error:
36 flushing:
37 {
38 GST_DEBUG_OBJECT (self, "Flushing -- stopping task");
39+
40+ g_mutex_lock (&self->drain_lock);
41+ if (self->draining) {
42+ self->draining = FALSE;
43+ g_cond_broadcast (&self->drain_cond);
44+ }
45 gst_pad_pause_task (GST_VIDEO_DECODER_SRC_PAD (self));
46 self->downstream_flow_ret = GST_FLOW_FLUSHING;
47 self->started = FALSE;
48+ g_mutex_unlock (&self->drain_lock);
49 return;
50 }
51
52@@ -1599,8 +1606,14 @@ flow_error:
53 self->started = FALSE;
54 } else if (flow_ret == GST_FLOW_FLUSHING) {
55 GST_DEBUG_OBJECT (self, "Flushing -- stopping task");
56+ g_mutex_lock (&self->drain_lock);
57+ if (self->draining) {
58+ self->draining = FALSE;
59+ g_cond_broadcast (&self->drain_cond);
60+ }
61 gst_pad_pause_task (GST_VIDEO_DECODER_SRC_PAD (self));
62 self->started = FALSE;
63+ g_mutex_unlock (&self->drain_lock);
64 }
65 GST_VIDEO_DECODER_STREAM_UNLOCK (self);
66 return;
67--
681.8.3.2
69
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx/0005-Don-t-abort-gst_omx_video_dec_set_format-if-there-s-.patch b/recipes-multimedia/gstreamer/gstreamer1.0-omx/0005-Don-t-abort-gst_omx_video_dec_set_format-if-there-s-.patch
deleted file mode 100644
index b7a8753..0000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-omx/0005-Don-t-abort-gst_omx_video_dec_set_format-if-there-s-.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From 12103842d5f347cf245e71071d0c44297bcdb1f9 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Enrique=20Oca=C3=B1a=20Gonz=C3=A1lez?= <eocanha@igalia.com>
3Date: Fri, 4 Dec 2015 18:39:59 +0100
4Subject: [PATCH] Don't abort gst_omx_video_dec_set_format() if there's a
5 timeout releasing the buffers taken by the egl_render out port
6
7---
8 omx/gstomxvideodec.c | 5 ++++-
9 1 file changed, 4 insertions(+), 1 deletion(-)
10
11diff --git a/omx/gstomxvideodec.c b/omx/gstomxvideodec.c
12index 2368f34..da35e0d 100644
13--- a/omx/gstomxvideodec.c
14+++ b/omx/gstomxvideodec.c
15@@ -1905,8 +1905,11 @@ gst_omx_video_dec_set_format (GstVideoDecoder * decoder,
16 5 * GST_SECOND) != OMX_ErrorNone)
17 return FALSE;
18 if (gst_omx_port_wait_buffers_released (out_port,
19- 1 * GST_SECOND) != OMX_ErrorNone)
20+ 1 * GST_SECOND) != OMX_ErrorNone) {
21+#if !(defined (USE_OMX_TARGET_RPI) && defined (HAVE_GST_GL))
22 return FALSE;
23+#endif
24+ }
25 if (gst_omx_port_deallocate_buffers (self->dec_in_port) != OMX_ErrorNone)
26 return FALSE;
27 if (gst_omx_video_dec_deallocate_output_buffers (self) != OMX_ErrorNone)
28--
292.1.4
30
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend
index 67e46de..67e46de 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-omx%.bbappend
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend