diff options
-rw-r--r-- | recipes-kernel/linux/files/0001-Revert-selftests-bpf-Skip-perf-hw-events-test-if-the.patch | 16 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-raspberrypi_5.4.bb | 8 |
2 files changed, 12 insertions, 12 deletions
diff --git a/recipes-kernel/linux/files/0001-Revert-selftests-bpf-Skip-perf-hw-events-test-if-the.patch b/recipes-kernel/linux/files/0001-Revert-selftests-bpf-Skip-perf-hw-events-test-if-the.patch index 59183dc..66efde1 100644 --- a/recipes-kernel/linux/files/0001-Revert-selftests-bpf-Skip-perf-hw-events-test-if-the.patch +++ b/recipes-kernel/linux/files/0001-Revert-selftests-bpf-Skip-perf-hw-events-test-if-the.patch | |||
@@ -1,16 +1,18 @@ | |||
1 | From a7783676c60dd90a6f4c26bcb9be03dc5703b74e Mon Sep 17 00:00:00 2001 | 1 | From 754e3030788702c1f013a88a4fc8546742d84e27 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Mon, 13 Apr 2020 11:25:32 -0700 | 3 | Date: Thu, 18 Jun 2020 13:45:04 -0700 |
4 | Subject: [PATCH 1/2] Revert "selftests/bpf: Skip perf hw events test if the | 4 | Subject: [PATCH] Revert "selftests/bpf: Skip perf hw events test if the setup |
5 | setup disabled it" | 5 | disabled it" |
6 | 6 | ||
7 | This reverts commit da43712a7262891317883d4b3a909fb18dac4b1d. | 7 | This reverts commit da43712a7262891317883d4b3a909fb18dac4b1d. |
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
8 | --- | 10 | --- |
9 | .../selftests/bpf/prog_tests/stacktrace_build_id_nmi.c | 8 ++------ | 11 | .../selftests/bpf/prog_tests/stacktrace_build_id_nmi.c | 8 ++------ |
10 | 1 file changed, 2 insertions(+), 6 deletions(-) | 12 | 1 file changed, 2 insertions(+), 6 deletions(-) |
11 | 13 | ||
12 | diff --git a/tools/testing/selftests/bpf/prog_tests/stacktrace_build_id_nmi.c b/tools/testing/selftests/bpf/prog_tests/stacktrace_build_id_nmi.c | 14 | diff --git a/tools/testing/selftests/bpf/prog_tests/stacktrace_build_id_nmi.c b/tools/testing/selftests/bpf/prog_tests/stacktrace_build_id_nmi.c |
13 | index 1735faf17536..f62aa0eb959b 100644 | 15 | index 437cb93e72ac..f62aa0eb959b 100644 |
14 | --- a/tools/testing/selftests/bpf/prog_tests/stacktrace_build_id_nmi.c | 16 | --- a/tools/testing/selftests/bpf/prog_tests/stacktrace_build_id_nmi.c |
15 | +++ b/tools/testing/selftests/bpf/prog_tests/stacktrace_build_id_nmi.c | 17 | +++ b/tools/testing/selftests/bpf/prog_tests/stacktrace_build_id_nmi.c |
16 | @@ -49,12 +49,8 @@ void test_stacktrace_build_id_nmi(void) | 18 | @@ -49,12 +49,8 @@ void test_stacktrace_build_id_nmi(void) |
@@ -20,7 +22,7 @@ index 1735faf17536..f62aa0eb959b 100644 | |||
20 | - if (pmu_fd < 0 && errno == ENOENT) { | 22 | - if (pmu_fd < 0 && errno == ENOENT) { |
21 | - printf("%s:SKIP:no PERF_COUNT_HW_CPU_CYCLES\n", __func__); | 23 | - printf("%s:SKIP:no PERF_COUNT_HW_CPU_CYCLES\n", __func__); |
22 | - test__skip(); | 24 | - test__skip(); |
23 | - goto cleanup; | 25 | - goto close_prog; |
24 | - } | 26 | - } |
25 | - if (CHECK(pmu_fd < 0, "perf_event_open", "err %d errno %d\n", | 27 | - if (CHECK(pmu_fd < 0, "perf_event_open", "err %d errno %d\n", |
26 | + if (CHECK(pmu_fd < 0, "perf_event_open", | 28 | + if (CHECK(pmu_fd < 0, "perf_event_open", |
@@ -29,5 +31,5 @@ index 1735faf17536..f62aa0eb959b 100644 | |||
29 | goto close_prog; | 31 | goto close_prog; |
30 | 32 | ||
31 | -- | 33 | -- |
32 | 2.26.0 | 34 | 2.27.0 |
33 | 35 | ||
diff --git a/recipes-kernel/linux/linux-raspberrypi_5.4.bb b/recipes-kernel/linux/linux-raspberrypi_5.4.bb index b1881a2..aaf228e 100644 --- a/recipes-kernel/linux/linux-raspberrypi_5.4.bb +++ b/recipes-kernel/linux/linux-raspberrypi_5.4.bb | |||
@@ -1,13 +1,11 @@ | |||
1 | LINUX_VERSION ?= "5.4.45" | 1 | LINUX_VERSION ?= "5.4.47" |
2 | LINUX_RPI_BRANCH ?= "rpi-5.4.y" | 2 | LINUX_RPI_BRANCH ?= "rpi-5.4.y" |
3 | 3 | ||
4 | SRCREV = "d00cdd80abb2a8c201cae2f6bd80e27eb2f7d347" | 4 | SRCREV = "dec0ddc506ab5d93a7de4b8a7c8dc98e0a96f85c" |
5 | 5 | ||
6 | require linux-raspberrypi_5.4.inc | 6 | require linux-raspberrypi_5.4.inc |
7 | 7 | ||
8 | SRC_URI += "file://0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch \ | 8 | SRC_URI += "file://0001-Revert-selftests-bpf-Skip-perf-hw-events-test-if-the.patch \ |
9 | file://0001-Revert-selftests-bpf-Skip-perf-hw-events-test-if-the.patch \ | ||
10 | file://0002-Revert-selftests-bpf-Fix-perf_buffer-test-on-systems.patch \ | 9 | file://0002-Revert-selftests-bpf-Fix-perf_buffer-test-on-systems.patch \ |
11 | file://0001-selftest-bpf-Use-CHECK-macro-instead-of-RET_IF.patch \ | ||
12 | file://powersave.cfg \ | 10 | file://powersave.cfg \ |
13 | " | 11 | " |