summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/bootfiles/rpi-config_git.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bb b/recipes-bsp/bootfiles/rpi-config_git.bb
index 5315676..d964de5 100644
--- a/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -25,6 +25,8 @@ PITFT35r="${@bb.utils.contains("MACHINE_FEATURES", "pitft35r", "1", "0", d)}"
25 25
26VC4GRAPHICS="${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}" 26VC4GRAPHICS="${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}"
27VC4DTBO ?= "vc4-kms-v3d" 27VC4DTBO ?= "vc4-kms-v3d"
28GPIO_IR ?= "18"
29GPIO_IR_TX ?= "17"
28 30
29inherit deploy nopackages 31inherit deploy nopackages
30 32
@@ -161,6 +163,13 @@ do_deploy() {
161 echo "enable_uart=1" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt 163 echo "enable_uart=1" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
162 fi 164 fi
163 165
166 # Infrared support
167 if [ "${ENABLE_IR}" = "1" ]; then
168 echo "# Enable infrared" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
169 echo "dtoverlay=gpio-ir,gpio_pin=${GPIO_IR}" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
170 echo "dtoverlay=gpio-ir-tx,gpio_pin=${GPIO_IR_TX}" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
171 fi
172
164 # VC4 Graphics support 173 # VC4 Graphics support
165 if [ "${VC4GRAPHICS}" = "1" ]; then 174 if [ "${VC4GRAPHICS}" = "1" ]; then
166 echo "# Enable VC4 Graphics" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt 175 echo "# Enable VC4 Graphics" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt