diff options
-rw-r--r-- | docs/extra-build-config.md | 2 | ||||
-rw-r--r-- | recipes-bsp/bootfiles/rpi-config_git.bb | 3 |
2 files changed, 4 insertions, 1 deletions
diff --git a/docs/extra-build-config.md b/docs/extra-build-config.md index f52c51f..82ec3c0 100644 --- a/docs/extra-build-config.md +++ b/docs/extra-build-config.md | |||
@@ -99,7 +99,7 @@ selected according to the connected monitor's EDID information and the composite | |||
99 | mode is defaulted to NTSC using a 4:3 aspect ratio. Check the config.txt for a | 99 | mode is defaulted to NTSC using a 4:3 aspect ratio. Check the config.txt for a |
100 | detailed description of options and modes. The following variables are supported in | 100 | detailed description of options and modes. The following variables are supported in |
101 | local.conf: `HDMI_FORCE_HOTPLUG`, `HDMI_DRIVE`, `HDMI_GROUP`, `HDMI_MODE`, | 101 | local.conf: `HDMI_FORCE_HOTPLUG`, `HDMI_DRIVE`, `HDMI_GROUP`, `HDMI_MODE`, |
102 | `CONFIG_HDMI_BOOST`, `SDTV_MODE`, `SDTV_ASPECT` and `DISPLAY_ROTATE`. | 102 | `HDMI_CVT`, `CONFIG_HDMI_BOOST`, `SDTV_MODE`, `SDTV_ASPECT` and `DISPLAY_ROTATE`. |
103 | 103 | ||
104 | Example to force HDMI output to 720p in CEA mode: | 104 | Example to force HDMI output to 720p in CEA mode: |
105 | 105 | ||
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bb b/recipes-bsp/bootfiles/rpi-config_git.bb index c1c5340..583144d 100644 --- a/recipes-bsp/bootfiles/rpi-config_git.bb +++ b/recipes-bsp/bootfiles/rpi-config_git.bb | |||
@@ -105,6 +105,9 @@ do_deploy() { | |||
105 | if [ -n "${HDMI_MODE}" ]; then | 105 | if [ -n "${HDMI_MODE}" ]; then |
106 | sed -i '/#hdmi_mode=/ c\hdmi_mode=${HDMI_MODE}' $CONFIG | 106 | sed -i '/#hdmi_mode=/ c\hdmi_mode=${HDMI_MODE}' $CONFIG |
107 | fi | 107 | fi |
108 | if [ -n "${HDMI_CVT}" ]; then | ||
109 | echo 'hdmi_cvt=${HDMI_CVT}' >> $CONFIG | ||
110 | fi | ||
108 | if [ -n "${CONFIG_HDMI_BOOST}" ]; then | 111 | if [ -n "${CONFIG_HDMI_BOOST}" ]; then |
109 | sed -i '/#config_hdmi_boost=/ c\config_hdmi_boost=${CONFIG_HDMI_BOOST}' $CONFIG | 112 | sed -i '/#config_hdmi_boost=/ c\config_hdmi_boost=${CONFIG_HDMI_BOOST}' $CONFIG |
110 | fi | 113 | fi |