summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/meta-python')
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/python/python3-sense-hat_2.2.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/dynamic-layers/meta-python/recipes-devtools/python/python3-sense-hat_2.2.0.bb b/dynamic-layers/meta-python/recipes-devtools/python/python3-sense-hat_2.2.0.bb
new file mode 100644
index 0000000..6195d28
--- /dev/null
+++ b/dynamic-layers/meta-python/recipes-devtools/python/python3-sense-hat_2.2.0.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Python module to control the Raspberry Pi Sense HAT used in the Astro Pi mission"
2HOMEPAGE = "https://github.com/RPi-Distro/python-sense-hat"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=d80fe312e1ff5fbd97369b093bf21cda"
6
7inherit setuptools3 pypi
8
9PYPI_PACKAGE = "sense-hat"
10
11SRC_URI[md5sum] = "69929250cb72349a8a82edf2584b1d83"
12SRC_URI[sha256sum] = "f000998d042d96ed722d459312e1bebd0107f9f3015cd34b3e4fabcab9c800af"
13
14DEPENDS += " \
15 jpeg \
16 zlib \
17 freetype \
18 "
19
20RDEPENDS_${PN} += " \
21 ${PYTHON_PN}-numpy \
22 ${PYTHON_PN}-rtimu \
23 ${PYTHON_PN}-pillow \
24 "