summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-tpm2/recipes-devtools/tpm2simulator/tpm2simulator-native_git.bb36
1 files changed, 0 insertions, 36 deletions
diff --git a/meta-tpm2/recipes-devtools/tpm2simulator/tpm2simulator-native_git.bb b/meta-tpm2/recipes-devtools/tpm2simulator/tpm2simulator-native_git.bb
deleted file mode 100644
index 3cbb594..0000000
--- a/meta-tpm2/recipes-devtools/tpm2simulator/tpm2simulator-native_git.bb
+++ /dev/null
@@ -1,36 +0,0 @@
1SUMMARY = "TPM 2.0 Simulator Extraction Script"
2DESCRIPTION = "The result of the extraction scripts is a complete set \
3of the source files for a Trusted Platform Module (TPM) 2.0 Simulator, \
4which runs under Windows, Linux, as well as Genode (by applying the \
5appropriate patches). \
6"
7
8LICENSE = "BSD-2-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=1415f7be284540b81d9d28c67c1a6b8b"
10
11DEPENDS += "\
12 python-native \
13 python-beautifulsoup4-native \
14"
15
16PV = "1.38+git${SRCPV}"
17
18SRC_URI = "\
19 git://github.com/stwagnr/tpm2simulator.git \
20"
21SRCREV = "e45324eba268723d39856111e7933c5c76238481"
22
23S = "${WORKDIR}/git"
24
25inherit pythonnative lib_package cmake native
26
27EXTRA_OECMAKE = "\
28 -DCMAKE_BUILD_TYPE=Debug \
29 -DSPEC_VERSION=116 \
30"
31
32OECMAKE_SOURCEPATH = "${S}/cmake"
33
34do_configure_prepend() {
35 sed -i 's/^SET = False/SET = True/' "${S}/scripts/settings.py"
36}