diff options
2 files changed, 37 insertions, 3 deletions
diff --git a/meta-signing-key/recipes-devtools/sbsigntool/sbsigntool/0001-src-Makefile.am-Add-read_write_all.c-to-common_SOURC.patch b/meta-signing-key/recipes-devtools/sbsigntool/sbsigntool/0001-src-Makefile.am-Add-read_write_all.c-to-common_SOURC.patch new file mode 100644 index 0000000..70438f1 --- /dev/null +++ b/meta-signing-key/recipes-devtools/sbsigntool/sbsigntool/0001-src-Makefile.am-Add-read_write_all.c-to-common_SOURC.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From c86fa2201f864585f470f33cec4f6d0bf10475a1 Mon Sep 17 00:00:00 2001 | ||
2 | From: Robert Yang <liezhi.yang@windriver.com> | ||
3 | Date: Thu, 17 Jun 2021 08:05:25 +0000 | ||
4 | Subject: [PATCH] src/Makefile.am: Add read_write_all.c to common_SOURCES | ||
5 | |||
6 | It is required by image.c. | ||
7 | |||
8 | Fixed: | ||
9 | src/image.c:659: undefined reference to `write_all' | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | |||
13 | Signed-off-by: Robert Yang <liezhi.yang@windriver.com> | ||
14 | --- | ||
15 | src/Makefile.am | 2 +- | ||
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
17 | |||
18 | diff --git a/src/Makefile.am b/src/Makefile.am | ||
19 | index e3f039b..34a0beb 100644 | ||
20 | --- a/src/Makefile.am | ||
21 | +++ b/src/Makefile.am | ||
22 | @@ -5,7 +5,7 @@ coff_headers = coff/external.h coff/pe.h | ||
23 | AM_CFLAGS = -Wall -Wextra --std=gnu99 | ||
24 | |||
25 | common_SOURCES = idc.c idc.h image.c image.h fileio.c fileio.h \ | ||
26 | - efivars.h $(coff_headers) | ||
27 | + ../lib/ccan.git/ccan/read_write_all/read_write_all.c efivars.h $(coff_headers) | ||
28 | common_LDADD = ../lib/ccan/libccan.a $(libcrypto_LIBS) | ||
29 | common_CFLAGS = -I$(top_srcdir)/lib/ccan/ -Werror | ||
30 | |||
31 | -- | ||
32 | 2.29.2 | ||
33 | |||
diff --git a/meta-signing-key/recipes-devtools/sbsigntool/sbsigntool_git.bb b/meta-signing-key/recipes-devtools/sbsigntool/sbsigntool_git.bb index c9cc615..c38fa42 100644 --- a/meta-signing-key/recipes-devtools/sbsigntool/sbsigntool_git.bb +++ b/meta-signing-key/recipes-devtools/sbsigntool/sbsigntool_git.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "\ | |||
7 | file://COPYING;md5=a7710ac18adec371b84a9594ed04fd20 \ | 7 | file://COPYING;md5=a7710ac18adec371b84a9594ed04fd20 \ |
8 | " | 8 | " |
9 | 9 | ||
10 | DEPENDS += "binutils openssl gnu-efi gnu-efi-native" | 10 | DEPENDS += "binutils openssl gnu-efi gnu-efi-native util-linux-libuuid" |
11 | DEPENDS += "binutils-native help2man-native coreutils-native openssl-native util-linux-native" | 11 | DEPENDS += "binutils-native help2man-native coreutils-native openssl-native util-linux-native" |
12 | 12 | ||
13 | SRC_URI = " \ | 13 | SRC_URI = " \ |
@@ -15,7 +15,8 @@ SRC_URI = " \ | |||
15 | git://github.com/rustyrussell/ccan.git;protocol=https;destsuffix=git/lib/ccan.git;name=ccan \ | 15 | git://github.com/rustyrussell/ccan.git;protocol=https;destsuffix=git/lib/ccan.git;name=ccan \ |
16 | file://0001-configure-Dont-t-check-for-gnu-efi.patch \ | 16 | file://0001-configure-Dont-t-check-for-gnu-efi.patch \ |
17 | file://0002-docs-Don-t-build-man-pages.patch \ | 17 | file://0002-docs-Don-t-build-man-pages.patch \ |
18 | file://0003-sbsign-add-x-option-to-avoid-overwrite-existing-sign.patch \ | 18 | file://0003-sbsign-add-x-option-to-avoid-overwrite-existing-sign.patch \ |
19 | file://0001-src-Makefile.am-Add-read_write_all.c-to-common_SOURC.patch \ | ||
19 | " | 20 | " |
20 | SRCREV_sbsigntools ?= "f12484869c9590682ac3253d583bf59b890bb826" | 21 | SRCREV_sbsigntools ?= "f12484869c9590682ac3253d583bf59b890bb826" |
21 | SRCREV_ccan ?= "b1f28e17227f2320d07fe052a8a48942fe17caa5" | 22 | SRCREV_ccan ?= "b1f28e17227f2320d07fe052a8a48942fe17caa5" |
@@ -25,7 +26,7 @@ PV = "0.9.2-git${SRCPV}" | |||
25 | 26 | ||
26 | S = "${WORKDIR}/git" | 27 | S = "${WORKDIR}/git" |
27 | 28 | ||
28 | inherit autotools-brokensep pkgconfig native | 29 | inherit autotools-brokensep pkgconfig |
29 | 30 | ||
30 | def efi_arch(d): | 31 | def efi_arch(d): |
31 | import re | 32 | import re |