summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-integrity/classes/ima-evm-rootfs.bbclass2
-rw-r--r--meta-parsec/recipes-parsec/parsec-service/parsec-service_1.4.1.bb4
2 files changed, 3 insertions, 3 deletions
diff --git a/meta-integrity/classes/ima-evm-rootfs.bbclass b/meta-integrity/classes/ima-evm-rootfs.bbclass
index 7ec2751..d50a025 100644
--- a/meta-integrity/classes/ima-evm-rootfs.bbclass
+++ b/meta-integrity/classes/ima-evm-rootfs.bbclass
@@ -61,7 +61,7 @@ ima_evm_sign_rootfs () {
61 # 61 #
62 # Deduplicates iversion in case that this gets called more than once. 62 # Deduplicates iversion in case that this gets called more than once.
63 if [ -f etc/fstab ]; then 63 if [ -f etc/fstab ]; then
64 perl -pi -e 's;(\S+)(\s+)(${@"|".join((d.getVar("IMA_EVM_ROOTFS_IVERSION", True) or "no-such-mount-point").split())})(\s+)(\S+)(\s+)(\S+);\1\2\3\4\5\6\7,iversion;; s/(,iversion)+/,iversion/;' etc/fstab 64 perl -pi -e 's;(\S+)(\s+)(${@"|".join((d.getVar("IMA_EVM_ROOTFS_IVERSION") or "no-such-mount-point").split())})(\s+)(\S+)(\s+)(\S+);\1\2\3\4\5\6\7,iversion;; s/(,iversion)+/,iversion/;' etc/fstab
65 fi 65 fi
66 66
67 # Detect 32bit target to pass --m32 to evmctl by looking at libc 67 # Detect 32bit target to pass --m32 to evmctl by looking at libc
diff --git a/meta-parsec/recipes-parsec/parsec-service/parsec-service_1.4.1.bb b/meta-parsec/recipes-parsec/parsec-service/parsec-service_1.4.1.bb
index 1d7c6e8..49467cd 100644
--- a/meta-parsec/recipes-parsec/parsec-service/parsec-service_1.4.1.bb
+++ b/meta-parsec/recipes-parsec/parsec-service/parsec-service_1.4.1.bb
@@ -28,11 +28,11 @@ PACKAGECONFIG[MBED-CRYPTO] = "mbed-crypto-provider,"
28PACKAGECONFIG[CRYPTOAUTHLIB] = "cryptoauthlib-provider," 28PACKAGECONFIG[CRYPTOAUTHLIB] = "cryptoauthlib-provider,"
29PACKAGECONFIG[TS] = "trusted-service-provider,,libts,libts" 29PACKAGECONFIG[TS] = "trusted-service-provider,,libts,libts"
30 30
31PARSEC_FEATURES = "${@d.getVar('PACKAGECONFIG_CONFARGS',True).strip().replace(' ', ',')}" 31PARSEC_FEATURES = "${@d.getVar('PACKAGECONFIG_CONFARGS').strip().replace(' ', ',')}"
32CARGO_BUILD_FLAGS += " --features ${PARSEC_FEATURES}" 32CARGO_BUILD_FLAGS += " --features ${PARSEC_FEATURES}"
33 33
34export BINDGEN_EXTRA_CLANG_ARGS 34export BINDGEN_EXTRA_CLANG_ARGS
35target = "${@d.getVar('TARGET_SYS',True).replace('-', ' ')}" 35target = "${@d.getVar('TARGET_SYS').replace('-', ' ')}"
36BINDGEN_EXTRA_CLANG_ARGS = "${@bb.utils.contains('target', 'arm', \ 36BINDGEN_EXTRA_CLANG_ARGS = "${@bb.utils.contains('target', 'arm', \
37 '--sysroot=${WORKDIR}/recipe-sysroot -I${WORKDIR}/recipe-sysroot/usr/include -mfloat-abi=hard', \ 37 '--sysroot=${WORKDIR}/recipe-sysroot -I${WORKDIR}/recipe-sysroot/usr/include -mfloat-abi=hard', \
38 '--sysroot=${WORKDIR}/recipe-sysroot -I${WORKDIR}/recipe-sysroot/usr/include', \ 38 '--sysroot=${WORKDIR}/recipe-sysroot -I${WORKDIR}/recipe-sysroot/usr/include', \