summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/meta-python/recipes-security/fail2ban/python3-fail2ban_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/meta-python/recipes-security/fail2ban/python3-fail2ban_git.bb')
-rw-r--r--dynamic-layers/meta-python/recipes-security/fail2ban/python3-fail2ban_git.bb66
1 files changed, 66 insertions, 0 deletions
diff --git a/dynamic-layers/meta-python/recipes-security/fail2ban/python3-fail2ban_git.bb b/dynamic-layers/meta-python/recipes-security/fail2ban/python3-fail2ban_git.bb
new file mode 100644
index 0000000..52d35f8
--- /dev/null
+++ b/dynamic-layers/meta-python/recipes-security/fail2ban/python3-fail2ban_git.bb
@@ -0,0 +1,66 @@
1SUMMARY = "Daemon to ban hosts that cause multiple authentication errors."
2DESCRIPTION = "Fail2Ban scans log files like /var/log/auth.log and bans IP addresses having too \
3many failed login attempts. It does this by updating system firewall rules to reject new \
4connections from those IP addresses, for a configurable amount of time. Fail2Ban comes \
5out-of-the-box ready to read many standard log files, such as those for sshd and Apache, \
6and is easy to configure to read any log file you choose, for any error you choose."
7HOMEPAGE = "http://www.fail2ban.org"
8
9LICENSE = "GPL-2.0-only"
10LIC_FILES_CHKSUM = "file://COPYING;md5=ecabc31e90311da843753ba772885d9f"
11
12DEPENDS = "python3-native"
13
14SRCREV = "ac62658c10f492911f8a0037a0bcf97c8521cd78"
15SRC_URI = "git://github.com/fail2ban/fail2ban.git;branch=master;protocol=https \
16 file://initd \
17 file://run-ptest \
18 "
19
20PV = "1.1.0+git"
21
22UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
23
24inherit update-rc.d ptest setuptools3_legacy
25inherit systemd
26
27SYSTEMD_SERVICE:${PN} = "fail2ban.service"
28
29S = "${UNPACKDIR}/git"
30
31do_install:append () {
32 rm -f ${D}/${bindir}/fail2ban-python
33 install -d ${D}/${sysconfdir}/fail2ban
34 install -d ${D}/${sysconfdir}/init.d
35 install -m 0755 ${UNPACKDIR}/initd ${D}${sysconfdir}/init.d/fail2ban-server
36
37 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
38 install -d ${D}${systemd_system_unitdir}
39 install -m 0644 ${B}/fail2ban.service ${D}${systemd_system_unitdir}
40 fi
41
42 chown -R root:root ${D}/${bindir}
43 rm -rf ${D}/run
44}
45
46do_install_ptest:append () {
47 install -d ${D}${PTEST_PATH}
48 install -d ${D}${PTEST_PATH}/bin
49 sed -i -e 's/##PYTHON##/python3/g' ${D}${PTEST_PATH}/run-ptest
50 install -D ${S}/bin/* ${D}${PTEST_PATH}/bin
51 rm -f ${D}${PTEST_PATH}/bin/fail2ban-python
52}
53
54
55INITSCRIPT_PACKAGES = "${PN}"
56INITSCRIPT_NAME = "fail2ban-server"
57INITSCRIPT_PARAMS = "defaults 25"
58
59INSANE_SKIP:${PN}:append = "already-stripped"
60
61RDEPENDS:${PN} = "${VIRTUAL-RUNTIME_base-utils-syslog} nftables python3-core python3-pyinotify"
62RDEPENDS:${PN} += "python3-sqlite3"
63RDEPENDS:${PN} += " python3-logging python3-fcntl python3-json"
64RDEPENDS:${PN}-ptest = "python3-core python3-io python3-modules python3-fail2ban"
65
66RRECOMMENDS:${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'python3-systemd', '', d)}"