summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-security/setools/setools_4.5.1.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/recipes-security/setools/setools_4.5.1.bb b/recipes-security/setools/setools_4.5.1.bb
index 45063cd..9b6745e 100644
--- a/recipes-security/setools/setools_4.5.1.bb
+++ b/recipes-security/setools/setools_4.5.1.bb
@@ -18,19 +18,18 @@ S = "${WORKDIR}/git"
18 18
19DEPENDS = "python3-cython-native libsepol libselinux" 19DEPENDS = "python3-cython-native libsepol libselinux"
20 20
21RDEPENDS:${PN} = "python3-networkx python3-setuptools \ 21RDEPENDS:${PN} = "python3-networkx python3-logging libselinux-python"
22 python3-logging libselinux-python"
23 22
24RPROVIDES:${PN} = "${PN}-console" 23RPROVIDES:${PN} = "${PN}-console"
25 24
26inherit setuptools3 25inherit python_setuptools_build_meta
27 26
28do_install:prepend() { 27do_install:prepend() {
29 sed -i -e 's:${RECIPE_SYSROOT}::g' ${S}/setools/policyrep.c 28 sed -i -e 's:${RECIPE_SYSROOT}::g' ${S}/setools/policyrep.c
30} 29}
31 30
32do_install:append() { 31do_install:append() {
33 # Need PyQt5 support, disable gui tools 32 # Need PyQt6 support, disable gui tools
34 rm -f ${D}${bindir}/apol 33 rm -f ${D}${bindir}/apol
35 rm -rf ${D}${libdir}/${PYTHON_DIR}/site-packages/setoolsgui 34 rm -rf ${D}${libdir}/${PYTHON_DIR}/site-packages/setoolsgui
36 rm -rf ${D}${libdir}/${PYTHON_DIR}/site-packages/setools/__pycache__ 35 rm -rf ${D}${libdir}/${PYTHON_DIR}/site-packages/setools/__pycache__