diff options
-rw-r--r-- | recipes-devtools/python/python3-decorator_%.bbappend | 2 | ||||
-rw-r--r-- | recipes-devtools/python/python3-networkx_%.bbappend | 2 | ||||
-rw-r--r-- | recipes-security/setools/setools_4.3.0.bb | 6 |
3 files changed, 10 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-decorator_%.bbappend b/recipes-devtools/python/python3-decorator_%.bbappend new file mode 100644 index 0000000..3bc71e0 --- /dev/null +++ b/recipes-devtools/python/python3-decorator_%.bbappend | |||
@@ -0,0 +1,2 @@ | |||
1 | BBCLASSEXTEND = "native nativesdk" | ||
2 | |||
diff --git a/recipes-devtools/python/python3-networkx_%.bbappend b/recipes-devtools/python/python3-networkx_%.bbappend new file mode 100644 index 0000000..3bc71e0 --- /dev/null +++ b/recipes-devtools/python/python3-networkx_%.bbappend | |||
@@ -0,0 +1,2 @@ | |||
1 | BBCLASSEXTEND = "native nativesdk" | ||
2 | |||
diff --git a/recipes-security/setools/setools_4.3.0.bb b/recipes-security/setools/setools_4.3.0.bb index ec73f7c..8fdeeb0 100644 --- a/recipes-security/setools/setools_4.3.0.bb +++ b/recipes-security/setools/setools_4.3.0.bb | |||
@@ -8,6 +8,8 @@ SETools." | |||
8 | SECTION = "base" | 8 | SECTION = "base" |
9 | LICENSE = "GPLv2 & LGPLv2.1" | 9 | LICENSE = "GPLv2 & LGPLv2.1" |
10 | 10 | ||
11 | BBCLASSEXTEND = "native nativesdk " | ||
12 | |||
11 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |
12 | SRC_URI = "git://github.com/SELinuxProject/${BPN}.git;branch=4.3 \ | 14 | SRC_URI = "git://github.com/SELinuxProject/${BPN}.git;branch=4.3 \ |
13 | file://setools4-fixes-for-cross-compiling.patch \ | 15 | file://setools4-fixes-for-cross-compiling.patch \ |
@@ -21,9 +23,13 @@ LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=83a5eb6974c11f30785e90d0eeccf40c \ | |||
21 | 23 | ||
22 | DEPENDS += "bison-native flex-native swig-native python3 python3-cython-native libsepol libselinux" | 24 | DEPENDS += "bison-native flex-native swig-native python3 python3-cython-native libsepol libselinux" |
23 | 25 | ||
26 | DEPENDS_class-native += "libselinux python3-setuptools python3-cython python3-networkx" | ||
27 | |||
24 | RDEPENDS_${PN} += "python3-networkx python3-decorator python3-setuptools \ | 28 | RDEPENDS_${PN} += "python3-networkx python3-decorator python3-setuptools \ |
25 | python3-logging python3-json libselinux-python" | 29 | python3-logging python3-json libselinux-python" |
26 | 30 | ||
31 | RDEPENDS_${PN}_class-native = "" | ||
32 | |||
27 | RPROVIDES_${PN} += "${PN}-console" | 33 | RPROVIDES_${PN} += "${PN}-console" |
28 | 34 | ||
29 | inherit setuptools3 | 35 | inherit setuptools3 |