diff options
-rw-r--r-- | recipes-support/libpcre/libpcre_%.bbappend | 1 | ||||
-rw-r--r-- | recipes-support/libpcre/libpcre_selinux.inc | 18 |
2 files changed, 0 insertions, 19 deletions
diff --git a/recipes-support/libpcre/libpcre_%.bbappend b/recipes-support/libpcre/libpcre_%.bbappend deleted file mode 100644 index 7719d3b..0000000 --- a/recipes-support/libpcre/libpcre_%.bbappend +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | require ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', '${BPN}_selinux.inc', '', d)} | ||
diff --git a/recipes-support/libpcre/libpcre_selinux.inc b/recipes-support/libpcre/libpcre_selinux.inc deleted file mode 100644 index 2da7073..0000000 --- a/recipes-support/libpcre/libpcre_selinux.inc +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | do_install:append () { | ||
2 | # This code creates libpcre for both the dev machine (SDK native) | ||
3 | # and for cross-compiling (machine arch). For Linux (SDK Linux native | ||
4 | # + all machine arch), symlinks to the .so files have to be created, | ||
5 | # but not for the Windows SDK native. | ||
6 | if [ ${TARGET_OS} != "mingw32" ]; then | ||
7 | if [ ! ${D}${libdir} -ef ${D}${base_libdir} -a -e ${D}${libdir}/libpcre.so ]; then | ||
8 | realsofile=`readlink ${D}${libdir}/libpcre.so` | ||
9 | mkdir -p ${D}/${base_libdir}/ | ||
10 | mv -f ${D}${libdir}/libpcre.so.* ${D}${base_libdir}/ | ||
11 | relpath=${@os.path.relpath("${base_libdir}", "${libdir}")} | ||
12 | ln -sf ${relpath}/${realsofile} ${D}${libdir}/libpcre.so | ||
13 | ln -sf ${relpath}/${realsofile} ${D}${libdir}/libpcre.so.1 | ||
14 | fi | ||
15 | fi | ||
16 | } | ||
17 | |||
18 | FILES:${PN} += "${base_libdir}/libpcre.so.*" | ||