diff options
-rw-r--r-- | recipes-security/refpolicy/refpolicy_common.inc | 6 | ||||
-rw-r--r-- | recipes-security/selinux-scripts/selinux-initsh.inc | 12 | ||||
-rw-r--r-- | recipes-security/selinux/policycoreutils_3.6.bb | 4 |
3 files changed, 12 insertions, 10 deletions
diff --git a/recipes-security/refpolicy/refpolicy_common.inc b/recipes-security/refpolicy/refpolicy_common.inc index 6ea1fc2..000fb3c 100644 --- a/recipes-security/refpolicy/refpolicy_common.inc +++ b/recipes-security/refpolicy/refpolicy_common.inc | |||
@@ -214,12 +214,12 @@ EOF | |||
214 | } | 214 | } |
215 | 215 | ||
216 | install_misc_files() { | 216 | install_misc_files() { |
217 | cat ${WORKDIR}/customizable_types >> \ | 217 | cat ${UNPACKDIR}/customizable_types >> \ |
218 | ${D}${sysconfdir}/selinux/${POLICY_NAME}/contexts/customizable_types | 218 | ${D}${sysconfdir}/selinux/${POLICY_NAME}/contexts/customizable_types |
219 | 219 | ||
220 | # Install setrans.conf for mls/mcs policy | 220 | # Install setrans.conf for mls/mcs policy |
221 | if [ -f ${WORKDIR}/setrans-${POLICY_TYPE}.conf ]; then | 221 | if [ -f ${UNPACKDIR}/setrans-${POLICY_TYPE}.conf ]; then |
222 | install -m 0644 ${WORKDIR}/setrans-${POLICY_TYPE}.conf \ | 222 | install -m 0644 ${UNPACKDIR}/setrans-${POLICY_TYPE}.conf \ |
223 | ${D}${sysconfdir}/selinux/${POLICY_NAME}/setrans.conf | 223 | ${D}${sysconfdir}/selinux/${POLICY_NAME}/setrans.conf |
224 | fi | 224 | fi |
225 | 225 | ||
diff --git a/recipes-security/selinux-scripts/selinux-initsh.inc b/recipes-security/selinux-scripts/selinux-initsh.inc index f6a3d85..efe7e88 100644 --- a/recipes-security/selinux-scripts/selinux-initsh.inc +++ b/recipes-security/selinux-scripts/selinux-initsh.inc | |||
@@ -1,4 +1,6 @@ | |||
1 | S ?= "${WORKDIR}" | 1 | S ?= "${WORKDIR}/sources" |
2 | UNPACKDIR = "${S}" | ||
3 | |||
2 | SECTION ?= "base" | 4 | SECTION ?= "base" |
3 | 5 | ||
4 | # Default is for script name to be the same as the recipe name. | 6 | # Default is for script name to be the same as the recipe name. |
@@ -21,17 +23,17 @@ FILES:${PN} += "/.autorelabel" | |||
21 | 23 | ||
22 | do_install () { | 24 | do_install () { |
23 | install -d ${D}${sysconfdir}/init.d/ | 25 | install -d ${D}${sysconfdir}/init.d/ |
24 | install -m 0755 ${WORKDIR}/${SELINUX_SCRIPT_SRC}.sh ${D}${sysconfdir}/init.d/${SELINUX_SCRIPT_DST} | 26 | install -m 0755 ${S}/${SELINUX_SCRIPT_SRC}.sh ${D}${sysconfdir}/init.d/${SELINUX_SCRIPT_DST} |
25 | # Insert the relabelling code which is only needed with sysvinit | 27 | # Insert the relabelling code which is only needed with sysvinit |
26 | sed -i -e '/HERE/r ${WORKDIR}/${SELINUX_SCRIPT_SRC}.sh.sysvinit' \ | 28 | sed -i -e '/HERE/r ${S}/${SELINUX_SCRIPT_SRC}.sh.sysvinit' \ |
27 | -e '/.*HERE$/d' -e '/.*Contents.*sysvinit/d' \ | 29 | -e '/.*HERE$/d' -e '/.*Contents.*sysvinit/d' \ |
28 | ${D}${sysconfdir}/init.d/${SELINUX_SCRIPT_DST} | 30 | ${D}${sysconfdir}/init.d/${SELINUX_SCRIPT_DST} |
29 | 31 | ||
30 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then | 32 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
31 | install -d ${D}${systemd_unitdir}/system | 33 | install -d ${D}${systemd_unitdir}/system |
32 | install -m 0644 ${WORKDIR}/${SELINUX_SCRIPT_SRC}.service ${D}${systemd_unitdir}/system | 34 | install -m 0644 ${S}/${SELINUX_SCRIPT_SRC}.service ${D}${systemd_unitdir}/system |
33 | install -d ${D}${bindir} | 35 | install -d ${D}${bindir} |
34 | install -m 0755 ${WORKDIR}/${SELINUX_SCRIPT_SRC}.sh ${D}${bindir} | 36 | install -m 0755 ${S}/${SELINUX_SCRIPT_SRC}.sh ${D}${bindir} |
35 | sed -i -e '/.*HERE$/d' ${D}${bindir}/${SELINUX_SCRIPT_SRC}.sh | 37 | sed -i -e '/.*HERE$/d' ${D}${bindir}/${SELINUX_SCRIPT_SRC}.sh |
36 | fi | 38 | fi |
37 | } | 39 | } |
diff --git a/recipes-security/selinux/policycoreutils_3.6.bb b/recipes-security/selinux/policycoreutils_3.6.bb index c106ee7..2871de0 100644 --- a/recipes-security/selinux/policycoreutils_3.6.bb +++ b/recipes-security/selinux/policycoreutils_3.6.bb | |||
@@ -166,9 +166,9 @@ do_install:class-native() { | |||
166 | } | 166 | } |
167 | 167 | ||
168 | do_install:append:class-target() { | 168 | do_install:append:class-target() { |
169 | if [ -e ${WORKDIR}/pam.d ]; then | 169 | if [ -e ${UNPACKDIR}/pam.d ]; then |
170 | install -d ${D}${sysconfdir}/pam.d/ | 170 | install -d ${D}${sysconfdir}/pam.d/ |
171 | install -m 0644 ${WORKDIR}/pam.d/* ${D}${sysconfdir}/pam.d/ | 171 | install -m 0644 ${UNPACKDIR}/pam.d/* ${D}${sysconfdir}/pam.d/ |
172 | fi | 172 | fi |
173 | 173 | ||
174 | # /var/lib/selinux is involved by seobject.py: | 174 | # /var/lib/selinux is involved by seobject.py: |