diff options
-rw-r--r-- | recipes-security/selinux/libsemanage/libsemanage-allow-to-disable-audit-support.patch | 12 | ||||
-rw-r--r-- | recipes-security/selinux/libsemanage/libsemanage-drop-Wno-unused-but-set-variable.patch | 28 | ||||
-rw-r--r-- | recipes-security/selinux/libsemanage_3.1.bb (renamed from recipes-security/selinux/libsemanage_3.0.bb) | 7 |
3 files changed, 9 insertions, 38 deletions
diff --git a/recipes-security/selinux/libsemanage/libsemanage-allow-to-disable-audit-support.patch b/recipes-security/selinux/libsemanage/libsemanage-allow-to-disable-audit-support.patch index c588b61..ff5cb00 100644 --- a/recipes-security/selinux/libsemanage/libsemanage-allow-to-disable-audit-support.patch +++ b/recipes-security/selinux/libsemanage/libsemanage-allow-to-disable-audit-support.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 1633f72579e3b79d055759256b71e4169627889b Mon Sep 17 00:00:00 2001 | 1 | From e76867515be3bc296174aeb26c7996a0939a2a8c Mon Sep 17 00:00:00 2001 |
2 | From: Wenzong Fan <wenzong.fan@windriver.com> | 2 | From: Wenzong Fan <wenzong.fan@windriver.com> |
3 | Date: Mon, 20 Jan 2014 03:53:48 -0500 | 3 | Date: Mon, 20 Jan 2014 03:53:48 -0500 |
4 | Subject: [PATCH] libsemanage: allow to disable audit support | 4 | Subject: [PATCH] libsemanage: allow to disable audit support |
@@ -13,11 +13,11 @@ Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> | |||
13 | 3 files changed, 31 insertions(+), 2 deletions(-) | 13 | 3 files changed, 31 insertions(+), 2 deletions(-) |
14 | 14 | ||
15 | diff --git a/src/Makefile b/src/Makefile | 15 | diff --git a/src/Makefile b/src/Makefile |
16 | index 3bd1e20..483e818 100644 | 16 | index a0eb374..afc4437 100644 |
17 | --- a/src/Makefile | 17 | --- a/src/Makefile |
18 | +++ b/src/Makefile | 18 | +++ b/src/Makefile |
19 | @@ -26,6 +26,14 @@ ifeq ($(DEBUG),1) | 19 | @@ -26,6 +26,14 @@ ifeq ($(DEBUG),1) |
20 | export LDFLAGS = -g | 20 | export LDFLAGS ?= -g |
21 | endif | 21 | endif |
22 | 22 | ||
23 | +DISABLE_AUDIT ?= n | 23 | +DISABLE_AUDIT ?= n |
@@ -31,7 +31,7 @@ index 3bd1e20..483e818 100644 | |||
31 | LEX = flex | 31 | LEX = flex |
32 | LFLAGS = -s | 32 | LFLAGS = -s |
33 | YACC = bison | 33 | YACC = bison |
34 | @@ -88,7 +96,7 @@ $(LIBA): $(OBJS) | 34 | @@ -89,7 +97,7 @@ $(LIBA): $(OBJS) |
35 | $(RANLIB) $@ | 35 | $(RANLIB) $@ |
36 | 36 | ||
37 | $(LIBSO): $(LOBJS) | 37 | $(LIBSO): $(LOBJS) |
@@ -41,7 +41,7 @@ index 3bd1e20..483e818 100644 | |||
41 | 41 | ||
42 | $(LIBPC): $(LIBPC).in ../VERSION | 42 | $(LIBPC): $(LIBPC).in ../VERSION |
43 | diff --git a/src/seusers_local.c b/src/seusers_local.c | 43 | diff --git a/src/seusers_local.c b/src/seusers_local.c |
44 | index 3e2761c..8bc6b83 100644 | 44 | index 6508ec0..1b26956 100644 |
45 | --- a/src/seusers_local.c | 45 | --- a/src/seusers_local.c |
46 | +++ b/src/seusers_local.c | 46 | +++ b/src/seusers_local.c |
47 | @@ -8,7 +8,11 @@ typedef struct semanage_seuser record_t; | 47 | @@ -8,7 +8,11 @@ typedef struct semanage_seuser record_t; |
@@ -122,5 +122,5 @@ index 69f49a3..f914492 100644 | |||
122 | OBJECTS = $(SOURCES:.c=.o) | 122 | OBJECTS = $(SOURCES:.c=.o) |
123 | POLICIES = $(CILS:.cil=.policy) | 123 | POLICIES = $(CILS:.cil=.policy) |
124 | -- | 124 | -- |
125 | 2.7.4 | 125 | 2.17.1 |
126 | 126 | ||
diff --git a/recipes-security/selinux/libsemanage/libsemanage-drop-Wno-unused-but-set-variable.patch b/recipes-security/selinux/libsemanage/libsemanage-drop-Wno-unused-but-set-variable.patch deleted file mode 100644 index c9b052c..0000000 --- a/recipes-security/selinux/libsemanage/libsemanage-drop-Wno-unused-but-set-variable.patch +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | From 90a2459d1683e53f4a896b977e6b396db562c903 Mon Sep 17 00:00:00 2001 | ||
2 | From: Randy MacLeod <Randy.MacLeod@windriver.com> | ||
3 | Date: Tue, 30 Apr 2013 23:15:57 -0400 | ||
4 | Subject: [PATCH] libselinux: drop flag: -Wno-unused-but-set-variable | ||
5 | |||
6 | Upstream-Status: Inappropriate [older compilers only] | ||
7 | |||
8 | Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> | ||
9 | --- | ||
10 | src/Makefile | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/src/Makefile b/src/Makefile | ||
14 | index e029f09..8240c3a 100644 | ||
15 | --- a/src/Makefile | ||
16 | +++ b/src/Makefile | ||
17 | @@ -55,7 +55,7 @@ OBJS= $(patsubst %.c,%.o,$(SRCS)) conf-scan.o conf-parse.o | ||
18 | LOBJS= $(patsubst %.c,%.lo,$(SRCS)) conf-scan.lo conf-parse.lo | ||
19 | CFLAGS ?= -Werror -Wall -W -Wundef -Wshadow -Wmissing-noreturn -Wmissing-format-attribute | ||
20 | |||
21 | -SWIG_CFLAGS += -Wno-error -Wno-unused-but-set-variable -Wno-unused-variable -Wno-shadow \ | ||
22 | +SWIG_CFLAGS += -Wno-error -Wno-unused-variable -Wno-shadow \ | ||
23 | -Wno-unused-parameter | ||
24 | |||
25 | override CFLAGS += -I../include -D_GNU_SOURCE | ||
26 | -- | ||
27 | 2.7.4 | ||
28 | |||
diff --git a/recipes-security/selinux/libsemanage_3.0.bb b/recipes-security/selinux/libsemanage_3.1.bb index 450675b..8e6781f 100644 --- a/recipes-security/selinux/libsemanage_3.0.bb +++ b/recipes-security/selinux/libsemanage_3.1.bb | |||
@@ -1,14 +1,13 @@ | |||
1 | require selinux_20191204.inc | 1 | require selinux_20200710.inc |
2 | require ${BPN}.inc | 2 | require ${BPN}.inc |
3 | 3 | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343" |
5 | 5 | ||
6 | SRC_URI[md5sum] = "17a2fc780af0a36f2cf27ab7c4e85946" | 6 | SRC_URI[md5sum] = "d16eee8c1dc8cf43f59957d575d6bd29" |
7 | SRC_URI[sha256sum] = "a497b0720d54eac427f1f3f618eed417e50ed8f4e47ed0f7a1d391bd416e84cf" | 7 | SRC_URI[sha256sum] = "22d6c75526e40d1781c30bcf29abf97171bdfe6780923f11c8e1c76a75a21ff8" |
8 | 8 | ||
9 | SRC_URI += "\ | 9 | SRC_URI += "\ |
10 | file://libsemanage-Fix-execve-segfaults-on-Ubuntu.patch \ | 10 | file://libsemanage-Fix-execve-segfaults-on-Ubuntu.patch \ |
11 | file://libsemanage-drop-Wno-unused-but-set-variable.patch \ | ||
12 | file://libsemanage-define-FD_CLOEXEC-as-necessary.patch \ | 11 | file://libsemanage-define-FD_CLOEXEC-as-necessary.patch \ |
13 | file://libsemanage-allow-to-disable-audit-support.patch \ | 12 | file://libsemanage-allow-to-disable-audit-support.patch \ |
14 | file://libsemanage-disable-expand-check-on-policy-load.patch \ | 13 | file://libsemanage-disable-expand-check-on-policy-load.patch \ |