diff options
Diffstat (limited to 'recipes-security/audit/audit/audit-python.patch')
-rw-r--r-- | recipes-security/audit/audit/audit-python.patch | 64 |
1 files changed, 0 insertions, 64 deletions
diff --git a/recipes-security/audit/audit/audit-python.patch b/recipes-security/audit/audit/audit-python.patch deleted file mode 100644 index c1a2595..0000000 --- a/recipes-security/audit/audit/audit-python.patch +++ /dev/null | |||
@@ -1,64 +0,0 @@ | |||
1 | From 9d95d7e28a2c4cbefa998d375de180c731a151b1 Mon Sep 17 00:00:00 2001 | ||
2 | From: Li xin <lixin.fnst@cn.fujitsu.com> | ||
3 | Date: Sun, 19 Jul 2015 01:40:48 +0900 | ||
4 | Subject: [PATCH] Remove hard coded python include directory | ||
5 | |||
6 | Upstream-Status: Inappropriate [embedded specific] | ||
7 | |||
8 | Signed-off-by: Mark Hatle <mark.hatle@windriver.com> | ||
9 | --- | ||
10 | bindings/Makefile.am | 8 +++++++- | ||
11 | bindings/python/python2/Makefile.am | 3 ++- | ||
12 | bindings/swig/python/Makefile.am | 5 +++-- | ||
13 | 3 files changed, 12 insertions(+), 4 deletions(-) | ||
14 | |||
15 | diff --git a/bindings/Makefile.am b/bindings/Makefile.am | ||
16 | index 5b5c576..7a15205 100644 | ||
17 | --- a/bindings/Makefile.am | ||
18 | +++ b/bindings/Makefile.am | ||
19 | @@ -22,4 +22,10 @@ | ||
20 | |||
21 | CONFIG_CLEAN_FILES = *.loT *.rej *.orig | ||
22 | |||
23 | -SUBDIRS = python golang swig | ||
24 | +SUBDIRS = swig | ||
25 | +if HAVE_PYTHON | ||
26 | +SUBDIRS += python | ||
27 | +endif | ||
28 | +if HAVE_GOLANG | ||
29 | +SUBDIRS += golang | ||
30 | +endif | ||
31 | diff --git a/bindings/python/python2/Makefile.am b/bindings/python/python2/Makefile.am | ||
32 | index 1dcb5bc..6226358 100644 | ||
33 | --- a/bindings/python/python2/Makefile.am | ||
34 | +++ b/bindings/python/python2/Makefile.am | ||
35 | @@ -23,7 +23,8 @@ | ||
36 | |||
37 | CONFIG_CLEAN_FILES = *.loT *.rej *.orig | ||
38 | AM_CFLAGS = -fPIC -DPIC -fno-strict-aliasing | ||
39 | -AM_CPPFLAGS = -I$(top_builddir) -I@PYINCLUDEDIR@ | ||
40 | +PYINC ?= /usr/include/python$(PYTHON_VERSION) | ||
41 | +AM_CPPFLAGS = -I$(top_builddir) -I${PYINC} | ||
42 | |||
43 | pyexec_LTLIBRARIES = auparse.la | ||
44 | |||
45 | diff --git a/bindings/swig/python/Makefile.am b/bindings/swig/python/Makefile.am | ||
46 | index 8c98b94..ae7c52b 100644 | ||
47 | --- a/bindings/swig/python/Makefile.am | ||
48 | +++ b/bindings/swig/python/Makefile.am | ||
49 | @@ -21,9 +21,10 @@ | ||
50 | # | ||
51 | CONFIG_CLEAN_FILES = *.loT *.rej *.orig | ||
52 | AM_CFLAGS = -fPIC -DPIC -fno-strict-aliasing | ||
53 | -AM_CPPFLAGS = -I. -I$(top_builddir) -I${top_srcdir}/lib -I@PYINCLUDEDIR@ | ||
54 | +PYINC ?= /usr/include/$(PYLIBVER) | ||
55 | +AM_CPPFLAGS = -I. -I$(top_builddir) -I${top_srcdir}/lib -I${PYINC} | ||
56 | SWIG_FLAGS = -python | ||
57 | -SWIG_INCLUDES = -I. -I$(top_builddir) -I${top_srcdir}/lib -I@PYINCLUDEDIR@ | ||
58 | +SWIG_INCLUDES = -I. -I$(top_builddir) -I${top_srcdir}/lib -I${PYINC} | ||
59 | pyexec_PYTHON = audit.py | ||
60 | pyexec_LTLIBRARIES = _audit.la | ||
61 | pyexec_SOLIBRARIES = _audit.so | ||
62 | -- | ||
63 | 2.7.4 | ||
64 | |||