diff options
7 files changed, 58 insertions, 0 deletions
diff --git a/meta-ti-bsp/conf/machine/am62lxx-evm.conf b/meta-ti-bsp/conf/machine/am62lxx-evm.conf new file mode 100644 index 00000000..ff373238 --- /dev/null +++ b/meta-ti-bsp/conf/machine/am62lxx-evm.conf | |||
@@ -0,0 +1,13 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: AM62L EVM | ||
3 | #@DESCRIPTION: Machine configuration for the TI AM62L EVM | ||
4 | |||
5 | require conf/machine/include/am62lxx.inc | ||
6 | |||
7 | KERNEL_DEVICETREE_PREFIX = " \ | ||
8 | ti/k3-am62l \ | ||
9 | " | ||
10 | |||
11 | KERNEL_DEVICETREE = "" | ||
12 | |||
13 | UBOOT_MACHINE = "am62lx_evm_defconfig" | ||
diff --git a/meta-ti-bsp/conf/machine/include/am62lxx.inc b/meta-ti-bsp/conf/machine/include/am62lxx.inc new file mode 100644 index 00000000..d3bc81df --- /dev/null +++ b/meta-ti-bsp/conf/machine/include/am62lxx.inc | |||
@@ -0,0 +1,12 @@ | |||
1 | require conf/machine/include/k3.inc | ||
2 | SOC_FAMILY:append = ":am62lxx" | ||
3 | |||
4 | MACHINE_FEATURES += "screen" | ||
5 | |||
6 | # Default tiboot3.bin on AM62L is for HS-FS | ||
7 | IMAGE_BOOT_FILES += "tiboot3-am62lx-hs-fs-evm.bin" | ||
8 | |||
9 | TFA_BOARD = "am62l" | ||
10 | TFA_K3_SYSTEM_SUSPEND = "1" | ||
11 | |||
12 | OPTEEMACHINE = "k3-am62lx" | ||
diff --git a/meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb b/meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb index 0b6792b6..638138f4 100644 --- a/meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb +++ b/meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb | |||
@@ -31,6 +31,7 @@ PLAT_SFX:am65xx = "am65xx" | |||
31 | PLAT_SFX:am64xx = "am64xx" | 31 | PLAT_SFX:am64xx = "am64xx" |
32 | PLAT_SFX:am62xx = "am62xx" | 32 | PLAT_SFX:am62xx = "am62xx" |
33 | PLAT_SFX:am62axx = "am62axx" | 33 | PLAT_SFX:am62axx = "am62axx" |
34 | PLAT_SFX:am62lxx = "am62lxx" | ||
34 | PLAT_SFX:am62pxx = "am62pxx" | 35 | PLAT_SFX:am62pxx = "am62pxx" |
35 | 36 | ||
36 | DM_FW_DIR = "ti-dm/${PLAT_SFX}" | 37 | DM_FW_DIR = "ti-dm/${PLAT_SFX}" |
@@ -50,6 +51,7 @@ DM_FW_LIST:am65xx = "" | |||
50 | DM_FW_LIST:am64xx = "" | 51 | DM_FW_LIST:am64xx = "" |
51 | DM_FW_LIST:am62xx = "${DM_FIRMWARE}" | 52 | DM_FW_LIST:am62xx = "${DM_FIRMWARE}" |
52 | DM_FW_LIST:am62axx = "${DM_FIRMWARE}" | 53 | DM_FW_LIST:am62axx = "${DM_FIRMWARE}" |
54 | DM_FW_LIST:am62lxx = "" | ||
53 | DM_FW_LIST:am62pxx = "${DM_FIRMWARE}" | 55 | DM_FW_LIST:am62pxx = "${DM_FIRMWARE}" |
54 | 56 | ||
55 | do_install() { | 57 | do_install() { |
diff --git a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb index 12292c88..0d724862 100644 --- a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb +++ b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | |||
@@ -26,4 +26,10 @@ do_deploy:k3r5() { | |||
26 | install -m 644 ${S}/ti-sysfw/ti-fs-stub-firmware-* ${DEPLOYDIR}/ti-sysfw | 26 | install -m 644 ${S}/ti-sysfw/ti-fs-stub-firmware-* ${DEPLOYDIR}/ti-sysfw |
27 | } | 27 | } |
28 | 28 | ||
29 | do_deploy:am62lxx(){ | ||
30 | install -d ${DEPLOYDIR}/ti-sysfw | ||
31 | install -m 644 ${S}/ti-sysfw/ti-sci-firmware-* ${DEPLOYDIR}/ti-sysfw | ||
32 | install -m 644 ${S}/ti-sysfw/ti-fs-firmware-* ${DEPLOYDIR}/ti-sysfw | ||
33 | } | ||
34 | |||
29 | addtask deploy before do_build after do_compile | 35 | addtask deploy before do_build after do_compile |
diff --git a/meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a-ti.inc b/meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a-ti.inc index c628eb15..9971e960 100644 --- a/meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a-ti.inc +++ b/meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a-ti.inc | |||
@@ -7,5 +7,8 @@ TFA_BUILD_TARGET:k3 = "all" | |||
7 | TFA_INSTALL_TARGET:k3 = "bl31" | 7 | TFA_INSTALL_TARGET:k3 = "bl31" |
8 | TFA_SPD:k3 = "opteed" | 8 | TFA_SPD:k3 = "opteed" |
9 | 9 | ||
10 | # For am62lxx, install bl1 & bl31 using TFA_INSTALL_TARGET | ||
11 | TFA_INSTALL_TARGET:am62lxx = "bl31 bl1" | ||
12 | |||
10 | EXTRA_OEMAKE:append:k3 = "${@ ' K3_USART=' + d.getVar('TFA_K3_USART') if d.getVar('TFA_K3_USART') else ''}" | 13 | EXTRA_OEMAKE:append:k3 = "${@ ' K3_USART=' + d.getVar('TFA_K3_USART') if d.getVar('TFA_K3_USART') else ''}" |
11 | EXTRA_OEMAKE:append:k3 = "${@ ' K3_PM_SYSTEM_SUSPEND=' + d.getVar('TFA_K3_SYSTEM_SUSPEND') if d.getVar('TFA_K3_SYSTEM_SUSPEND') else ''}" | 14 | EXTRA_OEMAKE:append:k3 = "${@ ' K3_PM_SYSTEM_SUSPEND=' + d.getVar('TFA_K3_SYSTEM_SUSPEND') if d.getVar('TFA_K3_SYSTEM_SUSPEND') else ''}" |
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc index 0e7e2c6e..41d4abdd 100644 --- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc +++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc | |||
@@ -53,8 +53,10 @@ PLAT_SFX:am65xx = "am65xx" | |||
53 | PLAT_SFX:am64xx = "am64xx" | 53 | PLAT_SFX:am64xx = "am64xx" |
54 | PLAT_SFX:am62xx = "am62xx" | 54 | PLAT_SFX:am62xx = "am62xx" |
55 | PLAT_SFX:am62axx = "am62axx" | 55 | PLAT_SFX:am62axx = "am62axx" |
56 | PLAT_SFX:am62lxx = "am62lxx" | ||
56 | PLAT_SFX:am62pxx = "am62pxx" | 57 | PLAT_SFX:am62pxx = "am62pxx" |
57 | 58 | ||
59 | PACKAGECONFIG[ap-trusted-rom] = "BL1=${STAGING_DIR_HOST}/firmware/bl1.bin,,trusted-firmware-a" | ||
58 | PACKAGECONFIG[atf] = "BL31=${STAGING_DIR_HOST}/firmware/bl31.bin,,trusted-firmware-a" | 60 | PACKAGECONFIG[atf] = "BL31=${STAGING_DIR_HOST}/firmware/bl31.bin,,trusted-firmware-a" |
59 | PACKAGECONFIG[optee] = "TEE=${STAGING_DIR_HOST}${nonarch_base_libdir}/firmware/bl32.bin,,optee-os" | 61 | PACKAGECONFIG[optee] = "TEE=${STAGING_DIR_HOST}${nonarch_base_libdir}/firmware/bl32.bin,,optee-os" |
60 | PACKAGECONFIG[dm] = "DM=${STAGING_DIR_HOST}${nonarch_base_libdir}/firmware/ti-dm/${PLAT_SFX}/${DM_FIRMWARE},,ti-dm-fw" | 62 | PACKAGECONFIG[dm] = "DM=${STAGING_DIR_HOST}${nonarch_base_libdir}/firmware/ti-dm/${PLAT_SFX}/${DM_FIRMWARE},,ti-dm-fw" |
@@ -68,6 +70,7 @@ PACKAGECONFIG:append:j722s = " dm" | |||
68 | PACKAGECONFIG:append:j742s2 = " dm" | 70 | PACKAGECONFIG:append:j742s2 = " dm" |
69 | PACKAGECONFIG:append:am62xx = " dm" | 71 | PACKAGECONFIG:append:am62xx = " dm" |
70 | PACKAGECONFIG:append:am62axx = " dm" | 72 | PACKAGECONFIG:append:am62axx = " dm" |
73 | PACKAGECONFIG:append:am62lxx = " ap-trusted-rom" | ||
71 | PACKAGECONFIG:append:am62pxx = " dm" | 74 | PACKAGECONFIG:append:am62pxx = " dm" |
72 | 75 | ||
73 | COMPATIBLE_MACHINE = "(ti-soc)" | 76 | COMPATIBLE_MACHINE = "(ti-soc)" |
@@ -226,6 +229,16 @@ uboot_deploy_config:append:k3r5 () { | |||
226 | done | 229 | done |
227 | } | 230 | } |
228 | 231 | ||
232 | uboot_deploy_config:append:am62lxx () { | ||
233 | for f in ${B}/${config}/tiboot3-*.bin; do | ||
234 | if [ -f "$f" ]; then | ||
235 | f_base=$(basename $f) | ||
236 | install -m 644 $f ${DEPLOYDIR}/${f_base}-${type} | ||
237 | ln -sf ${f_base}-${type} ${DEPLOYDIR}/${f_base} | ||
238 | fi | ||
239 | done | ||
240 | } | ||
241 | |||
229 | uboot_deploy:append:k3r5 () { | 242 | uboot_deploy:append:k3r5 () { |
230 | for f in ${B}/tiboot3-*.bin; do | 243 | for f in ${B}/tiboot3-*.bin; do |
231 | if [ -f "$f" ]; then | 244 | if [ -f "$f" ]; then |
@@ -240,6 +253,14 @@ uboot_deploy:append:k3r5 () { | |||
240 | done | 253 | done |
241 | } | 254 | } |
242 | 255 | ||
256 | uboot_deploy:append:am62lxx () { | ||
257 | for f in ${B}/tiboot3*.bin; do | ||
258 | if [ -f "$f" ]; then | ||
259 | install -m 644 $f ${DEPLOYDIR}/ | ||
260 | fi | ||
261 | done | ||
262 | } | ||
263 | |||
243 | uboot_deploy_config:append () { | 264 | uboot_deploy_config:append () { |
244 | cd ${DEPLOYDIR} | 265 | cd ${DEPLOYDIR} |
245 | if [ "x${SPL_UART_BINARY}" != "x" ]; then | 266 | if [ "x${SPL_UART_BINARY}" != "x" ]; then |
diff --git a/meta-ti-bsp/recipes-security/optee/optee-os-ti-overrides.inc b/meta-ti-bsp/recipes-security/optee/optee-os-ti-overrides.inc index f131f1ff..5756f3ff 100644 --- a/meta-ti-bsp/recipes-security/optee/optee-os-ti-overrides.inc +++ b/meta-ti-bsp/recipes-security/optee/optee-os-ti-overrides.inc | |||
@@ -6,6 +6,7 @@ EXTRA_OEMAKE:remove = "CFG_MAP_EXT_DT_SECURE=y" | |||
6 | EXTRA_OEMAKE:append:k3 = "${@ ' CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}" | 6 | EXTRA_OEMAKE:append:k3 = "${@ ' CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}" |
7 | 7 | ||
8 | EXTRA_OEMAKE:append:am62xx = " CFG_TEE_CORE_LOG_LEVEL=1" | 8 | EXTRA_OEMAKE:append:am62xx = " CFG_TEE_CORE_LOG_LEVEL=1" |
9 | EXTRA_OEMAKE:append:am62lxx = " CFG_TEE_CORE_LOG_LEVEL=1" | ||
9 | EXTRA_OEMAKE:append:am62pxx = " CFG_TEE_CORE_LOG_LEVEL=1" | 10 | EXTRA_OEMAKE:append:am62pxx = " CFG_TEE_CORE_LOG_LEVEL=1" |
10 | EXTRA_OEMAKE:append:am62axx = " CFG_TEE_CORE_LOG_LEVEL=1" | 11 | EXTRA_OEMAKE:append:am62axx = " CFG_TEE_CORE_LOG_LEVEL=1" |
11 | EXTRA_OEMAKE:append:j722s = " CFG_TEE_CORE_LOG_LEVEL=1" | 12 | EXTRA_OEMAKE:append:j722s = " CFG_TEE_CORE_LOG_LEVEL=1" |