diff options
author | OYTIS <tossel@gmail.com> | 2016-12-20 15:19:17 +0100 |
---|---|---|
committer | GitHub <noreply@github.com> | 2016-12-20 15:19:17 +0100 |
commit | 17e728e33bcb430b01dc3c424b313d1bbe3aae7c (patch) | |
tree | d890826197dcd77c5384691332f1d167f1a63208 | |
parent | 7ad5573662a0e6b3845e00e860846ca9c579f1e6 (diff) | |
parent | 65535be95067665b1212d7f7963e474f3b628af5 (diff) | |
download | meta-updater-17e728e33bcb430b01dc3c424b313d1bbe3aae7c.tar.gz |
Merge pull request #12 from advancedtelematic/feat/nosystemd
Make systemd optional
-rw-r--r-- | classes/image_types_ostree.bbclass | 35 | ||||
-rw-r--r-- | conf/distro/sota.conf.inc | 5 | ||||
-rw-r--r-- | recipes-sota/ostree/ostree_git.bb | 9 | ||||
-rw-r--r-- | recipes-sota/rvi-sota-client/rvi-sota-client_git.bb | 149 | ||||
-rw-r--r-- | recipes-support/libgsystem/libgsystem_git.bb | 4 |
5 files changed, 102 insertions, 100 deletions
diff --git a/classes/image_types_ostree.bbclass b/classes/image_types_ostree.bbclass index 32ea98f..f88140c 100644 --- a/classes/image_types_ostree.bbclass +++ b/classes/image_types_ostree.bbclass | |||
@@ -14,6 +14,8 @@ RAMDISK_EXT_arm ?= ".ext4.gz.u-boot" | |||
14 | 14 | ||
15 | OSTREE_KERNEL ??= "${KERNEL_IMAGETYPE}" | 15 | OSTREE_KERNEL ??= "${KERNEL_IMAGETYPE}" |
16 | 16 | ||
17 | export SYSTEMD_USED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', '', d)}" | ||
18 | |||
17 | IMAGE_CMD_ostree () { | 19 | IMAGE_CMD_ostree () { |
18 | if [ -z "$OSTREE_REPO" ]; then | 20 | if [ -z "$OSTREE_REPO" ]; then |
19 | bbfatal "OSTREE_REPO should be set in your local.conf" | 21 | bbfatal "OSTREE_REPO should be set in your local.conf" |
@@ -51,13 +53,21 @@ IMAGE_CMD_ostree () { | |||
51 | fi | 53 | fi |
52 | done | 54 | done |
53 | 55 | ||
54 | if [ ! -d "usr/etc/tmpfiles.d" ]; then | 56 | if [ -n "$SYSTEMD_USED" ]; then |
55 | mkdir usr/etc/tmpfiles.d | 57 | mkdir -p usr/etc/tmpfiles.d |
58 | tmpfiles_conf=usr/etc/tmpfiles.d/00ostree-tmpfiles.conf | ||
59 | echo "d /var/rootdirs 0755 root root -" >>${tmpfiles_conf} | ||
60 | echo "L /var/rootdirs/home - - - - /sysroot/home" >>${tmpfiles_conf} | ||
61 | else | ||
62 | mkdir -p usr/etc/init.d | ||
63 | tmpfiles_conf=usr/etc/init.d/tmpfiles.sh | ||
64 | echo '#!/bin/sh' > ${tmpfiles_conf} | ||
65 | echo "mkdir -p /var/rootdirs; chmod 755 /var/rootdirs" >> ${tmpfiles_conf} | ||
66 | echo "ln -sf /sysroot/home /var/rootdirs/home" >> ${tmpfiles_conf} | ||
67 | |||
68 | ln -s ../init.d/tmpfiles.sh usr/etc/rcS.d/S20tmpfiles.sh | ||
56 | fi | 69 | fi |
57 | tmpfiles_conf=usr/etc/tmpfiles.d/00ostree-tmpfiles.conf | ||
58 | 70 | ||
59 | echo "d /var/rootdirs 0755 root root -" >>${tmpfiles_conf} | ||
60 | echo "L /var/rootdirs/home - - - - /sysroot/home" >>${tmpfiles_conf} | ||
61 | # Preserve data in /home to be later copied to /sysroot/home by | 71 | # Preserve data in /home to be later copied to /sysroot/home by |
62 | # sysroot generating procedure | 72 | # sysroot generating procedure |
63 | mkdir -p usr/homedirs | 73 | mkdir -p usr/homedirs |
@@ -74,7 +84,12 @@ IMAGE_CMD_ostree () { | |||
74 | if [ "$(ls -A $dir)" ]; then | 84 | if [ "$(ls -A $dir)" ]; then |
75 | bbwarn "Data in /$dir directory is not preserved by OSTree. Consider moving it under /usr" | 85 | bbwarn "Data in /$dir directory is not preserved by OSTree. Consider moving it under /usr" |
76 | fi | 86 | fi |
77 | echo "d /var/rootdirs/${dir} 0755 root root -" >>${tmpfiles_conf} | 87 | |
88 | if [ -n "$SYSTEMD_USED" ]; then | ||
89 | echo "d /var/rootdirs/${dir} 0755 root root -" >>${tmpfiles_conf} | ||
90 | else | ||
91 | echo "mkdir -p /var/rootdirs/${dir}; chown 755 /var/rootdirs/${dir}" >>${tmpfiles_conf} | ||
92 | fi | ||
78 | rm -rf ${dir} | 93 | rm -rf ${dir} |
79 | ln -sf var/rootdirs/${dir} ${dir} | 94 | ln -sf var/rootdirs/${dir} ${dir} |
80 | fi | 95 | fi |
@@ -84,7 +99,13 @@ IMAGE_CMD_ostree () { | |||
84 | if [ "$(ls -A root)" ]; then | 99 | if [ "$(ls -A root)" ]; then |
85 | bberror "Data in /root directory is not preserved by OSTree." | 100 | bberror "Data in /root directory is not preserved by OSTree." |
86 | fi | 101 | fi |
87 | echo "d /var/roothome 0755 root root -" >>${tmpfiles_conf} | 102 | |
103 | if [ -n "$SYSTEMD_USED" ]; then | ||
104 | echo "d /var/roothome 0755 root root -" >>${tmpfiles_conf} | ||
105 | else | ||
106 | echo "mkdir -p /var/roothome; chown 755 /var/roothome" >>${tmpfiles_conf} | ||
107 | fi | ||
108 | |||
88 | rm -rf root | 109 | rm -rf root |
89 | ln -sf var/roothome root | 110 | ln -sf var/roothome root |
90 | fi | 111 | fi |
diff --git a/conf/distro/sota.conf.inc b/conf/distro/sota.conf.inc index 5520154..3136092 100644 --- a/conf/distro/sota.conf.inc +++ b/conf/distro/sota.conf.inc | |||
@@ -27,9 +27,4 @@ PREFERRED_PROVIDER_virtual/bootloader_raspberrypi3 = "u-boot" | |||
27 | # Some BSPs (e.g. meta-raspberrypi) use this variable to turn debug on/off | 27 | # Some BSPs (e.g. meta-raspberrypi) use this variable to turn debug on/off |
28 | DISTRO_TYPE ?= "${@bb.utils.contains("IMAGE_FEATURES", "debug-tweaks", "debug", "release",d)}" | 28 | DISTRO_TYPE ?= "${@bb.utils.contains("IMAGE_FEATURES", "debug-tweaks", "debug", "release",d)}" |
29 | 29 | ||
30 | DISTRO_FEATURES_append = " systemd" | ||
31 | PREFERRED_PROVIDER_udev ?= "systemd" | ||
32 | PREFERRED_PROVIDER_udev-utils ?= "systemd" | ||
33 | VIRTUAL-RUNTIME_init_manager = "systemd" | ||
34 | |||
35 | DISTROOVERRIDES_append = ":sota" | 30 | DISTROOVERRIDES_append = ":sota" |
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb index d444669..b6adf9b 100644 --- a/recipes-sota/ostree/ostree_git.bb +++ b/recipes-sota/ostree/ostree_git.bb | |||
@@ -14,7 +14,9 @@ S = "${WORKDIR}/git" | |||
14 | 14 | ||
15 | BBCLASSEXTEND = "native" | 15 | BBCLASSEXTEND = "native" |
16 | 16 | ||
17 | DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4 e2fsprogs systemd" | 17 | DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4 e2fsprogs" |
18 | DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" | ||
19 | |||
18 | DEPENDS_remove_class-native = "systemd-native" | 20 | DEPENDS_remove_class-native = "systemd-native" |
19 | 21 | ||
20 | RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap xz os-release" | 22 | RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap xz os-release" |
@@ -25,7 +27,7 @@ EXTRA_OEMAKE = "CFLAGS='-g'" | |||
25 | EXTRA_OECONF_append_class-native = " --enable-wrpseudo-compat" | 27 | EXTRA_OECONF_append_class-native = " --enable-wrpseudo-compat" |
26 | 28 | ||
27 | SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}" | 29 | SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}" |
28 | SYSTEMD_REQUIRED_class-native = "" | 30 | SYSTEMD_REQUIRED_class-native = "false" |
29 | 31 | ||
30 | SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service" | 32 | SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service" |
31 | SYSTEMD_SERVICE_${PN}_class-native = "" | 33 | SYSTEMD_SERVICE_${PN}_class-native = "" |
@@ -52,8 +54,7 @@ do_compile_prepend() { | |||
52 | export SYSTEMD_REQUIRED | 54 | export SYSTEMD_REQUIRED |
53 | 55 | ||
54 | do_install_append() { | 56 | do_install_append() { |
55 | if [ -n ${SYSTEMD_REQUIRED} ]; then | 57 | if [ "$SYSTEMD_REQUIRED" == "true" ]; then |
56 | install -p -D ${S}/src/boot/ostree-prepare-root.service ${D}${systemd_unitdir}/system/ostree-prepare-root.service | ||
57 | install -p -D ${S}/src/boot/ostree-remount.service ${D}${systemd_unitdir}/system/ostree-remount.service | 58 | install -p -D ${S}/src/boot/ostree-remount.service ${D}${systemd_unitdir}/system/ostree-remount.service |
58 | fi | 59 | fi |
59 | } | 60 | } |
diff --git a/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb b/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb index 9a7ec10..0acc6c6 100644 --- a/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb +++ b/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb | |||
@@ -8,97 +8,90 @@ inherit cargo systemd | |||
8 | 8 | ||
9 | S = "${WORKDIR}/git" | 9 | S = "${WORKDIR}/git" |
10 | 10 | ||
11 | SRCREV = "72e6096d9122cde2d9ece4e2693bd470e2b57abe" | 11 | SRCREV = "7fa3b3e088ed002d8d99b5496c5755f0fb358ab0" |
12 | 12 | ||
13 | # Generate with: | 13 | # Generate with: |
14 | # git describe --tags | cut -b2- | 14 | # git describe --tags | cut -b2- |
15 | PV = "v0.2.22-4-g72e6096" | 15 | PV = "0.2.23-5-g7fa3b3e" |
16 | 16 | ||
17 | BBCLASSEXTEND = "native" | 17 | BBCLASSEXTEND = "native" |
18 | 18 | ||
19 | FILES_${PN} = " \ | 19 | FILES_${PN} = " \ |
20 | ${bindir}/sota_client \ | 20 | /usr/bin/sota_client \ |
21 | ${bindir}/system_info.sh \ | 21 | /usr/bin/sota_sysinfo.sh \ |
22 | ${sysconfdir}/sota_client.version \ | 22 | /etc/sota_client.version \ |
23 | ${sysconfdir}/sota_certificates \ | 23 | /etc/sota_certificates \ |
24 | ${systemd_unitdir}/system/sota_client.service \ | 24 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_unitdir}/system/sota_client.service', '', d)} \ |
25 | ${bindir}/sota_ostree.sh \ | ||
26 | " | 25 | " |
27 | 26 | ||
28 | SRC_URI = " \ | 27 | SRC_URI = " \ |
29 | crate://crates.io/aho-corasick/0.5.3 \ | 28 | crate://crates.io/aho-corasick/0.5.3 \ |
30 | crate://crates.io/time/0.1.35 \ | ||
31 | crate://crates.io/url/1.2.1 \ | ||
32 | crate://crates.io/ws2_32-sys/0.2.1 \ | ||
33 | crate://crates.io/hyper/0.9.4 \ | ||
34 | crate://crates.io/log/0.3.6 \ | ||
35 | crate://crates.io/unicase/1.4.0 \ | ||
36 | crate://crates.io/bitflags/0.7.0 \ | ||
37 | crate://crates.io/bit-set/0.2.0 \ | 29 | crate://crates.io/bit-set/0.2.0 \ |
38 | crate://crates.io/lazy_static/0.2.1 \ | 30 | crate://crates.io/bit-vec/0.4.3 \ |
39 | crate://crates.io/rust-crypto/0.2.36 \ | 31 | crate://crates.io/bitflags/0.4.0 \ |
40 | crate://crates.io/typeable/0.1.2 \ | 32 | crate://crates.io/bitflags/0.7.0 \ |
41 | crate://crates.io/pkg-config/0.3.8 \ | 33 | crate://crates.io/bytes/0.3.0 \ |
42 | crate://crates.io/httparse/1.1.2 \ | 34 | crate://crates.io/cfg-if/0.1.0 \ |
43 | crate://crates.io/openssl/0.8.3 \ | 35 | crate://crates.io/chan-signal/0.1.7 \ |
44 | crate://crates.io/user32-sys/0.2.0 \ | ||
45 | crate://crates.io/regex/0.1.77 \ | ||
46 | crate://crates.io/unicode-normalization/0.1.2 \ | ||
47 | crate://crates.io/idna/0.1.0 \ | ||
48 | crate://crates.io/unicode-bidi/0.2.3 \ | ||
49 | crate://crates.io/rand/0.3.14 \ | ||
50 | crate://crates.io/gcc/0.3.37 \ | ||
51 | crate://crates.io/chan/0.1.18 \ | 36 | crate://crates.io/chan/0.1.18 \ |
52 | crate://crates.io/kernel32-sys/0.2.2 \ | 37 | crate://crates.io/cookie/0.2.5 \ |
53 | crate://crates.io/winapi/0.2.8 \ | ||
54 | crate://crates.io/crossbeam/0.2.10 \ | 38 | crate://crates.io/crossbeam/0.2.10 \ |
55 | crate://crates.io/bitflags/0.4.0 \ | ||
56 | crate://crates.io/thread-id/2.0.0 \ | ||
57 | crate://crates.io/mime/0.2.2 \ | ||
58 | crate://crates.io/thread_local/0.2.7 \ | ||
59 | crate://crates.io/utf8-ranges/0.1.3 \ | ||
60 | crate://crates.io/net2/0.2.26 \ | ||
61 | crate://crates.io/dbus/0.4.1 \ | 39 | crate://crates.io/dbus/0.4.1 \ |
62 | crate://crates.io/winapi-build/0.1.1 \ | 40 | crate://crates.io/env_logger/0.3.5 \ |
63 | crate://crates.io/chan-signal/0.1.7 \ | 41 | crate://crates.io/gcc/0.3.39 \ |
64 | crate://crates.io/bit-vec/0.4.3 \ | 42 | crate://crates.io/gdi32-sys/0.2.0 \ |
65 | crate://crates.io/toml/0.2.1 \ | ||
66 | crate://crates.io/quick-error/0.2.2 \ | ||
67 | crate://crates.io/ws/0.5.3 \ | ||
68 | crate://crates.io/traitobject/0.0.1 \ | ||
69 | crate://crates.io/cfg-if/0.1.0 \ | ||
70 | crate://crates.io/matches/0.1.3 \ | ||
71 | crate://crates.io/getopts/0.2.14 \ | 43 | crate://crates.io/getopts/0.2.14 \ |
72 | crate://crates.io/sha1/0.2.0 \ | 44 | crate://crates.io/hpack/0.2.0 \ |
73 | crate://crates.io/openssl-sys/0.7.17 \ | 45 | crate://crates.io/httparse/1.2.1 \ |
74 | crate://crates.io/cookie/0.2.5 \ | 46 | crate://crates.io/hyper/0.9.13 \ |
75 | crate://crates.io/libressl-pnacl-sys/2.1.6 \ | 47 | crate://crates.io/idna/0.1.0 \ |
48 | crate://crates.io/kernel32-sys/0.2.2 \ | ||
76 | crate://crates.io/language-tags/0.2.2 \ | 49 | crate://crates.io/language-tags/0.2.2 \ |
77 | crate://crates.io/semver/0.1.20 \ | 50 | crate://crates.io/lazy_static/0.1.16 \ |
78 | crate://crates.io/unix_socket/0.5.0 \ | 51 | crate://crates.io/lazy_static/0.2.2 \ |
52 | crate://crates.io/libc/0.2.18 \ | ||
53 | crate://crates.io/log/0.3.6 \ | ||
54 | crate://crates.io/matches/0.1.4 \ | ||
79 | crate://crates.io/memchr/0.1.11 \ | 55 | crate://crates.io/memchr/0.1.11 \ |
80 | crate://crates.io/gdi32-sys/0.2.0 \ | 56 | crate://crates.io/mime/0.2.2 \ |
81 | crate://crates.io/nom/1.2.4 \ | ||
82 | crate://crates.io/mio/0.5.1 \ | 57 | crate://crates.io/mio/0.5.1 \ |
83 | crate://crates.io/tempdir/0.3.5 \ | ||
84 | crate://crates.io/miow/0.1.3 \ | 58 | crate://crates.io/miow/0.1.3 \ |
85 | crate://crates.io/pnacl-build-helper/1.4.10 \ | 59 | crate://crates.io/net2/0.2.26 \ |
86 | crate://crates.io/libc/0.2.17 \ | ||
87 | crate://crates.io/nix/0.5.1 \ | 60 | crate://crates.io/nix/0.5.1 \ |
61 | crate://crates.io/nom/1.2.4 \ | ||
62 | crate://crates.io/num_cpus/1.2.0 \ | ||
63 | crate://crates.io/openssl-sys/0.9.3 \ | ||
64 | crate://crates.io/openssl/0.9.3 \ | ||
65 | crate://crates.io/pkg-config/0.3.8 \ | ||
66 | crate://crates.io/rand/0.3.15 \ | ||
67 | crate://crates.io/regex-syntax/0.3.9 \ | ||
68 | crate://crates.io/regex/0.1.80 \ | ||
69 | crate://crates.io/rust-crypto/0.2.36 \ | ||
70 | crate://crates.io/rustc-serialize/0.3.22 \ | ||
88 | crate://crates.io/rustc_version/0.1.7 \ | 71 | crate://crates.io/rustc_version/0.1.7 \ |
72 | crate://crates.io/semver/0.1.20 \ | ||
73 | crate://crates.io/sha1/0.2.0 \ | ||
89 | crate://crates.io/slab/0.1.3 \ | 74 | crate://crates.io/slab/0.1.3 \ |
90 | crate://crates.io/rustc-serialize/0.3.19 \ | 75 | crate://crates.io/solicit/0.4.4 \ |
91 | crate://crates.io/env_logger/0.3.5 \ | 76 | crate://crates.io/thread-id/2.0.0 \ |
92 | crate://crates.io/vecio/0.1.0 \ | 77 | crate://crates.io/thread_local/0.2.7 \ |
93 | crate://crates.io/rotor/0.6.3 \ | 78 | crate://crates.io/time/0.1.35 \ |
94 | crate://crates.io/openssl-sys-extras/0.7.14 \ | 79 | crate://crates.io/toml/0.2.1 \ |
95 | crate://crates.io/regex-syntax/0.3.7 \ | 80 | crate://crates.io/traitobject/0.0.1 \ |
96 | crate://crates.io/bytes/0.3.0 \ | 81 | crate://crates.io/typeable/0.1.2 \ |
97 | crate://crates.io/void/1.0.2 \ | 82 | crate://crates.io/unicase/1.4.0 \ |
98 | crate://crates.io/spmc/0.2.1 \ | 83 | crate://crates.io/unicode-bidi/0.2.3 \ |
99 | crate://crates.io/openssl-verify/0.1.0 \ | 84 | crate://crates.io/unicode-normalization/0.1.2 \ |
100 | crate-index://crates.io/7670a5aa394d0dcd7598905b352d1634ca74d84a \ | 85 | crate://crates.io/unix_socket/0.5.0 \ |
86 | crate://crates.io/url/1.2.3 \ | ||
87 | crate://crates.io/user32-sys/0.2.0 \ | ||
88 | crate://crates.io/utf8-ranges/0.1.3 \ | ||
89 | crate://crates.io/winapi-build/0.1.1 \ | ||
90 | crate://crates.io/winapi/0.2.8 \ | ||
91 | crate://crates.io/ws/0.5.3 \ | ||
92 | crate://crates.io/ws2_32-sys/0.2.1 \ | ||
101 | git://github.com/advancedtelematic/rvi_sota_client \ | 93 | git://github.com/advancedtelematic/rvi_sota_client \ |
94 | crate-index://crates.io/213b1a455d9270888c03a42c8d29975369102caa \ | ||
102 | " | 95 | " |
103 | SRC_URI[index.md5sum] = "79f10f436dbf26737cc80445746f16b4" | 96 | SRC_URI[index.md5sum] = "79f10f436dbf26737cc80445746f16b4" |
104 | SRC_URI[index.sha256sum] = "86114b93f1f51aaf0aec3af0751d214b351f4ff9839ba031315c1b19dcbb1913" | 97 | SRC_URI[index.sha256sum] = "86114b93f1f51aaf0aec3af0751d214b351f4ff9839ba031315c1b19dcbb1913" |
@@ -113,30 +106,22 @@ RDEPENDS_${PN} = " libcrypto \ | |||
113 | lshw \ | 106 | lshw \ |
114 | jq \ | 107 | jq \ |
115 | " | 108 | " |
116 | export SOTA_VERSION = "${PV}" | ||
117 | 109 | ||
118 | do_compile_prepend() { | 110 | do_compile_prepend() { |
119 | # Fetch and build the specific build of hyper that is specified in cargo.toml. | 111 | export SOTA_VERSION=$(make sota-version) |
120 | # meta-rust doesn't support fetching crates that don't point to a specific tag | ||
121 | # and rvi-sota-client needs a specific work-around to function correctly. | ||
122 | make rust-openssl | ||
123 | } | ||
124 | |||
125 | do_compile_append() { | ||
126 | # Ensure that the 'make rust-openssl' above resulted in the local build of | ||
127 | # rust-openssl being used rather than the default one. | ||
128 | strings target/${TARGET_SYS}/release/sota_client | grep ${EXTENDPE}${PV}-${PR}/git/rust-openssl -q || (bberror "local rust-open ssl package not used"; exit 1) | ||
129 | } | 112 | } |
130 | 113 | ||
131 | do_install() { | 114 | do_install() { |
132 | install -d ${D}${bindir} | 115 | install -d ${D}${bindir} |
133 | install -m 0755 target/${TARGET_SYS}/release/sota_client ${D}${bindir} | 116 | install -m 0755 target/${TARGET_SYS}/release/sota_client ${D}${bindir} |
134 | install -m 0755 run/system_info.sh ${D}${bindir} | 117 | install -m 0755 run/sota_sysinfo.sh ${D}${bindir} |
135 | install -m 0755 run/sota_ostree.sh ${D}${bindir} | ||
136 | 118 | ||
137 | install -d ${D}${systemd_unitdir}/system | 119 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
138 | install -c ${S}/run/sota_client.service ${D}${systemd_unitdir}/system | 120 | install -d ${D}${systemd_unitdir}/system |
121 | install -c ${S}/run/sota_client.service ${D}${systemd_unitdir}/system | ||
122 | fi | ||
139 | 123 | ||
140 | install -d ${D}${sysconfdir} | 124 | install -d ${D}${sysconfdir} |
125 | echo `git log -1 --pretty=format:%H` > ${D}${sysconfdir}/sota_client.version | ||
141 | install -c ${S}/run/sota_certificates ${D}${sysconfdir} | 126 | install -c ${S}/run/sota_certificates ${D}${sysconfdir} |
142 | } | 127 | } |
diff --git a/recipes-support/libgsystem/libgsystem_git.bb b/recipes-support/libgsystem/libgsystem_git.bb index 181dd42..048c44b 100644 --- a/recipes-support/libgsystem/libgsystem_git.bb +++ b/recipes-support/libgsystem/libgsystem_git.bb | |||
@@ -9,9 +9,9 @@ S = "${WORKDIR}/git" | |||
9 | 9 | ||
10 | inherit autotools-brokensep gobject-introspection | 10 | inherit autotools-brokensep gobject-introspection |
11 | 11 | ||
12 | DEPENDS += "attr glib-2.0 pkgconfig libcap" | 12 | DEPENDS += "attr glib-2.0 pkgconfig libcap xz" |
13 | RDEPENDS_${PN} = "xz systemd" | ||
14 | 13 | ||
14 | RDEPENDS_${PN}_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" | ||
15 | RDEPENDS_${PN}_remove_class-native = "systemd-native" | 15 | RDEPENDS_${PN}_remove_class-native = "systemd-native" |
16 | 16 | ||
17 | BBCLASSEXTEND = "native" | 17 | BBCLASSEXTEND = "native" |