diff options
author | cajun-rat <phil@advancedtelematic.com> | 2018-02-07 12:00:13 +0100 |
---|---|---|
committer | GitHub <noreply@github.com> | 2018-02-07 12:00:13 +0100 |
commit | b9ee096ce72ef7aa17c4f3c946a81a3bbcedcc0d (patch) | |
tree | 095f6bbd5b75a77a22a296d8688fc33ca94c8281 | |
parent | 51173110ef607a90d3fe699a7f53b6fbe6c76385 (diff) | |
parent | aa5753067430de2fd7a94c5d07c68ae429465acf (diff) | |
download | meta-updater-b9ee096ce72ef7aa17c4f3c946a81a3bbcedcc0d.tar.gz |
Merge pull request #252 from rsalveti/master
Merge latest changes from the rocko branch
-rw-r--r-- | CONTRIBUTING.adoc | 4 | ||||
-rw-r--r-- | recipes-sota/aktualizr/aktualizr_git.bb | 12 |
2 files changed, 8 insertions, 8 deletions
diff --git a/CONTRIBUTING.adoc b/CONTRIBUTING.adoc index 7255a72..69509c3 100644 --- a/CONTRIBUTING.adoc +++ b/CONTRIBUTING.adoc | |||
@@ -10,6 +10,6 @@ We welcome pull requests from everyone. Here are some notes that are useful for | |||
10 | | `require classes/sota_bleeding.inc` | Always build the latest master of Aktualizr | 10 | | `require classes/sota_bleeding.inc` | Always build the latest master of Aktualizr |
11 | | `BRANCH_pn-aktualizr = "mybranch"` | 11 | | `BRANCH_pn-aktualizr = "mybranch"` |
12 | `BRANCH_pn-aktualizr-native = "mybranch"` | Build `mybranch` of Aktualizr (note that both of these need to be set). This will normally be used with `require classes/sota_bleeding.inc` | 12 | `BRANCH_pn-aktualizr-native = "mybranch"` | Build `mybranch` of Aktualizr (note that both of these need to be set). This will normally be used with `require classes/sota_bleeding.inc` |
13 | | `SRCREV_pn-aktualizr = "1004efa3f86cef90c012b34620992b5762b741e3"` | ||
14 | `SRCREV_pn-aktualizr-native = "1004efa3f86cef90c012b34620992b5762b741e3"` | Build the specified revision of Aktualizr (note that both of these need to be set). | ||
13 | | `TOOLCHAIN_HOST_TASK_append = " nativesdk-cmake "` | Use with `bitbake -c populate_sdk core-image-minimal` to build a SDK | 15 | | `TOOLCHAIN_HOST_TASK_append = " nativesdk-cmake "` | Use with `bitbake -c populate_sdk core-image-minimal` to build a SDK |
14 | |||
15 | |||
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb index beaf893..768ec3d 100644 --- a/recipes-sota/aktualizr/aktualizr_git.bb +++ b/recipes-sota/aktualizr/aktualizr_git.bb | |||
@@ -21,7 +21,7 @@ SRC_URI = " \ | |||
21 | file://aktualizr.service \ | 21 | file://aktualizr.service \ |
22 | file://aktualizr-serialcan.service \ | 22 | file://aktualizr-serialcan.service \ |
23 | " | 23 | " |
24 | SRCREV = "07d73645231681848bd943074498581e930d8582" | 24 | SRCREV = "d861896e7467e3e0cafdd7384ff87c62fe724640" |
25 | BRANCH ?= "master" | 25 | BRANCH ?= "master" |
26 | 26 | ||
27 | S = "${WORKDIR}/git" | 27 | S = "${WORKDIR}/git" |
@@ -49,9 +49,6 @@ do_install_append_class-target () { | |||
49 | install -d ${D}${systemd_unitdir}/system | 49 | install -d ${D}${systemd_unitdir}/system |
50 | aktualizr_service=${@bb.utils.contains('SOTA_CLIENT_FEATURES', 'serialcan', '${WORKDIR}/aktualizr-serialcan.service', '${WORKDIR}/aktualizr.service', d)} | 50 | aktualizr_service=${@bb.utils.contains('SOTA_CLIENT_FEATURES', 'serialcan', '${WORKDIR}/aktualizr-serialcan.service', '${WORKDIR}/aktualizr.service', d)} |
51 | install -m 0644 ${aktualizr_service} ${D}${systemd_unitdir}/system/aktualizr.service | 51 | install -m 0644 ${aktualizr_service} ${D}${systemd_unitdir}/system/aktualizr.service |
52 | |||
53 | install -d ${D}${libdir}/sota/schemas | ||
54 | install -m 0755 ${S}/config/storage/* ${D}${libdir}/sota/schemas | ||
55 | } | 52 | } |
56 | do_install_append_class-native () { | 53 | do_install_append_class-native () { |
57 | rm -f ${D}${bindir}/aktualizr | 54 | rm -f ${D}${bindir}/aktualizr |
@@ -66,19 +63,22 @@ do_install_append_class-native () { | |||
66 | install -m 0644 ${B}/src/sota_tools/garage-sign-prefix/src/garage-sign/lib/* ${D}${libdir} | 63 | install -m 0644 ${B}/src/sota_tools/garage-sign-prefix/src/garage-sign/lib/* ${D}${libdir} |
67 | } | 64 | } |
68 | 65 | ||
66 | FILES_${PN}_append = " \ | ||
67 | ${libdir}/sota \ | ||
68 | " | ||
69 | |||
69 | FILES_${PN}_class-target = " \ | 70 | FILES_${PN}_class-target = " \ |
70 | ${bindir}/aktualizr \ | 71 | ${bindir}/aktualizr \ |
71 | ${bindir}/aktualizr-info \ | 72 | ${bindir}/aktualizr-info \ |
72 | ${systemd_unitdir}/system/aktualizr.service \ | 73 | ${systemd_unitdir}/system/aktualizr.service \ |
73 | ${libdir}/sota/schemas \ | ||
74 | " | 74 | " |
75 | |||
75 | FILES_${PN}_append_class-target = " ${@bb.utils.contains('SOTA_CLIENT_FEATURES', 'secondary-example', ' ${bindir}/example-interface', '', d)} " | 76 | FILES_${PN}_append_class-target = " ${@bb.utils.contains('SOTA_CLIENT_FEATURES', 'secondary-example', ' ${bindir}/example-interface', '', d)} " |
76 | FILES_${PN}_append_class-target = " ${@bb.utils.contains('SOTA_CLIENT_FEATURES', 'secondary-isotp-example', ' ${bindir}/isotp-test-interface', '', d)} " | 77 | FILES_${PN}_append_class-target = " ${@bb.utils.contains('SOTA_CLIENT_FEATURES', 'secondary-isotp-example', ' ${bindir}/isotp-test-interface', '', d)} " |
77 | FILES_${PN}_class-native = " \ | 78 | FILES_${PN}_class-native = " \ |
78 | ${bindir}/aktualizr_implicit_writer \ | 79 | ${bindir}/aktualizr_implicit_writer \ |
79 | ${bindir}/garage-deploy \ | 80 | ${bindir}/garage-deploy \ |
80 | ${bindir}/garage-push \ | 81 | ${bindir}/garage-push \ |
81 | ${libdir}/sota/* \ | ||
82 | " | 82 | " |
83 | 83 | ||
84 | # vim:set ts=4 sw=4 sts=4 expandtab: | 84 | # vim:set ts=4 sw=4 sts=4 expandtab: |