summaryrefslogtreecommitdiffstats
path: root/recipes-support/libgsystem/libgsystem_git.bb
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-09-13 16:55:35 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2016-09-13 16:55:35 +0000
commit211b12c727d3d7edeedf8f93ad5221cd61a513fe (patch)
treec39ab62a54d7ea71948c79f82efafe8b88bcfa11 /recipes-support/libgsystem/libgsystem_git.bb
parent6cc7aad0c745d8d4b48f3dbbae6b72f573bc6816 (diff)
parentd0d74fbff4709ab9b093ec7785794d7f82b8e7b3 (diff)
downloadmeta-updater-211b12c727d3d7edeedf8f93ad5221cd61a513fe.tar.gz
Merge "Build OSTree natively, and its dependencies as well"
Diffstat (limited to 'recipes-support/libgsystem/libgsystem_git.bb')
-rw-r--r--recipes-support/libgsystem/libgsystem_git.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes-support/libgsystem/libgsystem_git.bb b/recipes-support/libgsystem/libgsystem_git.bb
new file mode 100644
index 0000000..4b1eb49
--- /dev/null
+++ b/recipes-support/libgsystem/libgsystem_git.bb
@@ -0,0 +1,38 @@
1SUMMARY = "GIO-based library, targeted primarily for use by operating system components"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
4
5SRC_URI = "gitsm://github.com/GNOME/libgsystem.git"
6SRCREV="d606bec68ddfea78de4b03c3f3568afb71bdc1ce"
7
8S = "${WORKDIR}/git"
9
10inherit autotools-brokensep
11
12DEPENDS += "attr glib-2.0 pkgconfig libcap"
13RDEPENDS_${PN} = "xz systemd"
14
15RDEPENDS_${PN}_remove_class-native = "systemd-native"
16
17BBCLASSEXTEND = "native"
18
19export STAGING_INCDIR
20export STAGING_LIBDIR
21
22do_configure() {
23 NOCONFIGURE=true ./autogen.sh
24 oe_runconf
25}
26
27do_compile_prepend() {
28 export BUILD_SYS="${BUILD_SYS}"
29 export HOST_SYS="${HOST_SYS}"
30}
31
32FILES_${PN} += " \
33 ${datadir} \
34 ${datadir}/gir-1.0 \
35 ${datadir}/gir-1.0/GSystem-1.0.gir \
36 ${libdir}/girepository-1.0/ \
37 ${libdir}/girepository-1.0/GSystem-1.0.typelib \
38"