diff options
author | Patrick Vacek <patrickvacek@gmail.com> | 2020-08-03 08:58:53 +0200 |
---|---|---|
committer | Patrick Vacek <patrickvacek@gmail.com> | 2020-08-03 13:47:30 +0200 |
commit | 628c4e317618d1b03da41e43cf0ede69c1fa4695 (patch) | |
tree | b389457e32963338ce779431ed8cebb5d11ed23e /recipes-test | |
parent | 5f7f0d139b3c81e163ad46d366cf1d843c3cb793 (diff) | |
download | meta-updater-fix/pythonnative.tar.gz |
Inherit python3native instead of using HOSTTOOLS.fix/pythonnative
Signed-off-by: Patrick Vacek <patrickvacek@gmail.com>
Diffstat (limited to 'recipes-test')
-rw-r--r-- | recipes-test/big-update/big-update_1.0.bb | 2 | ||||
-rw-r--r-- | recipes-test/big-update/big-update_2.0.bb | 2 |
2 files changed, 4 insertions, 0 deletions
diff --git a/recipes-test/big-update/big-update_1.0.bb b/recipes-test/big-update/big-update_1.0.bb index 3b1d652..dfb3a96 100644 --- a/recipes-test/big-update/big-update_1.0.bb +++ b/recipes-test/big-update/big-update_1.0.bb | |||
@@ -7,6 +7,8 @@ FILES_${PN} = "/usr/lib/big-update" | |||
7 | 7 | ||
8 | DEPENDS = "coreutils-native" | 8 | DEPENDS = "coreutils-native" |
9 | 9 | ||
10 | inherit python3native | ||
11 | |||
10 | do_install() { | 12 | do_install() { |
11 | install -d ${D}/usr/lib/big-update | 13 | install -d ${D}/usr/lib/big-update |
12 | python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 10M) | 14 | python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 10M) |
diff --git a/recipes-test/big-update/big-update_2.0.bb b/recipes-test/big-update/big-update_2.0.bb index 7cb6e94..6fffbc1 100644 --- a/recipes-test/big-update/big-update_2.0.bb +++ b/recipes-test/big-update/big-update_2.0.bb | |||
@@ -7,6 +7,8 @@ FILES_${PN} = "/usr/lib/big-update" | |||
7 | 7 | ||
8 | DEPENDS = "coreutils-native" | 8 | DEPENDS = "coreutils-native" |
9 | 9 | ||
10 | inherit python3native | ||
11 | |||
10 | do_install() { | 12 | do_install() { |
11 | install -d ${D}/usr/lib/big-update | 13 | install -d ${D}/usr/lib/big-update |
12 | python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 12M) | 14 | python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 12M) |