diff options
-rw-r--r-- | classes/image_types_ostree.bbclass | 3 | ||||
-rw-r--r-- | conf/distro/sota.conf.inc | 3 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot_2016.11.bb | 9 | ||||
-rw-r--r-- | recipes-sota/aktualizr/aktualizr_git.bb | 2 | ||||
-rw-r--r-- | recipes-sota/sota-tools/sota-tools_git.bb | 2 | ||||
-rw-r--r-- | recipes-support/glib-networking/glib-networking_%.bbappend | 7 | ||||
-rw-r--r-- | recipes-support/libsoup/libsoup-2.4_%.bbappend | 2 | ||||
-rw-r--r-- | scripts/lib/wic/plugins/source/otaimage.py | 11 |
8 files changed, 29 insertions, 10 deletions
diff --git a/classes/image_types_ostree.bbclass b/classes/image_types_ostree.bbclass index 8c9f262..110f88d 100644 --- a/classes/image_types_ostree.bbclass +++ b/classes/image_types_ostree.bbclass | |||
@@ -6,7 +6,8 @@ IMAGE_DEPENDS_ostree = "ostree-native:do_populate_sysroot \ | |||
6 | openssl-native:do_populate_sysroot \ | 6 | openssl-native:do_populate_sysroot \ |
7 | zip-native:do_populate_sysroot \ | 7 | zip-native:do_populate_sysroot \ |
8 | virtual/kernel:do_deploy \ | 8 | virtual/kernel:do_deploy \ |
9 | ${OSTREE_INITRAMFS_IMAGE}:do_image_complete" | 9 | ${OSTREE_INITRAMFS_IMAGE}:do_image_complete \ |
10 | unzip-native" | ||
10 | 11 | ||
11 | export OSTREE_REPO | 12 | export OSTREE_REPO |
12 | export OSTREE_BRANCHNAME | 13 | export OSTREE_BRANCHNAME |
diff --git a/conf/distro/sota.conf.inc b/conf/distro/sota.conf.inc index 7438424..ea1ca95 100644 --- a/conf/distro/sota.conf.inc +++ b/conf/distro/sota.conf.inc | |||
@@ -5,6 +5,9 @@ | |||
5 | # require conf/distro/sota.conf.inc | 5 | # require conf/distro/sota.conf.inc |
6 | 6 | ||
7 | DISTRO_FEATURES_append = " sota" | 7 | DISTRO_FEATURES_append = " sota" |
8 | DISTRO_FEATURES_NATIVE_append = " sota" | ||
8 | INHERIT += " sota" | 9 | INHERIT += " sota" |
9 | # Prelinking increases the size of downloads and causes build errors | 10 | # Prelinking increases the size of downloads and causes build errors |
10 | USER_CLASSES_remove = "image-prelink" | 11 | USER_CLASSES_remove = "image-prelink" |
12 | |||
13 | HOSTTOOLS_append = " sync sha256sum" | ||
diff --git a/recipes-bsp/u-boot/u-boot_2016.11.bb b/recipes-bsp/u-boot/u-boot_2016.11.bb index e6e1fcf..acd4bb8 100644 --- a/recipes-bsp/u-boot/u-boot_2016.11.bb +++ b/recipes-bsp/u-boot/u-boot_2016.11.bb | |||
@@ -1,8 +1,17 @@ | |||
1 | require recipes-bsp/u-boot/u-boot.inc | 1 | require recipes-bsp/u-boot/u-boot.inc |
2 | 2 | ||
3 | HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome" | ||
4 | SECTION = "bootloaders" | ||
5 | |||
6 | LICENSE = "GPLv2+" | ||
7 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6" | ||
8 | PE = "1" | ||
9 | |||
3 | DEPENDS += "dtc-native" | 10 | DEPENDS += "dtc-native" |
4 | 11 | ||
5 | SRCREV = "5ea3e51fc481613a8dee8c02848d1b42c81ad892" | 12 | SRCREV = "5ea3e51fc481613a8dee8c02848d1b42c81ad892" |
13 | SRC_URI = "git://git.denx.de/u-boot.git" | ||
14 | S = "${WORKDIR}/git" | ||
6 | 15 | ||
7 | PV = "v2016.11+git${SRCPV}" | 16 | PV = "v2016.11+git${SRCPV}" |
8 | 17 | ||
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb index 8bc580d..6ad9577 100644 --- a/recipes-sota/aktualizr/aktualizr_git.bb +++ b/recipes-sota/aktualizr/aktualizr_git.bb | |||
@@ -22,7 +22,7 @@ SYSTEMD_SERVICE_${PN} = "aktualizr.service" | |||
22 | 22 | ||
23 | inherit cmake systemd | 23 | inherit cmake systemd |
24 | 24 | ||
25 | EXTRA_OECMAKE = "-DWARNING_AS_ERROR=OFF -DCMAKE_BUILD_TYPE=Release -DBUILD_TESTS=OFF -DBUILD_OSTREE=ON -DAKTUALIZR_VERSION=${PV}" | 25 | EXTRA_OECMAKE = "-DWARNING_AS_ERROR=OFF -DCMAKE_BUILD_TYPE=Release -DBUILD_OSTREE=ON -DAKTUALIZR_VERSION=${PV}" |
26 | 26 | ||
27 | export SOTA_PACKED_CREDENTIALS | 27 | export SOTA_PACKED_CREDENTIALS |
28 | 28 | ||
diff --git a/recipes-sota/sota-tools/sota-tools_git.bb b/recipes-sota/sota-tools/sota-tools_git.bb index 2b9d0cb..5403d9a 100644 --- a/recipes-sota/sota-tools/sota-tools_git.bb +++ b/recipes-sota/sota-tools/sota-tools_git.bb | |||
@@ -10,7 +10,7 @@ SRCREV = "216cb84db98e9b0f8c6c1c407f480c5dd0b3cf62" | |||
10 | 10 | ||
11 | inherit cmake | 11 | inherit cmake |
12 | 12 | ||
13 | DEPENDS = "boost glib-2.0 curl" | 13 | DEPENDS = "boost glib-2.0 curl libarchive" |
14 | 14 | ||
15 | BBCLASSEXTEND = "native" | 15 | BBCLASSEXTEND = "native" |
16 | 16 | ||
diff --git a/recipes-support/glib-networking/glib-networking_%.bbappend b/recipes-support/glib-networking/glib-networking_%.bbappend index fccb949..1c4fe19 100644 --- a/recipes-support/glib-networking/glib-networking_%.bbappend +++ b/recipes-support/glib-networking/glib-networking_%.bbappend | |||
@@ -1 +1,6 @@ | |||
1 | BBCLASSEXTEND_append_sota = " native" | 1 | BBCLASSEXTEND_append_sota = " native nativesdk" |
2 | |||
3 | # Hackery to prevent relocatable_native_pcfiles from crashing | ||
4 | do_install_append_class-native () { | ||
5 | rmdir ${D}${libdir}/pkgconfig | ||
6 | } | ||
diff --git a/recipes-support/libsoup/libsoup-2.4_%.bbappend b/recipes-support/libsoup/libsoup-2.4_%.bbappend index ce4df6d..18383f1 100644 --- a/recipes-support/libsoup/libsoup-2.4_%.bbappend +++ b/recipes-support/libsoup/libsoup-2.4_%.bbappend | |||
@@ -1,3 +1,3 @@ | |||
1 | BBCLASSEXTEND_append_sota = " native" | 1 | BBCLASSEXTEND_append_sota = " native nativesdk" |
2 | 2 | ||
3 | DEPENDS_append_class-native = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ' glib-networking-native', ' ', d)}" | 3 | DEPENDS_append_class-native = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ' glib-networking-native', ' ', d)}" |
diff --git a/scripts/lib/wic/plugins/source/otaimage.py b/scripts/lib/wic/plugins/source/otaimage.py index dc507a8..eef0bb4 100644 --- a/scripts/lib/wic/plugins/source/otaimage.py +++ b/scripts/lib/wic/plugins/source/otaimage.py | |||
@@ -15,11 +15,12 @@ | |||
15 | # 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA. | 15 | # 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA. |
16 | # | 16 | # |
17 | 17 | ||
18 | import logging | ||
18 | import os | 19 | import os |
20 | import sys | ||
19 | 21 | ||
20 | from wic import msger | ||
21 | from wic.pluginbase import SourcePlugin | 22 | from wic.pluginbase import SourcePlugin |
22 | from wic.utils.oe.misc import get_bitbake_var | 23 | from wic.utils.misc import get_bitbake_var |
23 | 24 | ||
24 | class OTAImagePlugin(SourcePlugin): | 25 | class OTAImagePlugin(SourcePlugin): |
25 | """ | 26 | """ |
@@ -57,12 +58,12 @@ class OTAImagePlugin(SourcePlugin): | |||
57 | """ | 58 | """ |
58 | bootimg_dir = get_bitbake_var("DEPLOY_DIR_IMAGE") | 59 | bootimg_dir = get_bitbake_var("DEPLOY_DIR_IMAGE") |
59 | if not bootimg_dir: | 60 | if not bootimg_dir: |
60 | msger.error("Couldn't find DEPLOY_DIR_IMAGE, exiting\n") | 61 | logger.error("Couldn't find DEPLOY_DIR_IMAGE, exiting\n") |
61 | 62 | ||
62 | msger.debug('Bootimg dir: %s' % bootimg_dir) | 63 | logger.debug('Bootimg dir: %s' % bootimg_dir) |
63 | 64 | ||
64 | src = bootimg_dir + "/" + get_bitbake_var("IMAGE_LINK_NAME") + ".otaimg" | 65 | src = bootimg_dir + "/" + get_bitbake_var("IMAGE_LINK_NAME") + ".otaimg" |
65 | 66 | ||
66 | msger.debug('Preparing partition using image %s' % (src)) | 67 | logger.debug('Preparing partition using image %s' % (src)) |
67 | part.prepare_rootfs_from_fs_image(cr_workdir, src, "") | 68 | part.prepare_rootfs_from_fs_image(cr_workdir, src, "") |
68 | 69 | ||