diff options
21 files changed, 99 insertions, 65 deletions
diff --git a/classes/image_types_ota.bbclass b/classes/image_types_ota.bbclass index cb71899..8108d51 100644 --- a/classes/image_types_ota.bbclass +++ b/classes/image_types_ota.bbclass | |||
@@ -98,7 +98,11 @@ IMAGE_CMD_otaimg () { | |||
98 | HOME_TMP=`mktemp -d ${WORKDIR}/home-tmp-XXXXX` | 98 | HOME_TMP=`mktemp -d ${WORKDIR}/home-tmp-XXXXX` |
99 | tar --xattrs --xattrs-include='*' -C ${HOME_TMP} -xf ${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.rootfs.ostree.tar.bz2 ./usr/homedirs ./var/sota || true | 99 | tar --xattrs --xattrs-include='*' -C ${HOME_TMP} -xf ${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.rootfs.ostree.tar.bz2 ./usr/homedirs ./var/sota || true |
100 | mv ${HOME_TMP}/var/sota ${PHYS_SYSROOT}/ostree/deploy/${OSTREE_OSNAME}/var/ || true | 100 | mv ${HOME_TMP}/var/sota ${PHYS_SYSROOT}/ostree/deploy/${OSTREE_OSNAME}/var/ || true |
101 | # Create /var/sota if it doesn't exist yet | ||
102 | mkdir -p ${PHYS_SYSROOT}/ostree/deploy/${OSTREE_OSNAME}/var/sota || true | ||
101 | mv ${HOME_TMP}/usr/homedirs/home ${PHYS_SYSROOT}/ || true | 103 | mv ${HOME_TMP}/usr/homedirs/home ${PHYS_SYSROOT}/ || true |
104 | # Ensure that /var/local exists (AGL symlinks /usr/local to /var/local) | ||
105 | install -d ${PHYS_SYSROOT}/ostree/deploy/${OSTREE_OSNAME}/var/local | ||
102 | rm -rf ${HOME_TMP} | 106 | rm -rf ${HOME_TMP} |
103 | 107 | ||
104 | # Calculate image type | 108 | # Calculate image type |
diff --git a/classes/sdcard_image-rpi-ota.bbclass b/classes/sdcard_image-rpi-ota.bbclass index f5c35a2..9022aaf 100644 --- a/classes/sdcard_image-rpi-ota.bbclass +++ b/classes/sdcard_image-rpi-ota.bbclass | |||
@@ -35,6 +35,7 @@ KERNEL_INITRAMFS ?= "" | |||
35 | # Kernel image name | 35 | # Kernel image name |
36 | SDIMG_OTA_KERNELIMAGE_raspberrypi ?= "kernel.img" | 36 | SDIMG_OTA_KERNELIMAGE_raspberrypi ?= "kernel.img" |
37 | SDIMG_OTA_KERNELIMAGE_raspberrypi2 ?= "kernel7.img" | 37 | SDIMG_OTA_KERNELIMAGE_raspberrypi2 ?= "kernel7.img" |
38 | SDIMG_OTA_KERNELIMAGE_raspberrypi3 ?= "kernel7.img" | ||
38 | 39 | ||
39 | # Boot partition volume id | 40 | # Boot partition volume id |
40 | BOOTDD_VOLUME_ID ?= "${MACHINE}" | 41 | BOOTDD_VOLUME_ID ?= "${MACHINE}" |
diff --git a/classes/sota.bbclass b/classes/sota.bbclass index a1a5028..d786b69 100644 --- a/classes/sota.bbclass +++ b/classes/sota.bbclass | |||
@@ -1,32 +1,31 @@ | |||
1 | DISTRO_FEATURES_append = " sota" | 1 | python __anonymous() { |
2 | OVERRIDES .= ":sota" | 2 | if bb.utils.contains('DISTRO_FEATURES', 'sota', True, False, d): |
3 | d.appendVarFlag("do_image_wic", "depends", " %s:do_image_otaimg" % d.getVar("IMAGE_BASENAME", True)) | ||
4 | } | ||
3 | 5 | ||
4 | IMAGE_INSTALL_append = " ostree os-release" | 6 | OVERRIDES .= "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ':sota', '', d)}" |
5 | 7 | ||
6 | # live image for OSTree-enabled systems | 8 | IMAGE_INSTALL_append_sota = " ostree os-release" |
7 | IMAGE_CLASSES += "image_types_ostree image_types_ota" | 9 | IMAGE_CLASSES += " image_types_ostree image_types_ota" |
8 | IMAGE_FSTYPES += "ostreepush otaimg" | 10 | IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', 'sota', 'ostreepush otaimg wic', ' ', d)}" |
9 | 11 | ||
10 | # if don't build wic image unless IMAGE_BOOT_FILES is set. Prevents build from failing | 12 | WKS_FILE_sota ?= "sdimage-sota.wks" |
11 | # on machines that don't support updater yet | ||
12 | IMAGE_FSTYPES += "${@' wic' if (d.getVar("IMAGE_BOOT_FILES", True)) else ''}" | ||
13 | WKS_FILE ?= "sdimage-sota.wks" | ||
14 | do_image_wic[depends] += "${IMAGE_BASENAME}:do_image_otaimg" | ||
15 | 13 | ||
16 | EXTRA_IMAGEDEPENDS += " parted-native mtools-native dosfstools-native" | 14 | EXTRA_IMAGEDEPENDS_append_sota = " parted-native mtools-native dosfstools-native" |
17 | 15 | ||
18 | # Please redefine OSTREE_REPO in order to have a persistent OSTree repo | 16 | # Please redefine OSTREE_REPO in order to have a persistent OSTree repo |
19 | OSTREE_REPO ?= "${DEPLOY_DIR_IMAGE}/ostree_repo" | 17 | OSTREE_REPO ?= "${DEPLOY_DIR_IMAGE}/ostree_repo" |
20 | OSTREE_BRANCHNAME ?= "ota-${MACHINE}" | 18 | # For UPTANE operation, OSTREE_BRANCHNAME must start with "${MACHINE}-" |
19 | OSTREE_BRANCHNAME ?= "${MACHINE}-ota" | ||
21 | OSTREE_OSNAME ?= "poky" | 20 | OSTREE_OSNAME ?= "poky" |
22 | OSTREE_INITRAMFS_IMAGE ?= "initramfs-ostree-image" | 21 | OSTREE_INITRAMFS_IMAGE ?= "initramfs-ostree-image" |
23 | 22 | ||
24 | SOTA_MACHINE ?= "none" | 23 | SOTA_MACHINE ??="none" |
25 | SOTA_MACHINE_raspberrypi = "raspberrypi" | 24 | SOTA_MACHINE_raspberrypi2 ?= "raspberrypi" |
26 | SOTA_MACHINE_raspberrypi3 = "raspberrypi" | 25 | SOTA_MACHINE_raspberrypi3 ?= "raspberrypi" |
27 | SOTA_MACHINE_porter = "porter" | 26 | SOTA_MACHINE_porter ?= "porter" |
28 | SOTA_MACHINE_intel-corei7-64 = "minnowboard" | 27 | SOTA_MACHINE_intel-corei7-64 ?= "minnowboard" |
29 | SOTA_MACHINE_qemux86-64 = "qemux86-64" | 28 | SOTA_MACHINE_qemux86-64 ?= "qemux86-64" |
30 | SOTA_MACHINE_qemux86-64 = "qemux86-64" | 29 | SOTA_MACHINE_am335x-evm ?= "am335x-evm-wifi" |
31 | SOTA_MACHINE_am335x-evm = "am335x-evm-wifi" | 30 | |
32 | inherit sota_${SOTA_MACHINE} | 31 | inherit sota_${SOTA_MACHINE} |
diff --git a/classes/sota_minnowboard.bbclass b/classes/sota_minnowboard.bbclass index 970bd6a..8417348 100644 --- a/classes/sota_minnowboard.bbclass +++ b/classes/sota_minnowboard.bbclass | |||
@@ -1,7 +1,7 @@ | |||
1 | OSTREE_BOOTLOADER ?= "grub" | 1 | OSTREE_BOOTLOADER ?= "grub" |
2 | EFI_PROVIDER = "grub-efi" | 2 | EFI_PROVIDER_sota = "grub-efi" |
3 | 3 | ||
4 | WKS_FILE = "efiimage-sota.wks" | 4 | WKS_FILE_sota = "efiimage-sota.wks" |
5 | IMAGE_BOOT_FILES = "" | 5 | IMAGE_BOOT_FILES_sota = "" |
6 | 6 | ||
7 | OSTREE_KERNEL_ARGS ?= "ramdisk_size=16384 rw rootfstype=ext4 rootwait rootdelay=2 console=ttyS0,115200 console=tty0" | 7 | OSTREE_KERNEL_ARGS ?= "ramdisk_size=16384 rw rootfstype=ext4 rootwait rootdelay=2 console=ttyS0,115200 console=tty0" |
diff --git a/classes/sota_minnowboard_uboot.inc b/classes/sota_minnowboard_uboot.inc index 5097e9d..85d6a60 100644 --- a/classes/sota_minnowboard_uboot.inc +++ b/classes/sota_minnowboard_uboot.inc | |||
@@ -1,8 +1,8 @@ | |||
1 | PREFERRED_PROVIDER_virtual/bootloader = "u-boot-ota" | 1 | PREFERRED_PROVIDER_virtual/bootloader_sota ?= "u-boot-ota" |
2 | UBOOT_MACHINE = "minnowmax_defconfig" | 2 | UBOOT_MACHINE_sota ?= "minnowmax_defconfig" |
3 | 3 | ||
4 | EXTRA_IMAGEDEPENDS_append = " minnowboard-bootfiles" | 4 | EXTRA_IMAGEDEPENDS_append_sota = " minnowboard-bootfiles" |
5 | IMAGE_BOOT_FILES = "minnowboard-bootfiles/*" | 5 | IMAGE_BOOT_FILES_sota ?= "minnowboard-bootfiles/*" |
6 | 6 | ||
7 | OSTREE_KERNEL_ARGS ?= "ramdisk_size=16384 rw rootfstype=ext4 rootwait rootdelay=2 ostree_root=/dev/hda console=ttyS0,115200 console=tty0" | 7 | OSTREE_KERNEL_ARGS ?= "ramdisk_size=16384 rw rootfstype=ext4 rootwait rootdelay=2 ostree_root=/dev/hda console=ttyS0,115200 console=tty0" |
8 | 8 | ||
diff --git a/classes/sota_none.bbclass b/classes/sota_none.bbclass index dc72a07..86eaf0b 100644 --- a/classes/sota_none.bbclass +++ b/classes/sota_none.bbclass | |||
@@ -1 +1,4 @@ | |||
1 | # null machine it's here to make bitbake happy when SOTA_MACHINE is undefined | 1 | # null machine it's here to make bitbake happy when SOTA_MACHINE is undefined |
2 | python __anonymous() { | ||
3 | bb.warn("SOTA functionality is not yet supported for your machine") | ||
4 | } | ||
diff --git a/classes/sota_qemux86-64.bbclass b/classes/sota_qemux86-64.bbclass index 533c11c..5ec4f69 100644 --- a/classes/sota_qemux86-64.bbclass +++ b/classes/sota_qemux86-64.bbclass | |||
@@ -1,6 +1,8 @@ | |||
1 | # See https://advancedtelematic.atlassian.net/browse/PRO-2693 | 1 | # See https://advancedtelematic.atlassian.net/browse/PRO-2693 |
2 | PREFERRED_VERSION_linux-yocto_qemux86-64_sota = "4.4%" | 2 | PREFERRED_VERSION_linux-yocto_qemux86-64_sota = "4.4%" |
3 | 3 | ||
4 | IMAGE_FSTYPES_remove = "wic" | ||
5 | |||
4 | # U-Boot support for SOTA | 6 | # U-Boot support for SOTA |
5 | PREFERRED_PROVIDER_virtual/bootloader_sota = "u-boot-ota" | 7 | PREFERRED_PROVIDER_virtual/bootloader_sota = "u-boot-ota" |
6 | UBOOT_MACHINE_sota = "qemu-x86_defconfig" | 8 | UBOOT_MACHINE_sota = "qemu-x86_defconfig" |
diff --git a/classes/sota_raspberrypi.bbclass b/classes/sota_raspberrypi.bbclass index 1d23d1f..b6cf639 100644 --- a/classes/sota_raspberrypi.bbclass +++ b/classes/sota_raspberrypi.bbclass | |||
@@ -1,8 +1,7 @@ | |||
1 | IMAGE_CLASSES += "${@bb.utils.contains('DISTRO_FEATURES', 'sota', 'image_types_uboot sdcard_image-rpi-ota', '', d)}" | 1 | IMAGE_CLASSES += "${@bb.utils.contains('DISTRO_FEATURES', 'sota', 'image_types_uboot sdcard_image-rpi-ota', '', d)}" |
2 | IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', 'sota', 'rpi-sdimg-ota', 'rpi-sdimg', d)}" | 2 | IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', 'sota', 'rpi-sdimg-ota', 'rpi-sdimg', d)}" |
3 | 3 | ||
4 | ### both rpi-sdimg and rpi-sdimg-ota broken | 4 | IMAGE_FSTYPES_remove = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', 'wic rpi-sdimg', '', d)}" |
5 | IMAGE_FSTYPES += "ext4.xz ext4.bmap tar.xz" | ||
6 | 5 | ||
7 | KERNEL_IMAGETYPE_sota = "uImage" | 6 | KERNEL_IMAGETYPE_sota = "uImage" |
8 | PREFERRED_PROVIDER_virtual/bootloader_sota ?= "u-boot" | 7 | PREFERRED_PROVIDER_virtual/bootloader_sota ?= "u-boot" |
diff --git a/conf/distro/poky-sota-systemd.conf b/conf/distro/poky-sota-systemd.conf index 3a50d66..726e9f9 100644 --- a/conf/distro/poky-sota-systemd.conf +++ b/conf/distro/poky-sota-systemd.conf | |||
@@ -1,5 +1,7 @@ | |||
1 | require conf/distro/poky.conf | 1 | require conf/distro/poky.conf |
2 | 2 | ||
3 | require conf/distro/sota.conf.inc | ||
4 | |||
3 | DISTRO = "poky-sota" | 5 | DISTRO = "poky-sota" |
4 | DISTRO_NAME = "OTA-enabled Linux" | 6 | DISTRO_NAME = "OTA-enabled Linux" |
5 | DISTRO_VERSION = "1.0" | 7 | DISTRO_VERSION = "1.0" |
@@ -8,8 +10,4 @@ DISTRO_CODENAME = "sota" | |||
8 | DISTRO_FEATURES_append = " systemd" | 10 | DISTRO_FEATURES_append = " systemd" |
9 | VIRTUAL-RUNTIME_init_manager = "systemd" | 11 | VIRTUAL-RUNTIME_init_manager = "systemd" |
10 | 12 | ||
11 | INHERIT += " sota" | ||
12 | IMAGE_INSTALL_append = " connman connman-client rvi-sota-client" | 13 | IMAGE_INSTALL_append = " connman connman-client rvi-sota-client" |
13 | |||
14 | # Prelinking increases the size of downloads and causes build errors | ||
15 | USER_CLASSES_remove = "image-prelink" | ||
diff --git a/conf/distro/poky-sota.conf b/conf/distro/poky-sota.conf index d6d2a1e..2bbc62b 100644 --- a/conf/distro/poky-sota.conf +++ b/conf/distro/poky-sota.conf | |||
@@ -1,12 +1,9 @@ | |||
1 | require conf/distro/poky.conf | 1 | require conf/distro/poky.conf |
2 | require conf/distro/sota.conf.inc | ||
2 | 3 | ||
3 | DISTRO = "poky-sota" | 4 | DISTRO = "poky-sota" |
4 | DISTRO_NAME = "OTA-enabled Linux" | 5 | DISTRO_NAME = "OTA-enabled Linux" |
5 | DISTRO_VERSION = "1.0" | 6 | DISTRO_VERSION = "1.0" |
6 | DISTRO_CODENAME = "sota" | 7 | DISTRO_CODENAME = "sota" |
7 | 8 | ||
8 | INHERIT += " sota" | ||
9 | IMAGE_INSTALL_append = " connman connman-client" | 9 | IMAGE_INSTALL_append = " connman connman-client" |
10 | |||
11 | # Prelinking increases the size of downloads and causes build errors | ||
12 | USER_CLASSES_remove = "image-prelink" | ||
diff --git a/conf/distro/sota.conf.inc b/conf/distro/sota.conf.inc new file mode 100644 index 0000000..fddd1d2 --- /dev/null +++ b/conf/distro/sota.conf.inc | |||
@@ -0,0 +1,11 @@ | |||
1 | # Common settings to enable SOTA | ||
2 | # This can be pulled into a custom distribution, or included in | ||
3 | # local.conf directly with: | ||
4 | # | ||
5 | # require conf/distro/sota.conf.inc | ||
6 | |||
7 | DISTRO_FEATURES_append = " sota" | ||
8 | INHERIT += " sota" | ||
9 | IMAGE_INSTALL_append = " aktualizr" | ||
10 | # Prelinking increases the size of downloads and causes build errors | ||
11 | USER_CLASSES_remove = "image-prelink" | ||
diff --git a/conf/include/bblayers/sota_porter.inc b/conf/include/bblayers/sota_porter.inc index a0888d5..6964ef0 100644 --- a/conf/include/bblayers/sota_porter.inc +++ b/conf/include/bblayers/sota_porter.inc | |||
@@ -1,2 +1,2 @@ | |||
1 | 1 | ||
2 | BBLAYERS += " ${METADIR}/meta-updater-porter ${METADIR}/meta-renesas " | 2 | BBLAYERS += " ${METADIR}/meta-renesas ${METADIR}/meta-renesas/meta-rcar-gen2 ${METADIR}/meta-openembedded/meta-multimedia ${METADIR}/meta-updater-porter" |
diff --git a/recipes-bsp/grub/grub-efi_%.bbappend b/recipes-bsp/grub/grub-efi_%.bbappend index 545e806..bebb006 100644 --- a/recipes-bsp/grub/grub-efi_%.bbappend +++ b/recipes-bsp/grub/grub-efi_%.bbappend | |||
@@ -1,2 +1,2 @@ | |||
1 | 1 | ||
2 | GRUB_BUILDIN += "configfile" | 2 | GRUB_BUILDIN_append_sota = " configfile" |
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb index 12a3eed..fa71af8 100644 --- a/recipes-sota/aktualizr/aktualizr_git.bb +++ b/recipes-sota/aktualizr/aktualizr_git.bb | |||
@@ -2,24 +2,38 @@ SUMMARY = "Aktualizr SOTA Client" | |||
2 | DESCRIPTION = "SOTA Client application written in C++" | 2 | DESCRIPTION = "SOTA Client application written in C++" |
3 | HOMEPAGE = "https://github.com/advancedtelematic/aktualizr" | 3 | HOMEPAGE = "https://github.com/advancedtelematic/aktualizr" |
4 | SECTION = "base" | 4 | SECTION = "base" |
5 | |||
6 | LICENSE = "MPL-2.0" | 5 | LICENSE = "MPL-2.0" |
7 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=9741c346eef56131163e13b9db1241b3" | 6 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=9741c346eef56131163e13b9db1241b3" |
7 | DEPENDS = "boost curl openssl jansson libsodium ostree" | ||
8 | SRCREV = "4e9344ae375a444f02b964dca52fe808010d17df" | ||
9 | PV = "1.0+git${SRCPV}" | ||
8 | 10 | ||
9 | inherit cmake systemd | 11 | SRC_URI = " \ |
12 | git://github.com/advancedtelematic/aktualizr \ | ||
13 | file://aktualizr-manual-provision.service \ | ||
14 | " | ||
10 | 15 | ||
11 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
12 | PV = "1.0+git${SRCPV}" | 17 | SYSTEMD_SERVICE_${PN} = "aktualizr.service" |
13 | 18 | ||
14 | SRCREV = "f2275e9938f5c942c9e51a3966b1ad91acd65367" | 19 | inherit cmake systemd |
15 | 20 | ||
16 | SRC_URI = "git://github.com/advancedtelematic/aktualizr" | 21 | EXTRA_OECMAKE = "-DWARNING_AS_ERROR=OFF -DCMAKE_BUILD_TYPE=Release -DBUILD_TESTS=OFF -DBUILD_OSTREE=ON" |
17 | 22 | ||
18 | DEPENDS = "boost curl openssl jansson" | 23 | export SOTA_AUTOPROVISION_CREDENTIALS |
19 | RDEPENDS = "" | ||
20 | 24 | ||
21 | EXTRA_OECMAKE = "-DWARNING_AS_ERROR=OFF -DCMAKE_BUILD_TYPE=Release -DBUILD_TESTS=OFF" | 25 | do_install_append() { |
26 | if [ -n "$SOTA_AUTOPROVISION_CREDENTIALS" ]; then | ||
27 | bbwarn "Aktualizr recipe currently lacks support for SOTA_AUTOPROVISION_CREDENTIALS. No systemd service will be created" | ||
28 | else | ||
29 | install -d ${D}/${systemd_unitdir}/system | ||
30 | install -m 0644 ${WORKDIR}/aktualizr-manual-provision.service ${D}/${systemd_unitdir}/system/aktualizr.service | ||
31 | fi | ||
32 | } | ||
33 | |||
34 | RDEPENDS = "" | ||
22 | 35 | ||
23 | FILES_${PN} = " \ | 36 | FILES_${PN} = " \ |
24 | ${bindir}/aktualizr \ | 37 | ${bindir}/aktualizr \ |
25 | " | 38 | ${systemd_unitdir}/system/aktualizr.service \ |
39 | " | ||
diff --git a/recipes-sota/aktualizr/files/aktualizr-manual-provision.service b/recipes-sota/aktualizr/files/aktualizr-manual-provision.service new file mode 100644 index 0000000..a70f2f9 --- /dev/null +++ b/recipes-sota/aktualizr/files/aktualizr-manual-provision.service | |||
@@ -0,0 +1,13 @@ | |||
1 | [Unit] | ||
2 | Description=Aktualizr SOTA Client | ||
3 | Wants=network-online.target | ||
4 | After=network.target network-online.target | ||
5 | Requires=network-online.target | ||
6 | |||
7 | [Service] | ||
8 | RestartSec=10 | ||
9 | Restart=always | ||
10 | ExecStart=/usr/bin/aktualizr --config /sysroot/boot/sota.toml --loglevel 2 | ||
11 | |||
12 | [Install] | ||
13 | WantedBy=multi-user.target | ||
diff --git a/recipes-support/fuse/fuse_%.bbappend b/recipes-support/fuse/fuse_%.bbappend index 4f23349..85bdf50 100644 --- a/recipes-support/fuse/fuse_%.bbappend +++ b/recipes-support/fuse/fuse_%.bbappend | |||
@@ -1,3 +1,3 @@ | |||
1 | BBCLASSEXTEND = "native" | 1 | BBCLASSEXTEND_append_sota = " native" |
2 | 2 | ||
3 | PACKAGES_append_class-native = "fuse-utils-dbg-native fuse-utils-native libulockmgr-native libulockmgr-dev-native libulockmgr-dbg-native" | 3 | PACKAGES_append_class-native_sota = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ' fuse-utils-dbg-native fuse-utils-native libulockmgr-native libulockmgr-dev-native libulockmgr-dbg-native', ' ', d)}" |
diff --git a/recipes-support/glib-networking/glib-networking_%.bbappend b/recipes-support/glib-networking/glib-networking_%.bbappend index d3267ac..fccb949 100644 --- a/recipes-support/glib-networking/glib-networking_%.bbappend +++ b/recipes-support/glib-networking/glib-networking_%.bbappend | |||
@@ -1 +1 @@ | |||
BBCLASSEXTEND = "native" | BBCLASSEXTEND_append_sota = " native" | ||
diff --git a/recipes-support/gpgme/gpgme_%.bbappend b/recipes-support/gpgme/gpgme_%.bbappend index d3267ac..27f258e 100644 --- a/recipes-support/gpgme/gpgme_%.bbappend +++ b/recipes-support/gpgme/gpgme_%.bbappend | |||
@@ -1 +1 @@ | |||
BBCLASSEXTEND = "native" | BBCLASSEXTEND_append_sota = "native" | ||
diff --git a/recipes-support/libsoup/libsoup-2.4_%.bbappend b/recipes-support/libsoup/libsoup-2.4_%.bbappend index ed24273..ce4df6d 100644 --- a/recipes-support/libsoup/libsoup-2.4_%.bbappend +++ b/recipes-support/libsoup/libsoup-2.4_%.bbappend | |||
@@ -1,3 +1,3 @@ | |||
1 | BBCLASSEXTEND = "native" | 1 | BBCLASSEXTEND_append_sota = " native" |
2 | 2 | ||
3 | DEPENDS_append_class-native = " glib-networking-native" | 3 | DEPENDS_append_class-native = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ' glib-networking-native', ' ', d)}" |
diff --git a/recipes-support/libssh2/libssh2_%.bbappend b/recipes-support/libssh2/libssh2_%.bbappend index ce4807e..bebaf84 100644 --- a/recipes-support/libssh2/libssh2_%.bbappend +++ b/recipes-support/libssh2/libssh2_%.bbappend | |||
@@ -1,2 +1,2 @@ | |||
1 | # meta-oe/recipes-support/libssh2 | 1 | # meta-oe/recipes-support/libssh2 |
2 | BBCLASSEXTEND = "native" | 2 | BBCLASSEXTEND_append_sota = " native" |
diff --git a/recipes-support/util-linux/util-linux_%.bbappend b/recipes-support/util-linux/util-linux_%.bbappend index bd3f686..d653bb2 100644 --- a/recipes-support/util-linux/util-linux_%.bbappend +++ b/recipes-support/util-linux/util-linux_%.bbappend | |||
@@ -1,10 +1,3 @@ | |||
1 | PACKAGES_append_class-native = "util-linux-agetty-native util-linux-fdisk-native util-linux-cfdisk-native util-linux-sfdisk-native \ | 1 | PACKAGES_append_class-native = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ' util-linux-agetty-native util-linux-fdisk-native util-linux-cfdisk-native util-linux-sfdisk-native util-linux-swaponoff-native util-linux-losetup-native util-linux-umount-native util-linux-mount-native util-linux-readprofile-native util-linux-uuidd-native util-linux-uuidgen-native util-linux-lscpu-native util-linux-fsck-native util-linux-blkid util-linux-mkfs-native util-linux-mcookie-native util-linux-reset-native util-linux-mkfs.cramfs-native util-linux-fsck.cramfs-native util-linux-fstrim-native util-linux-partx-native ${PN}-bash-completion-native util-linux-hwclock util-linux-findfs-native util-linux-getopt-native util-linux-sulogin-native', ' ', d)}" |
2 | util-linux-swaponoff-native util-linux-losetup-native util-linux-umount-native \ | ||
3 | util-linux-mount-native util-linux-readprofile-native util-linux-uuidd-native \ | ||
4 | util-linux-uuidgen-native util-linux-lscpu-native util-linux-fsck-native util-linux-blkid \ | ||
5 | util-linux-mkfs-native util-linux-mcookie-native util-linux-reset-native \ | ||
6 | util-linux-mkfs.cramfs-native util-linux-fsck.cramfs-native util-linux-fstrim-native \ | ||
7 | util-linux-partx-native ${PN}-bash-completion-native util-linux-hwclock \ | ||
8 | util-linux-findfs-native util-linux-getopt-native util-linux-sulogin-native \ | ||
9 | ${@bb.utils.contains('PACKAGECONFIG', 'pylibmount', 'util-linux-pylibmount-native', '', d)}" | ||
10 | 2 | ||
3 | PACKAGES_append_class-native = "${@' util-linux-pylibmount-native' if bb.utils.contains('DISTRO_FEATURES', 'sota', True, False, d) and bb.utils.contains('PACKAGECONFIG', 'pylibmount', True, False, d) else ' '}" | ||