diff options
-rw-r--r-- | classes/image_types_ostree.bbclass | 8 | ||||
-rw-r--r-- | classes/image_types_ota.bbclass | 4 | ||||
-rw-r--r-- | classes/sota.bbclass | 4 | ||||
-rw-r--r-- | recipes-core/images/initramfs-ostree-image.bb | 3 |
4 files changed, 7 insertions, 12 deletions
diff --git a/classes/image_types_ostree.bbclass b/classes/image_types_ostree.bbclass index 5ebed81..904db96 100644 --- a/classes/image_types_ostree.bbclass +++ b/classes/image_types_ostree.bbclass | |||
@@ -1,7 +1,5 @@ | |||
1 | # OSTree deployment | 1 | # OSTree deployment |
2 | 2 | ||
3 | inherit image | ||
4 | |||
5 | do_image_ostree[depends] += "ostree-native:do_populate_sysroot \ | 3 | do_image_ostree[depends] += "ostree-native:do_populate_sysroot \ |
6 | openssl-native:do_populate_sysroot \ | 4 | openssl-native:do_populate_sysroot \ |
7 | coreutils-native:do_populate_sysroot \ | 5 | coreutils-native:do_populate_sysroot \ |
@@ -12,14 +10,12 @@ do_image_ostree[depends] += "ostree-native:do_populate_sysroot \ | |||
12 | export OSTREE_REPO | 10 | export OSTREE_REPO |
13 | export OSTREE_BRANCHNAME | 11 | export OSTREE_BRANCHNAME |
14 | 12 | ||
13 | RAMDISK_EXT ?= ".${INITRAMFS_FSTYPES}" | ||
15 | export GARAGE_TARGET_NAME | 14 | export GARAGE_TARGET_NAME |
16 | 15 | ||
17 | RAMDISK_EXT ?= ".ext4.gz" | ||
18 | RAMDISK_EXT_arm ?= ".ext4.gz.u-boot" | ||
19 | |||
20 | OSTREE_KERNEL ??= "${KERNEL_IMAGETYPE}" | 16 | OSTREE_KERNEL ??= "${KERNEL_IMAGETYPE}" |
21 | 17 | ||
22 | export SYSTEMD_USED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', '', d)}" | 18 | export SYSTEMD_USED = "${@oe.utils.ifelse(d.getVar('VIRTUAL-RUNTIME_init_manager', True) == 'systemd', 'true', '')}" |
23 | 19 | ||
24 | IMAGE_CMD_ostree () { | 20 | IMAGE_CMD_ostree () { |
25 | if [ -z "$OSTREE_REPO" ]; then | 21 | if [ -z "$OSTREE_REPO" ]; then |
diff --git a/classes/image_types_ota.bbclass b/classes/image_types_ota.bbclass index e753e0e..84095a6 100644 --- a/classes/image_types_ota.bbclass +++ b/classes/image_types_ota.bbclass | |||
@@ -7,8 +7,6 @@ | |||
7 | # boot scripts, kernel and initramfs images | 7 | # boot scripts, kernel and initramfs images |
8 | # | 8 | # |
9 | 9 | ||
10 | inherit image | ||
11 | |||
12 | OSTREE_BOOTLOADER ??= 'u-boot' | 10 | OSTREE_BOOTLOADER ??= 'u-boot' |
13 | 11 | ||
14 | do_image_otaimg[depends] += "e2fsprogs-native:do_populate_sysroot \ | 12 | do_image_otaimg[depends] += "e2fsprogs-native:do_populate_sysroot \ |
@@ -32,7 +30,7 @@ calculate_size () { | |||
32 | fi | 30 | fi |
33 | 31 | ||
34 | if [ "$SIZE" -lt "$MIN" ]; then | 32 | if [ "$SIZE" -lt "$MIN" ]; then |
35 | $SIZE=$MIN | 33 | SIZE=$MIN |
36 | fi | 34 | fi |
37 | 35 | ||
38 | SIZE=`expr $SIZE \+ $EXTRA` | 36 | SIZE=`expr $SIZE \+ $EXTRA` |
diff --git a/classes/sota.bbclass b/classes/sota.bbclass index bbb9ac9..2a12e8f 100644 --- a/classes/sota.bbclass +++ b/classes/sota.bbclass | |||
@@ -20,13 +20,15 @@ WKS_FILE_sota ?= "sdimage-sota.wks" | |||
20 | 20 | ||
21 | EXTRA_IMAGEDEPENDS_append_sota = " parted-native mtools-native dosfstools-native" | 21 | EXTRA_IMAGEDEPENDS_append_sota = " parted-native mtools-native dosfstools-native" |
22 | 22 | ||
23 | INITRAMFS_FSTYPES = "${@oe.utils.ifelse(d.getVar('OSTREE_BOOTLOADER', True) == 'u-boot', 'ext4.gz.u-boot', 'ext4.gz')}" | ||
24 | |||
23 | # Please redefine OSTREE_REPO in order to have a persistent OSTree repo | 25 | # Please redefine OSTREE_REPO in order to have a persistent OSTree repo |
24 | OSTREE_REPO ?= "${DEPLOY_DIR_IMAGE}/ostree_repo" | 26 | OSTREE_REPO ?= "${DEPLOY_DIR_IMAGE}/ostree_repo" |
25 | # For UPTANE operation, OSTREE_BRANCHNAME must start with "${MACHINE}-" | 27 | # For UPTANE operation, OSTREE_BRANCHNAME must start with "${MACHINE}-" |
26 | OSTREE_BRANCHNAME ?= "${MACHINE}" | 28 | OSTREE_BRANCHNAME ?= "${MACHINE}" |
27 | OSTREE_OSNAME ?= "poky" | 29 | OSTREE_OSNAME ?= "poky" |
28 | OSTREE_INITRAMFS_IMAGE ?= "initramfs-ostree-image" | 30 | OSTREE_INITRAMFS_IMAGE ?= "initramfs-ostree-image" |
29 | 31 | OSTREE_BOOTLOADER ??= 'u-boot' | |
30 | 32 | ||
31 | GARAGE_SIGN_REPO ?= "${DEPLOY_DIR_IMAGE}/garage_sign_repo" | 33 | GARAGE_SIGN_REPO ?= "${DEPLOY_DIR_IMAGE}/garage_sign_repo" |
32 | GARAGE_SIGN_KEYNAME ?= "garage-key" | 34 | GARAGE_SIGN_KEYNAME ?= "garage-key" |
diff --git a/recipes-core/images/initramfs-ostree-image.bb b/recipes-core/images/initramfs-ostree-image.bb index 4ab9da8..e77499e 100644 --- a/recipes-core/images/initramfs-ostree-image.bb +++ b/recipes-core/images/initramfs-ostree-image.bb | |||
@@ -13,8 +13,7 @@ IMAGE_LINGUAS = "" | |||
13 | 13 | ||
14 | LICENSE = "MIT" | 14 | LICENSE = "MIT" |
15 | 15 | ||
16 | IMAGE_FSTYPES = "ext4.gz" | 16 | IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}" |
17 | IMAGE_FSTYPES_append_arm = " ext4.gz.u-boot" | ||
18 | 17 | ||
19 | inherit core-image | 18 | inherit core-image |
20 | 19 | ||