summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/sota.bbclass2
-rw-r--r--conf/distro/poky-sota-systemd.conf2
-rw-r--r--conf/distro/sota.conf.inc2
-rw-r--r--recipes-sota/rvi-sota-client/rvi-sota-client_git.bb4
4 files changed, 5 insertions, 5 deletions
diff --git a/classes/sota.bbclass b/classes/sota.bbclass
index d786b69..2761111 100644
--- a/classes/sota.bbclass
+++ b/classes/sota.bbclass
@@ -5,7 +5,7 @@ python __anonymous() {
5 5
6OVERRIDES .= "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ':sota', '', d)}" 6OVERRIDES .= "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ':sota', '', d)}"
7 7
8IMAGE_INSTALL_append_sota = " ostree os-release" 8IMAGE_INSTALL_append_sota = " ostree os-release ${SOTA_CLIENT}"
9IMAGE_CLASSES += " image_types_ostree image_types_ota" 9IMAGE_CLASSES += " image_types_ostree image_types_ota"
10IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', 'sota', 'ostreepush otaimg wic', ' ', d)}" 10IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', 'sota', 'ostreepush otaimg wic', ' ', d)}"
11 11
diff --git a/conf/distro/poky-sota-systemd.conf b/conf/distro/poky-sota-systemd.conf
index 726e9f9..7d008a9 100644
--- a/conf/distro/poky-sota-systemd.conf
+++ b/conf/distro/poky-sota-systemd.conf
@@ -10,4 +10,4 @@ DISTRO_CODENAME = "sota"
10DISTRO_FEATURES_append = " systemd" 10DISTRO_FEATURES_append = " systemd"
11VIRTUAL-RUNTIME_init_manager = "systemd" 11VIRTUAL-RUNTIME_init_manager = "systemd"
12 12
13IMAGE_INSTALL_append = " connman connman-client rvi-sota-client" 13IMAGE_INSTALL_append = " connman connman-client"
diff --git a/conf/distro/sota.conf.inc b/conf/distro/sota.conf.inc
index fddd1d2..07844e3 100644
--- a/conf/distro/sota.conf.inc
+++ b/conf/distro/sota.conf.inc
@@ -6,6 +6,6 @@
6 6
7DISTRO_FEATURES_append = " sota" 7DISTRO_FEATURES_append = " sota"
8INHERIT += " sota" 8INHERIT += " sota"
9IMAGE_INSTALL_append = " aktualizr" 9SOTA_CLIENT ?= "aktualizr"
10# Prelinking increases the size of downloads and causes build errors 10# Prelinking increases the size of downloads and causes build errors
11USER_CLASSES_remove = "image-prelink" 11USER_CLASSES_remove = "image-prelink"
diff --git a/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb b/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
index 52edd26..83cd9ab 100644
--- a/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
+++ b/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
@@ -11,13 +11,13 @@ S = "${WORKDIR}/git"
11# When changing this, don't forget to: 11# When changing this, don't forget to:
12# 1) Update PV 12# 1) Update PV
13# 2) Check that Cargo.lock hasn't changed with git diff old..new Cargo.lock 13# 2) Check that Cargo.lock hasn't changed with git diff old..new Cargo.lock
14SRCREV = "0d092c218c823fe38e59e7ecb4589c3770dc6448" 14SRCREV = "9c79909cd18d50cd7a26c7621bdcc0c254b6e948"
15 15
16# Generate with: 16# Generate with:
17# git describe --tags | cut -b2- 17# git describe --tags | cut -b2-
18# or from the rvi_sota_client repo: 18# or from the rvi_sota_client repo:
19# make package-version 19# make package-version
20PV = "0.2.32-186-g313ba1a" 20PV = "0.2.32-190-g9c79909"
21 21
22BBCLASSEXTEND = "native" 22BBCLASSEXTEND = "native"
23 23