diff options
-rw-r--r-- | classes/sota.bbclass | 3 | ||||
-rw-r--r-- | conf/distro/poky-sota-systemd.conf | 2 | ||||
-rw-r--r-- | conf/distro/sota.conf.inc | 1 | ||||
-rw-r--r-- | recipes-sota/rvi-sota-client/rvi-sota-client_git.bb | 4 |
4 files changed, 5 insertions, 5 deletions
diff --git a/classes/sota.bbclass b/classes/sota.bbclass index d786b69..a96429c 100644 --- a/classes/sota.bbclass +++ b/classes/sota.bbclass | |||
@@ -5,7 +5,8 @@ python __anonymous() { | |||
5 | 5 | ||
6 | OVERRIDES .= "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ':sota', '', d)}" | 6 | OVERRIDES .= "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ':sota', '', d)}" |
7 | 7 | ||
8 | IMAGE_INSTALL_append_sota = " ostree os-release" | 8 | SOTA_CLIENT ??= "aktualizr" |
9 | IMAGE_INSTALL_append_sota = " ostree os-release ${SOTA_CLIENT}" | ||
9 | IMAGE_CLASSES += " image_types_ostree image_types_ota" | 10 | IMAGE_CLASSES += " image_types_ostree image_types_ota" |
10 | IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', 'sota', 'ostreepush otaimg wic', ' ', d)}" | 11 | IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', 'sota', 'ostreepush otaimg wic', ' ', d)}" |
11 | 12 | ||
diff --git a/conf/distro/poky-sota-systemd.conf b/conf/distro/poky-sota-systemd.conf index 726e9f9..7d008a9 100644 --- a/conf/distro/poky-sota-systemd.conf +++ b/conf/distro/poky-sota-systemd.conf | |||
@@ -10,4 +10,4 @@ DISTRO_CODENAME = "sota" | |||
10 | DISTRO_FEATURES_append = " systemd" | 10 | DISTRO_FEATURES_append = " systemd" |
11 | VIRTUAL-RUNTIME_init_manager = "systemd" | 11 | VIRTUAL-RUNTIME_init_manager = "systemd" |
12 | 12 | ||
13 | IMAGE_INSTALL_append = " connman connman-client rvi-sota-client" | 13 | IMAGE_INSTALL_append = " connman connman-client" |
diff --git a/conf/distro/sota.conf.inc b/conf/distro/sota.conf.inc index fddd1d2..7438424 100644 --- a/conf/distro/sota.conf.inc +++ b/conf/distro/sota.conf.inc | |||
@@ -6,6 +6,5 @@ | |||
6 | 6 | ||
7 | DISTRO_FEATURES_append = " sota" | 7 | DISTRO_FEATURES_append = " sota" |
8 | INHERIT += " sota" | 8 | INHERIT += " sota" |
9 | IMAGE_INSTALL_append = " aktualizr" | ||
10 | # Prelinking increases the size of downloads and causes build errors | 9 | # Prelinking increases the size of downloads and causes build errors |
11 | USER_CLASSES_remove = "image-prelink" | 10 | USER_CLASSES_remove = "image-prelink" |
diff --git a/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb b/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb index 87fa752..5a08670 100644 --- a/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb +++ b/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb | |||
@@ -11,13 +11,13 @@ S = "${WORKDIR}/git" | |||
11 | # When changing this, don't forget to: | 11 | # When changing this, don't forget to: |
12 | # 1) Update PV | 12 | # 1) Update PV |
13 | # 2) Check that Cargo.lock hasn't changed with git diff old..new Cargo.lock | 13 | # 2) Check that Cargo.lock hasn't changed with git diff old..new Cargo.lock |
14 | SRCREV = "0d092c218c823fe38e59e7ecb4589c3770dc6448" | 14 | SRCREV = "d64be93cc5da9b5399c7d381fd7a0a6f1b13bc3c" |
15 | 15 | ||
16 | # Generate with: | 16 | # Generate with: |
17 | # git describe --tags | cut -b2- | 17 | # git describe --tags | cut -b2- |
18 | # or from the rvi_sota_client repo: | 18 | # or from the rvi_sota_client repo: |
19 | # make package-version | 19 | # make package-version |
20 | PV = "0.2.32-186-g313ba1a" | 20 | PV = "0.2.32-192-gd64be93" |
21 | 21 | ||
22 | BBCLASSEXTEND = "native" | 22 | BBCLASSEXTEND = "native" |
23 | 23 | ||