diff options
-rw-r--r-- | lib/oeqa/selftest/garage_push.py | 39 | ||||
-rw-r--r-- | recipes-sota/garage-sign/garage-sign.bb | 10 |
2 files changed, 47 insertions, 2 deletions
diff --git a/lib/oeqa/selftest/garage_push.py b/lib/oeqa/selftest/garage_push.py new file mode 100644 index 0000000..3490de5 --- /dev/null +++ b/lib/oeqa/selftest/garage_push.py | |||
@@ -0,0 +1,39 @@ | |||
1 | import unittest | ||
2 | import os | ||
3 | import logging | ||
4 | |||
5 | from oeqa.selftest.base import oeSelfTest | ||
6 | from oeqa.utils.commands import runCmd, bitbake, get_bb_var | ||
7 | |||
8 | class GaragePushTests(oeSelfTest): | ||
9 | |||
10 | @classmethod | ||
11 | def setUpClass(cls): | ||
12 | # Ensure we have the right data in pkgdata | ||
13 | logger = logging.getLogger("selftest") | ||
14 | logger.info('Running bitbake to build aktualizr-native tools') | ||
15 | bitbake('aktualizr-native garage-sign-native') | ||
16 | |||
17 | def test_help(self): | ||
18 | image_dir = get_bb_var("D", "aktualizr-native") | ||
19 | bin_dir = get_bb_var("bindir", "aktualizr-native") | ||
20 | gp_path = os.path.join(image_dir, bin_dir[1:], 'garage-push') | ||
21 | result = runCmd('%s --help' % gp_path, ignore_status=True) | ||
22 | self.assertEqual(result.status, 0, "Status not equal to 0. output: %s" % result.output) | ||
23 | |||
24 | def test_java(self): | ||
25 | result = runCmd('which java', ignore_status=True) | ||
26 | self.assertEqual(result.status, 0, "Java not found.") | ||
27 | |||
28 | def test_sign(self): | ||
29 | image_dir = get_bb_var("D", "garage-sign-native") | ||
30 | bin_dir = get_bb_var("bindir", "garage-sign-native") | ||
31 | gs_path = os.path.join(image_dir, bin_dir[1:], 'garage-sign') | ||
32 | result = runCmd('%s --help' % gs_path, ignore_status=True) | ||
33 | self.assertEqual(result.status, 0, "Status not equal to 0. output: %s" % result.output) | ||
34 | |||
35 | def test_push(self): | ||
36 | bitbake('core-image-minimal') | ||
37 | self.write_config('IMAGE_INSTALL_append = " man "') | ||
38 | bitbake('core-image-minimal') | ||
39 | |||
diff --git a/recipes-sota/garage-sign/garage-sign.bb b/recipes-sota/garage-sign/garage-sign.bb index 0da35bb..ccd7299 100644 --- a/recipes-sota/garage-sign/garage-sign.bb +++ b/recipes-sota/garage-sign/garage-sign.bb | |||
@@ -12,8 +12,8 @@ SRC_URI = " \ | |||
12 | https://ats-tuf-cli-releases.s3-eu-central-1.amazonaws.com/cli-${PV}.tgz \ | 12 | https://ats-tuf-cli-releases.s3-eu-central-1.amazonaws.com/cli-${PV}.tgz \ |
13 | " | 13 | " |
14 | 14 | ||
15 | SRC_URI[md5sum] = "496ee983f03218f3e3f8d4f56c5d8d8d" | 15 | SRC_URI[md5sum] = "39941607ddef3a93476e267ad7bf6280" |
16 | SRC_URI[sha256sum] = "1ab296d7abadc40f5ad851ae62a7dff8423bd7167fa9fdc1972c88c5fe90dd40" | 16 | SRC_URI[sha256sum] = "fbd2ea56f21341146844b02837377b08e63a3e361079e2c65142c2ed881c3b5d" |
17 | 17 | ||
18 | S = "${WORKDIR}/${BPN}" | 18 | S = "${WORKDIR}/${BPN}" |
19 | 19 | ||
@@ -26,3 +26,9 @@ do_install() { | |||
26 | install -m "0644" -t ${D}${libdir} ${S}/lib/* | 26 | install -m "0644" -t ${D}${libdir} ${S}/lib/* |
27 | } | 27 | } |
28 | 28 | ||
29 | FILES_${PN} = " \ | ||
30 | /usr/bin \ | ||
31 | /usr/bin/garage-sign.bat \ | ||
32 | /usr/bin/garage-sign \ | ||
33 | /usr/lib/* \ | ||
34 | " | ||