diff options
-rw-r--r-- | classes/image_types_ostree.bbclass | 8 | ||||
-rw-r--r-- | classes/sota.bbclass | 3 | ||||
-rw-r--r-- | recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb | 2 | ||||
-rw-r--r-- | recipes-sota/aktualizr/aktualizr-device-prov.bb | 2 | ||||
-rw-r--r-- | recipes-sota/aktualizr/aktualizr-shared-prov.bb | 2 | ||||
-rw-r--r-- | recipes-sota/aktualizr/aktualizr_git.bb | 17 | ||||
-rw-r--r-- | recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb | 8 | ||||
-rw-r--r-- | recipes-support/gpgme/gpgme_%.bbappend | 1 | ||||
-rw-r--r-- | recipes-support/libssh2/libssh2_%.bbappend | 2 | ||||
-rw-r--r-- | recipes-support/lshw/files/cross-compile.patch | 39 | ||||
-rw-r--r-- | recipes-support/lshw/files/ldflags.patch | 42 | ||||
-rw-r--r-- | recipes-support/lshw/lshw_02.17.bb | 36 |
12 files changed, 22 insertions, 140 deletions
diff --git a/classes/image_types_ostree.bbclass b/classes/image_types_ostree.bbclass index 219218d..748ddd3 100644 --- a/classes/image_types_ostree.bbclass +++ b/classes/image_types_ostree.bbclass | |||
@@ -86,7 +86,7 @@ IMAGE_CMD_ostree () { | |||
86 | if [ -n "${SYSTEMD_USED}" ]; then | 86 | if [ -n "${SYSTEMD_USED}" ]; then |
87 | echo "d /var/rootdirs/${dir} 0755 root root -" >>${tmpfiles_conf} | 87 | echo "d /var/rootdirs/${dir} 0755 root root -" >>${tmpfiles_conf} |
88 | else | 88 | else |
89 | echo "mkdir -p /var/rootdirs/${dir}; chown 755 /var/rootdirs/${dir}" >>${tmpfiles_conf} | 89 | echo "mkdir -p /var/rootdirs/${dir}; chmod 755 /var/rootdirs/${dir}" >>${tmpfiles_conf} |
90 | fi | 90 | fi |
91 | ln -sf var/rootdirs/${dir} ${dir} | 91 | ln -sf var/rootdirs/${dir} ${dir} |
92 | done | 92 | done |
@@ -99,7 +99,7 @@ IMAGE_CMD_ostree () { | |||
99 | if [ -n "${SYSTEMD_USED}" ]; then | 99 | if [ -n "${SYSTEMD_USED}" ]; then |
100 | echo "d /var/roothome 0700 root root -" >>${tmpfiles_conf} | 100 | echo "d /var/roothome 0700 root root -" >>${tmpfiles_conf} |
101 | else | 101 | else |
102 | echo "mkdir -p /var/roothome; chown 700 /var/roothome" >>${tmpfiles_conf} | 102 | echo "mkdir -p /var/roothome; chmod 700 /var/roothome" >>${tmpfiles_conf} |
103 | fi | 103 | fi |
104 | 104 | ||
105 | rm -rf root | 105 | rm -rf root |
@@ -116,7 +116,7 @@ IMAGE_CMD_ostree () { | |||
116 | if [ -n "${SYSTEMD_USED}" ]; then | 116 | if [ -n "${SYSTEMD_USED}" ]; then |
117 | echo "d /var/usrlocal 0755 root root -" >>${tmpfiles_conf} | 117 | echo "d /var/usrlocal 0755 root root -" >>${tmpfiles_conf} |
118 | else | 118 | else |
119 | echo "mkdir -p /var/usrlocal; chown 755 /var/usrlocal" >>${tmpfiles_conf} | 119 | echo "mkdir -p /var/usrlocal; chmod 755 /var/usrlocal" >>${tmpfiles_conf} |
120 | fi | 120 | fi |
121 | 121 | ||
122 | dirs="bin etc games include lib man sbin share src" | 122 | dirs="bin etc games include lib man sbin share src" |
@@ -125,7 +125,7 @@ IMAGE_CMD_ostree () { | |||
125 | if [ -n "${SYSTEMD_USED}" ]; then | 125 | if [ -n "${SYSTEMD_USED}" ]; then |
126 | echo "d /var/usrlocal/${dir} 0755 root root -" >>${tmpfiles_conf} | 126 | echo "d /var/usrlocal/${dir} 0755 root root -" >>${tmpfiles_conf} |
127 | else | 127 | else |
128 | echo "mkdir -p /var/usrlocal/${dir}; chown 755 /var/usrlocal/${dir}" >>${tmpfiles_conf} | 128 | echo "mkdir -p /var/usrlocal/${dir}; chmod 755 /var/usrlocal/${dir}" >>${tmpfiles_conf} |
129 | fi | 129 | fi |
130 | done | 130 | done |
131 | 131 | ||
diff --git a/classes/sota.bbclass b/classes/sota.bbclass index fde00cd..04215ba 100644 --- a/classes/sota.bbclass +++ b/classes/sota.bbclass | |||
@@ -6,8 +6,7 @@ SOTA_HARDWARE_ID ??= "${MACHINE}" | |||
6 | 6 | ||
7 | IMAGE_CLASSES += " image_types_ostree image_types_ota image_repo_manifest" | 7 | IMAGE_CLASSES += " image_types_ostree image_types_ota image_repo_manifest" |
8 | IMAGE_INSTALL_append_sota = " aktualizr aktualizr-info ${SOTA_CLIENT_PROV} \ | 8 | IMAGE_INSTALL_append_sota = " aktualizr aktualizr-info ${SOTA_CLIENT_PROV} \ |
9 | ostree os-release ostree-kernel \ | 9 | ostree os-release ostree-kernel ostree-initramfs \ |
10 | ${@'ostree-initramfs' if d.getVar('KERNEL_IMAGETYPE') != 'fitImage' else ''} \ | ||
11 | ${@'ostree-devicetrees' if oe.types.boolean('${OSTREE_DEPLOY_DEVICETREE}') else ''}" | 10 | ${@'ostree-devicetrees' if oe.types.boolean('${OSTREE_DEPLOY_DEVICETREE}') else ''}" |
12 | 11 | ||
13 | IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', 'sota', 'ostreepush garagesign garagecheck ota-ext4 wic', ' ', d)}" | 12 | IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', 'sota', 'ostreepush garagesign garagecheck ota-ext4 wic', ' ', d)}" |
diff --git a/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb b/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb index 8f28c03..7239bfd 100644 --- a/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb +++ b/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7 | |||
7 | 7 | ||
8 | inherit allarch | 8 | inherit allarch |
9 | 9 | ||
10 | # We need to get the config files from the aktualizr-host-tools package built by | 10 | # We need to get the config files from the aktualizr-configs package built by |
11 | # the aktualizr (target) recipe. | 11 | # the aktualizr (target) recipe. |
12 | DEPENDS = "aktualizr" | 12 | DEPENDS = "aktualizr" |
13 | 13 | ||
diff --git a/recipes-sota/aktualizr/aktualizr-device-prov.bb b/recipes-sota/aktualizr/aktualizr-device-prov.bb index 55f398d..391b098 100644 --- a/recipes-sota/aktualizr/aktualizr-device-prov.bb +++ b/recipes-sota/aktualizr/aktualizr-device-prov.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7 | |||
7 | 7 | ||
8 | inherit allarch | 8 | inherit allarch |
9 | 9 | ||
10 | # We need to get the config files from the aktualizr-host-tools package built by | 10 | # We need to get the config files from the aktualizr-configs package built by |
11 | # the aktualizr (target) recipe. | 11 | # the aktualizr (target) recipe. |
12 | DEPENDS = "aktualizr" | 12 | DEPENDS = "aktualizr" |
13 | 13 | ||
diff --git a/recipes-sota/aktualizr/aktualizr-shared-prov.bb b/recipes-sota/aktualizr/aktualizr-shared-prov.bb index 0f712df..0c54f32 100644 --- a/recipes-sota/aktualizr/aktualizr-shared-prov.bb +++ b/recipes-sota/aktualizr/aktualizr-shared-prov.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7 | |||
7 | 7 | ||
8 | inherit allarch | 8 | inherit allarch |
9 | 9 | ||
10 | # We need to get the config files from the aktualizr-host-tools package built by | 10 | # We need to get the config files from the aktualizr-configs package built by |
11 | # the aktualizr (target) recipe. | 11 | # the aktualizr (target) recipe. |
12 | DEPENDS = "aktualizr" | 12 | DEPENDS = "aktualizr" |
13 | RDEPENDS_${PN}_append = "${@' aktualizr-shared-prov-creds' if oe.types.boolean(d.getVar('SOTA_DEPLOY_CREDENTIALS')) else ''}" | 13 | RDEPENDS_${PN}_append = "${@' aktualizr-shared-prov-creds' if oe.types.boolean(d.getVar('SOTA_DEPLOY_CREDENTIALS')) else ''}" |
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb index 69beb4b..c09e7cb 100644 --- a/recipes-sota/aktualizr/aktualizr_git.bb +++ b/recipes-sota/aktualizr/aktualizr_git.bb | |||
@@ -7,8 +7,7 @@ LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=815ca599c9df247a0c7f619bab123dad" | |||
7 | 7 | ||
8 | DEPENDS = "boost curl openssl libarchive libsodium sqlite3 asn1c-native" | 8 | DEPENDS = "boost curl openssl libarchive libsodium sqlite3 asn1c-native" |
9 | DEPENDS_append = "${@bb.utils.contains('PTEST_ENABLED', '1', ' coreutils-native net-tools-native ostree-native aktualizr-native ', '', d)}" | 9 | DEPENDS_append = "${@bb.utils.contains('PTEST_ENABLED', '1', ' coreutils-native net-tools-native ostree-native aktualizr-native ', '', d)}" |
10 | RDEPENDS_${PN}_class-target = "${PN}-configs ${PN}-hwid lshw" | 10 | RDEPENDS_${PN}_class-target = "${PN}-hwid lshw" |
11 | RDEPENDS_${PN}-host-tools = "aktualizr aktualizr-cert-provider ${@bb.utils.contains('PACKAGECONFIG', 'sota-tools', 'garage-deploy garage-push', '', d)}" | ||
12 | 11 | ||
13 | RDEPENDS_${PN}-ptest += "bash cmake curl net-tools python3-core python3-misc python3-modules openssl-bin sqlite3 valgrind" | 12 | RDEPENDS_${PN}-ptest += "bash cmake curl net-tools python3-core python3-misc python3-modules openssl-bin sqlite3 valgrind" |
14 | 13 | ||
@@ -17,7 +16,7 @@ PRIVATE_LIBS_${PN}-ptest = "libaktualizr.so libaktualizr_secondary.so" | |||
17 | PV = "1.0+git${SRCPV}" | 16 | PV = "1.0+git${SRCPV}" |
18 | PR = "7" | 17 | PR = "7" |
19 | 18 | ||
20 | GARAGE_SIGN_PV = "0.7.1-22-g1d0d714" | 19 | GARAGE_SIGN_PV = "0.7.2-9-g80ae114" |
21 | 20 | ||
22 | SRC_URI = " \ | 21 | SRC_URI = " \ |
23 | gitsm://github.com/advancedtelematic/aktualizr;branch=${BRANCH};name=aktualizr \ | 22 | gitsm://github.com/advancedtelematic/aktualizr;branch=${BRANCH};name=aktualizr \ |
@@ -29,10 +28,10 @@ SRC_URI = " \ | |||
29 | ${@ d.expand("https://tuf-cli-releases.ota.here.com/cli-${GARAGE_SIGN_PV}.tgz;unpack=0;name=garagesign") if not oe.types.boolean(d.getVar('GARAGE_SIGN_AUTOVERSION')) else ''} \ | 28 | ${@ d.expand("https://tuf-cli-releases.ota.here.com/cli-${GARAGE_SIGN_PV}.tgz;unpack=0;name=garagesign") if not oe.types.boolean(d.getVar('GARAGE_SIGN_AUTOVERSION')) else ''} \ |
30 | " | 29 | " |
31 | 30 | ||
32 | SRC_URI[garagesign.md5sum] = "7be214beb64ce4ae443f7a4288b6d491" | 31 | SRC_URI[garagesign.md5sum] = "2598ce3a468c40a58df3304fb71ea14b" |
33 | SRC_URI[garagesign.sha256sum] = "b8524a03bb31551889790eca4ed44070f679d33a98b09e8220d7e0e965de68d8" | 32 | SRC_URI[garagesign.sha256sum] = "acbc814a9ed962a0d3b5bc397b14fef6a139e874e6cc3075671dab69bc8541fd" |
34 | 33 | ||
35 | SRCREV = "d4811f900c765f3b4e5b9ea76531bad7d830a691" | 34 | SRCREV = "1255aa24fe55f99b606027c8acc8cd80db29a282" |
36 | BRANCH ?= "master" | 35 | BRANCH ?= "master" |
37 | 36 | ||
38 | S = "${WORKDIR}/git" | 37 | S = "${WORKDIR}/git" |
@@ -133,14 +132,12 @@ python split_hosttools_packages () { | |||
133 | bindir = d.getVar('bindir') | 132 | bindir = d.getVar('bindir') |
134 | 133 | ||
135 | # Split all binaries to their own packages. | 134 | # Split all binaries to their own packages. |
136 | do_split_packages(d, bindir, '^(.*)$', '%s', 'Aktualizr tool - %s', extra_depends='aktualizr-configs', prepend=False) | 135 | do_split_packages(d, bindir, '^(.*)$', '%s', 'Aktualizr tool - %s', extra_depends='', prepend=False) |
137 | } | 136 | } |
138 | 137 | ||
139 | PACKAGES_DYNAMIC = "^aktualizr-.* ^garage-.*" | 138 | PACKAGES_DYNAMIC = "^aktualizr-.* ^garage-.*" |
140 | 139 | ||
141 | PACKAGES =+ "${PN}-host-tools ${PN}-info ${PN}-lib ${PN}-resource-control ${PN}-configs ${PN}-secondary ${PN}-secondary-lib ${PN}-sotatools-lib" | 140 | PACKAGES =+ "${PN}-info ${PN}-lib ${PN}-resource-control ${PN}-configs ${PN}-secondary ${PN}-secondary-lib ${PN}-sotatools-lib" |
142 | |||
143 | ALLOW_EMPTY_${PN}-host-tools = "1" | ||
144 | 141 | ||
145 | FILES_${PN} = " \ | 142 | FILES_${PN} = " \ |
146 | ${bindir}/aktualizr \ | 143 | ${bindir}/aktualizr \ |
diff --git a/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb b/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb index 136bb22..94010f7 100644 --- a/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb +++ b/recipes-sota/ostree-kernel-initramfs/ostree-kernel-initramfs_0.0.1.bb | |||
@@ -36,7 +36,13 @@ do_install() { | |||
36 | 36 | ||
37 | cp ${DEPLOY_DIR_IMAGE}/${OSTREE_KERNEL} $kerneldir/vmlinuz | 37 | cp ${DEPLOY_DIR_IMAGE}/${OSTREE_KERNEL} $kerneldir/vmlinuz |
38 | 38 | ||
39 | if [ "${KERNEL_IMAGETYPE}" != "fitImage" ]; then | 39 | if [ "${KERNEL_IMAGETYPE}" = "fitImage" ]; then |
40 | if [ -n "${INITRAMFS_IMAGE}" ]; then | ||
41 | # this is a hack for ostree not to override init= in kernel cmdline - | ||
42 | # make it think that the initramfs is present (while it is in FIT image) | ||
43 | touch $kerneldir/initramfs.img | ||
44 | fi | ||
45 | else | ||
40 | if [ -n "${INITRAMFS_IMAGE}" ]; then | 46 | if [ -n "${INITRAMFS_IMAGE}" ]; then |
41 | cp ${DEPLOY_DIR_IMAGE}/${INITRAMFS_IMAGE}-${MACHINE}.${INITRAMFS_FSTYPES} $kerneldir/initramfs.img | 47 | cp ${DEPLOY_DIR_IMAGE}/${INITRAMFS_IMAGE}-${MACHINE}.${INITRAMFS_FSTYPES} $kerneldir/initramfs.img |
42 | fi | 48 | fi |
diff --git a/recipes-support/gpgme/gpgme_%.bbappend b/recipes-support/gpgme/gpgme_%.bbappend deleted file mode 100644 index fccb949..0000000 --- a/recipes-support/gpgme/gpgme_%.bbappend +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | BBCLASSEXTEND_append_sota = " native" | ||
diff --git a/recipes-support/libssh2/libssh2_%.bbappend b/recipes-support/libssh2/libssh2_%.bbappend deleted file mode 100644 index bebaf84..0000000 --- a/recipes-support/libssh2/libssh2_%.bbappend +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | # meta-oe/recipes-support/libssh2 | ||
2 | BBCLASSEXTEND_append_sota = " native" | ||
diff --git a/recipes-support/lshw/files/cross-compile.patch b/recipes-support/lshw/files/cross-compile.patch deleted file mode 100644 index 221b7e5..0000000 --- a/recipes-support/lshw/files/cross-compile.patch +++ /dev/null | |||
@@ -1,39 +0,0 @@ | |||
1 | --- | ||
2 | src/Makefile | 2 +- | ||
3 | src/core/Makefile | 2 +- | ||
4 | src/gui/Makefile | 4 ++-- | ||
5 | 3 files changed, 4 insertions(+), 4 deletions(-) | ||
6 | |||
7 | --- a/src/Makefile | ||
8 | +++ b/src/Makefile | ||
9 | @@ -18,7 +18,7 @@ export MANDIR | ||
10 | export DATADIR | ||
11 | export SQLITE | ||
12 | |||
13 | -CXX?=c++ | ||
14 | +CXX?=$(CROSS_COMPILE)c++ | ||
15 | INCLUDES=-I./core/ | ||
16 | DEFINES=-DPREFIX=\"$(PREFIX)\" -DSBINDIR=\"$(SBINDIR)\" -DMANDIR=\"$(MANDIR)\" -DDATADIR=\"$(DATADIR)\" | ||
17 | CXXFLAGS=-g -Wall -g $(INCLUDES) $(DEFINES) $(RPM_OPT_FLAGS) | ||
18 | --- a/src/core/Makefile | ||
19 | +++ b/src/core/Makefile | ||
20 | @@ -1,6 +1,6 @@ | ||
21 | PACKAGENAME?=lshw | ||
22 | |||
23 | -CXX=c++ | ||
24 | +CXX?=$(CROSS_COMPILE)c++ | ||
25 | INCLUDES= | ||
26 | DEFINES=-DPREFIX=\"$(PREFIX)\" -DSBINDIR=\"$(SBINDIR)\" -DMANDIR=\"$(MANDIR)\" -DDATADIR=\"$(DATADIR)\" | ||
27 | CXXFLAGS?=-g -Wall $(INCLUDES) $(DEFINES) $(RPM_OPT_FLAGS) | ||
28 | --- a/src/gui/Makefile | ||
29 | +++ b/src/gui/Makefile | ||
30 | @@ -1,7 +1,7 @@ | ||
31 | PACKAGENAME?=lshw | ||
32 | |||
33 | -CXX?=c++ | ||
34 | -CC?=cc | ||
35 | +CXX?=$(CROSS_COMPILE)c++ | ||
36 | +CC?=$(CROSS_COMPILE)cc | ||
37 | STRIP?=strip | ||
38 | OBJCOPY?=objcopy | ||
39 | |||
diff --git a/recipes-support/lshw/files/ldflags.patch b/recipes-support/lshw/files/ldflags.patch deleted file mode 100644 index d95699d..0000000 --- a/recipes-support/lshw/files/ldflags.patch +++ /dev/null | |||
@@ -1,42 +0,0 @@ | |||
1 | diff -Naur /home/anton/lshw-old/src/Makefile lshw-B.02.17/src/Makefile | ||
2 | --- /home/anton/lshw-old/src/Makefile 2017-02-07 16:21:52.554738182 +0100 | ||
3 | +++ lshw-B.02.17/src/Makefile 2017-02-07 16:22:45.578588072 +0100 | ||
4 | @@ -25,9 +25,9 @@ | ||
5 | ifeq ($(SQLITE), 1) | ||
6 | CXXFLAGS+= -DSQLITE $(shell pkg-config --cflags sqlite3) | ||
7 | endif | ||
8 | -LDFLAGS=-L./core/ -g | ||
9 | +LDEXTRAS=-L./core/ -g | ||
10 | ifneq ($(shell $(LD) --help 2| grep -- --as-needed), ) | ||
11 | - LDFLAGS+= -Wl,--as-needed | ||
12 | + LDEXTRAS+= -Wl,--as-needed | ||
13 | endif | ||
14 | LDSTATIC=-static | ||
15 | LIBS=-llshw -lresolv | ||
16 | @@ -37,7 +37,7 @@ | ||
17 | |||
18 | export CXXFLAGS | ||
19 | export LIBS | ||
20 | -export LDFLAGS | ||
21 | +export LDEXTRAS | ||
22 | |||
23 | DATAFILES = pci.ids usb.ids oui.txt manuf.txt | ||
24 | |||
25 | @@ -51,7 +51,7 @@ | ||
26 | +make -C core all | ||
27 | |||
28 | $(PACKAGENAME): core $(PACKAGENAME).o | ||
29 | - $(CXX) $(LDFLAGS) -o $@ $(PACKAGENAME).o $(LIBS) | ||
30 | + $(CXX) $(LDFLAGS) ${LDEXTRAS} -o $@ $(PACKAGENAME).o $(LIBS) | ||
31 | |||
32 | .PHONY: po | ||
33 | po: | ||
34 | @@ -69,7 +69,7 @@ | ||
35 | static: $(PACKAGENAME)-static | ||
36 | |||
37 | $(PACKAGENAME)-static: core core/lib$(PACKAGENAME).a $(PACKAGENAME).o | ||
38 | - $(CXX) $(LDSTATIC) $(LDFLAGS) -o $@ $(PACKAGENAME).o $(LIBS) | ||
39 | + $(CXX) $(LDSTATIC) $(LDFLAGS) ${LDEXTRAS} -o $@ $(PACKAGENAME).o $(LIBS) | ||
40 | $(STRIP) $@ | ||
41 | |||
42 | .PHONY: compressed | ||
diff --git a/recipes-support/lshw/lshw_02.17.bb b/recipes-support/lshw/lshw_02.17.bb deleted file mode 100644 index 1ecc4c1..0000000 --- a/recipes-support/lshw/lshw_02.17.bb +++ /dev/null | |||
@@ -1,36 +0,0 @@ | |||
1 | # From meta-linaro | ||
2 | # http://git.linaro.org/openembedded/meta-linaro.git | ||
3 | |||
4 | DESCRIPTION = "A small tool to provide detailed information on the hardware \ | ||
5 | configuration of the machine. It can report exact memory configuration, \ | ||
6 | firmware version, mainboard configuration, CPU version and speed, cache \ | ||
7 | configuration, bus speed, etc. on DMI-capable or EFI systems." | ||
8 | SUMMARY = "Hardware lister" | ||
9 | HOMEPAGE = "http://ezix.org/project/wiki/HardwareLiSter" | ||
10 | SECTION = "console/tools" | ||
11 | LICENSE = "GPLv2+" | ||
12 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
13 | DEPENDS = "pciutils \ | ||
14 | usbutils" | ||
15 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" | ||
16 | |||
17 | SRC_URI="http://ezix.org/software/files/lshw-B.${PV}.tar.gz \ | ||
18 | file://cross-compile.patch \ | ||
19 | file://ldflags.patch \ | ||
20 | " | ||
21 | |||
22 | SRC_URI[md5sum] = "a5feb796cb302850eaf5b4530888e3ed" | ||
23 | SRC_URI[sha256sum] = "eb9cc053fa0f1e78685cb695596e73931bfb55d2377e3bc3b8b94aff4c5a489c" | ||
24 | |||
25 | S="${WORKDIR}/lshw-B.${PV}" | ||
26 | |||
27 | do_compile() { | ||
28 | # build core only - don't ship gui | ||
29 | oe_runmake -C src core | ||
30 | } | ||
31 | |||
32 | do_install() { | ||
33 | oe_runmake install DESTDIR=${D} | ||
34 | # data files provided by dependencies | ||
35 | rm -rf ${D}/usr/share/lshw | ||
36 | } | ||