summaryrefslogtreecommitdiffstats
path: root/recipes-sota/sota-client-cpp/sota-client-cpp_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-sota/sota-client-cpp/sota-client-cpp_git.bb')
-rw-r--r--recipes-sota/sota-client-cpp/sota-client-cpp_git.bb31
1 files changed, 0 insertions, 31 deletions
diff --git a/recipes-sota/sota-client-cpp/sota-client-cpp_git.bb b/recipes-sota/sota-client-cpp/sota-client-cpp_git.bb
deleted file mode 100644
index e3c5245..0000000
--- a/recipes-sota/sota-client-cpp/sota-client-cpp_git.bb
+++ /dev/null
@@ -1,31 +0,0 @@
1SUMMARY = "SOTA Client"
2DESCRIPTION = "SOTA Client application written in C++"
3HOMEPAGE = "https://github.com/advancedtelematic/sota_client_cpp"
4SECTION = "base"
5
6LICENSE = "MPL-2.0"
7LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=9741c346eef56131163e13b9db1241b3"
8
9inherit cmake systemd
10
11S = "${WORKDIR}/git"
12
13SRCREV = "b14c668bdf914c71e68706168aa821bcae32c8f3"
14
15SRC_URI = " \
16 git://github.com/advancedtelematic/sota_client_cpp \
17 "
18
19DEPENDS = "boost curl openssl"
20RDEPENDS = ""
21
22EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release"
23
24do_install() {
25 install -d ${D}${bindir}
26 install -m 0755 ${WORKDIR}/build/target/sota_client ${D}${bindir}/sota_client_cpp
27}
28
29FILES_${PN} = " \
30 ${bindir}/sota_client_cpp \
31 "