summaryrefslogtreecommitdiffstats
path: root/recipes-sota
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-sota')
-rw-r--r--recipes-sota/garage-sign/garage-sign.bb6
-rw-r--r--recipes-sota/ostree-initrd/files/init.sh2
-rw-r--r--recipes-sota/ostree/ostree_git.bb4
3 files changed, 9 insertions, 3 deletions
diff --git a/recipes-sota/garage-sign/garage-sign.bb b/recipes-sota/garage-sign/garage-sign.bb
index 3d8c98c..ccd7299 100644
--- a/recipes-sota/garage-sign/garage-sign.bb
+++ b/recipes-sota/garage-sign/garage-sign.bb
@@ -26,3 +26,9 @@ do_install() {
26 install -m "0644" -t ${D}${libdir} ${S}/lib/* 26 install -m "0644" -t ${D}${libdir} ${S}/lib/*
27} 27}
28 28
29FILES_${PN} = " \
30 /usr/bin \
31 /usr/bin/garage-sign.bat \
32 /usr/bin/garage-sign \
33 /usr/lib/* \
34 "
diff --git a/recipes-sota/ostree-initrd/files/init.sh b/recipes-sota/ostree-initrd/files/init.sh
index 0b0693d..d7e0429 100644
--- a/recipes-sota/ostree-initrd/files/init.sh
+++ b/recipes-sota/ostree-initrd/files/init.sh
@@ -67,7 +67,7 @@ ostree-prepare-root /sysroot
67 67
68# move mounted devices to new root 68# move mounted devices to new root
69cd /sysroot 69cd /sysroot
70for x in dev proc; do 70for x in dev proc run; do
71 log_info "Moving /$x to new rootfs" 71 log_info "Moving /$x to new rootfs"
72 mount -o move "/$x" "$x" 72 mount -o move "/$x" "$x"
73done 73done
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb
index 7a0320e..724976a 100644
--- a/recipes-sota/ostree/ostree_git.bb
+++ b/recipes-sota/ostree/ostree_git.bb
@@ -8,9 +8,9 @@ INHERIT_remove_class-native = "systemd"
8 8
9SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master" 9SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master"
10 10
11SRCREV="e3c3ec5dd91492e82c79223052443d038c60f41c" 11SRCREV="ae61321046ad7f4148a5884c8c6c8b2594ff840e"
12 12
13PV = "v2017.11-20-ge3c3ec5d" 13PV = "v2017.13"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16