diff options
author | Doug Goldstein <cardoe@cardoe.com> | 2016-01-26 13:09:24 -0600 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2016-02-01 15:32:50 -0500 |
commit | 005cdc9fcffce179f18c1c44cc72240d810b489b (patch) | |
tree | d108ceec6b90dd3808b510d5bc640b5ef4917f27 | |
parent | aa17f6817051985b298d489220f5c3ee4946763d (diff) | |
download | meta-virtualization-005cdc9fcffce179f18c1c44cc72240d810b489b.tar.gz |
xen: don't inject -mfpmath=sse which causes build issues
Don't inject -mfpmath=sse into the build which causes issues with the
hypervisor build.
Signed-off-by: Doug Goldstein <cardoe@cardoe.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r-- | recipes-extended/xen/files/xen-x86-Fix-up-rules-when-forcing-mno-sse.patch | 28 | ||||
-rw-r--r-- | recipes-extended/xen/xen.inc | 5 | ||||
-rw-r--r-- | recipes-extended/xen/xen_4.6.0.bb | 1 |
3 files changed, 5 insertions, 29 deletions
diff --git a/recipes-extended/xen/files/xen-x86-Fix-up-rules-when-forcing-mno-sse.patch b/recipes-extended/xen/files/xen-x86-Fix-up-rules-when-forcing-mno-sse.patch deleted file mode 100644 index 4c3e297f..00000000 --- a/recipes-extended/xen/files/xen-x86-Fix-up-rules-when-forcing-mno-sse.patch +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | From: Nathan Rossi <nathan.rossi@xilinx.com> | ||
2 | Subject: [PATCH] xen/x86: Fix up rules when forcing -mno-sse | ||
3 | |||
4 | * When forcing -mno-sse specify -mfpmath=387 to avoid the fallback | ||
5 | warning | ||
6 | |||
7 | Signed-off-by: Nathan Rossi <nathan.rossi@xilinx.com> | ||
8 | Upstream-Status: Not-Submitted | ||
9 | --- | ||
10 | xen/arch/x86/Rules.mk | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/xen/arch/x86/Rules.mk b/xen/arch/x86/Rules.mk | ||
14 | index 6775cb5..03848f7 100644 | ||
15 | --- a/xen/arch/x86/Rules.mk | ||
16 | +++ b/xen/arch/x86/Rules.mk | ||
17 | @@ -42,7 +42,7 @@ x86 := y | ||
18 | x86_32 := n | ||
19 | x86_64 := y | ||
20 | |||
21 | -CFLAGS += -mno-red-zone -mno-sse -fpic | ||
22 | +CFLAGS += -mno-red-zone -mno-sse -fpic -mfpmath=387 | ||
23 | CFLAGS += -fno-asynchronous-unwind-tables | ||
24 | # -fvisibility=hidden reduces -fpic cost, if it's available | ||
25 | ifneq ($(call cc-option,$(CC),-fvisibility=hidden,n),n) | ||
26 | -- | ||
27 | 2.1.1 | ||
28 | |||
diff --git a/recipes-extended/xen/xen.inc b/recipes-extended/xen/xen.inc index f937b05d..5555ed32 100644 --- a/recipes-extended/xen/xen.inc +++ b/recipes-extended/xen/xen.inc | |||
@@ -713,6 +713,11 @@ export CROSS_COMPILE="${TARGET_PREFIX}" | |||
713 | # overide LDFLAGS to allow xen to build without: "x86_64-oe-linux-ld: unrecognized option '-Wl,-O1'" | 713 | # overide LDFLAGS to allow xen to build without: "x86_64-oe-linux-ld: unrecognized option '-Wl,-O1'" |
714 | export LDFLAGS="" | 714 | export LDFLAGS="" |
715 | 715 | ||
716 | # Yocto injects -mfpmath=sse for some machine types into the CFLAGS which | ||
717 | # conflicts with -mno-sse so instead we strip -mfpmath=sse instead of | ||
718 | # patching the build to be ok with this | ||
719 | TUNE_CCARGS := "${@oe_filter_out('-mfpmath=sse', '${TUNE_CCARGS}', d)}" | ||
720 | |||
716 | EXTRA_OECONF += " \ | 721 | EXTRA_OECONF += " \ |
717 | --exec-prefix=/usr \ | 722 | --exec-prefix=/usr \ |
718 | --prefix=/usr \ | 723 | --prefix=/usr \ |
diff --git a/recipes-extended/xen/xen_4.6.0.bb b/recipes-extended/xen/xen_4.6.0.bb index 0391dbd8..41241cd4 100644 --- a/recipes-extended/xen/xen_4.6.0.bb +++ b/recipes-extended/xen/xen_4.6.0.bb | |||
@@ -2,7 +2,6 @@ require xen.inc | |||
2 | 2 | ||
3 | SRC_URI = " \ | 3 | SRC_URI = " \ |
4 | http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz \ | 4 | http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz \ |
5 | file://xen-x86-Fix-up-rules-when-forcing-mno-sse.patch \ | ||
6 | " | 5 | " |
7 | 6 | ||
8 | SRC_URI[md5sum] = "48e232f90927c08326a7b52bb06f49bc" | 7 | SRC_URI[md5sum] = "48e232f90927c08326a7b52bb06f49bc" |