diff options
-rw-r--r-- | recipes-devtools/yq/yq_git.bb | 16 |
1 files changed, 1 insertions, 15 deletions
diff --git a/recipes-devtools/yq/yq_git.bb b/recipes-devtools/yq/yq_git.bb index 9682ec95..363769b9 100644 --- a/recipes-devtools/yq/yq_git.bb +++ b/recipes-devtools/yq/yq_git.bb | |||
@@ -84,24 +84,10 @@ SRC_URI += "git://github.com/inconshreveable/mousetrap;name=mousetrap;protocol=h | |||
84 | PV = "4.45.1+git" | 84 | PV = "4.45.1+git" |
85 | 85 | ||
86 | GO_IMPORT = "github.com/mikefarah/yq" | 86 | GO_IMPORT = "github.com/mikefarah/yq" |
87 | export GO111MODULE = "off" | ||
87 | 88 | ||
88 | inherit go ptest | 89 | inherit go ptest |
89 | 90 | ||
90 | do_compile:prepend() { | ||
91 | # arrange for some of the golang built ins to be found | ||
92 | ( | ||
93 | cd ${WORKDIR}/build/src/ | ||
94 | ln -sf ${STAGING_DIR_TARGET}/${prefix}/lib/go/src/cmd/vendor/golang.org . | ||
95 | |||
96 | cd ${WORKDIR}/build/ | ||
97 | ln -sf ${UNPACKDIR}/build/vendor . | ||
98 | ) | ||
99 | |||
100 | # arrange for the fetched dependencies to be found | ||
101 | export GOPATH="${GOPATH}:${WORKDIR}/build/vendor/" | ||
102 | export GO111MODULE=off | ||
103 | } | ||
104 | |||
105 | do_install_ptest() { | 91 | do_install_ptest() { |
106 | install -d ${D}${PTEST_PATH}/tests | 92 | install -d ${D}${PTEST_PATH}/tests |
107 | cp -r ${S}/src/${GO_IMPORT}/scripts/* ${D}${PTEST_PATH}/tests | 93 | cp -r ${S}/src/${GO_IMPORT}/scripts/* ${D}${PTEST_PATH}/tests |